SOLVED

Cannot open Teams, "This app can't run on your PC"

%3CLINGO-SUB%20id%3D%22lingo-sub-2165865%22%20slang%3D%22en-US%22%3ECannot%20open%20Teams%2C%20%22This%20app%20can't%20run%20on%20your%20PC%22%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2165865%22%20slang%3D%22en-US%22%3E%3CP%3EI%20have%20had%20two%20users%20now%20that%20get%20this%20error%20message%20when%20trying%20to%20open%20Teams.%20We%20have%20had%20teams%20installed%20on%20our%20machines%20for%20over%20a%20year%20now%2C%20and%20within%20the%20same%20month%20both%20users%20have%20experienced%20this%20issue.%3C%2FP%3E%3CDIV%20class%3D%22mceNonEditable%20lia-copypaste-placeholder%22%3E%26nbsp%3B%3C%2FDIV%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22download.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F257854iED2230A009328891%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20role%3D%22button%22%20title%3D%22download.png%22%20alt%3D%22download.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20fixed%20it%20for%20both%20users%20temporarily%20by%20completely%20uninstalling%20Office%20365%20and%20reinstalling.%20But%20for%20one%20user%20the%20issue%20has%20reappeared%2C%20so%20obviously%20that%20isn't%20the%20correct%20answer.%20What's%20really%20strange%20is%20if%20the%20user%20clicks%20on%20a%20Teams%20link%20in%20an%20email%20or%20tries%20to%20open%20Teams%20through%20the%20system%20tray%20it%20opens%20just%20fine%2C%20but%20if%20he%20tries%20to%20open%20it%20normally%20from%20the%20start%20menu%2C%20a%20desktop%20icon%2C%20or%20from%20the%20taskbar%20he%20gets%20the%20error.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI'm%20not%20sure%20what%20else%20to%20do.%20User%20is%20on%20Windows%2010%2064%20bit%20running%20the%2064%20bit%20version%20of%20Teams.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-2165865%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EMicrosoft%20Teams%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
New Contributor

I have had two users now that get this error message when trying to open Teams. We have had teams installed on our machines for over a year now, and within the same month both users have experienced this issue.

 

download.png

 

I have fixed it for both users temporarily by completely uninstalling Office 365 and reinstalling. But for one user the issue has reappeared, so obviously that isn't the correct answer. What's really strange is if the user clicks on a Teams link in an email or tries to open Teams through the system tray it opens just fine, but if he tries to open it normally from the start menu, a desktop icon, or from the taskbar he gets the error.

 

I'm not sure what else to do. User is on Windows 10 64 bit running the 64 bit version of Teams.

5 Replies
best response confirmed by ThereseSolimeno (Microsoft)
Solution

@jweiskittel 

 

I had the same issue after checking for and installing a Teams update. It seems like the update uninstalled Teams but left the shortcuts. Go to Add/Remove programs ( or run appwiz.cpl) and uninstall Teams, then download it and reinstall. 

 

Download link https://www.microsoft.com/en-us/microsoft-teams/download-app 

 

@jweiskittel 

This is plaguing my org at the moment as well. My ServiceDesk has had like 10 calls just this morning for staff that are experiencing this issue.

A re-install of the software resolves it but I'm nowhere near finding a root cause. And doing that for hundreds of staff every day is not feasible.

One thing I have noticed, on the affected machines:

C:\Users\%user%\AppData\Local\Microsoft\Teams\Update.exe file size is 0Kb while in this broken state.

 

Did you get any closer to a resolution?

 

 

 

@MosJef We still haven't discovered the root cause, but it has happened again to the same user, as well as with new ones. We think it may somehow be related to the shortcuts on the desktop/taskbar/start menu. This time we did a full uninstall of Office, deleted all Teams folders, and deleted all shortcuts where I mentioned above. So far so good, but I'm just waiting for it to break again.
@MosJef I did find another way to fix that may help you. I encountered some weird things when trying to fix this for yet another user. When I tried to reinstall Teams it was not installing properly and would always require admin credentials to open. I found documentation from Microsoft on how to correctly fully uninstall Teams. You must uninstall the Teams app, as well as the Teams Machine-Wide Installer. I then deleted all remaining Teams files and folders from the machine in the following locations:
%localappdata%\SquirrelTemp
%localappdata%\Microsoft\Teams
%localappdata%\Microsoft\TeamsMeetingAddin
%localappdata%\Microsoft\TeamsPresenceAddin
%appdata%\Teams
C:\Program Files
C:\Program Files (x86)

Once those were wiped out, I found an MSI installer here: https://docs.microsoft.com/en-us/MicrosoftTeams/msi-deployment

Running this installs the Machine-Wide Installer and creates a folder at C:\Program Files (x86)\Teams Installer. Run the Teams.exe inside that folder and you should be good to go.
Just happened to me.

The error seemed to come from the shortcut and the newer "apps and features" shortcut, which did not detect that it was already uninstalled. The older control panel did detect that it was already uninstalled.

For me, simply downloading and installing again worked, plus when it started it indicated I have the latest update. I'll try your solution if it happens again.