Cannot log into teams enabled phone

%3CLINGO-SUB%20id%3D%22lingo-sub-2526432%22%20slang%3D%22en-US%22%3ECannot%20log%20into%20teams%20enable%20phone%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2526432%22%20slang%3D%22en-US%22%3E%3CP%3EWe%20are%20getting%20this%20issue%20where%20a%20user%20with%20a%20common%20area%20license%20can%20log%20into%20a%20Yealink%20MP56%20Teams%20enabled%20phone%20with%20little%20to%20no%20issues.%3C%2FP%3E%3CP%3EIf%20we%20try%20and%20log%20in%20a%20user%20with%20a%20phone%20system%20license%20we%20get%20the%20error%20%22Something%20went%20wrong.%20Let%E2%80%99s%20try%20again%22%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20pulled%20the%20logs%20from%20the%20device%20and%20noted%20these%20-%3C%2FP%3E%3CP%3E%26lt%3B132%26gt%3BJul%208%2009%3A45%3A42%20GUI%20%5B892%3A950%5D%3A%20ANDR%26lt%3B4%2Bwarnin%26gt%3B%202159%202159%20W%20ActivityThread%3A%20handleWindowVisibility%3A%20no%20activity%20for%20token%20android.os.BinderProxy%40cf8c00a%3CBR%20%2F%3E%26lt%3B134%26gt%3BJul%208%2009%3A45%3A42%20GUI%20%5B892%3A950%5D%3A%20ANDR%26lt%3B6%2Binfo%20%26gt%3B%201202%201230%20D%20GotoHomeHelper%3A%20onResumeUpdate%20com.microsoft.windowsintune.companyportal%3CBR%20%2F%3E%26lt%3B134%26gt%3BJul%208%2009%3A45%3A42%20GUI%20%5B892%3A950%5D%3A%20ANDR%26lt%3B6%2Binfo%20%26gt%3B%201202%201221%20D%20ApplicationObserver%3A%20onResumeUpdate%3A%20com.microsoft.windowsintune.companyportal%3CBR%20%2F%3E%26lt%3B134%26gt%3BJul%208%2009%3A45%3A42%20GUI%20%5B892%3A950%5D%3A%20ANDR%26lt%3B6%2Binfo%20%26gt%3B%202159%202159%20I%20am_on_create_called%3A%20%5B0%2Ccom.microsoft.windowsintune.companyportal.views.DismissAppActivity%2CperformCreate%5D%3CBR%20%2F%3E%26lt%3B134%26gt%3BJul%208%2009%3A45%3A42%20GUI%20%5B892%3A950%5D%3A%20ANDR%26lt%3B6%2Binfo%20%26gt%3B%20981%201016%20I%20sysui_count%3A%20%5Bwindow_time_0%2C0%5D%3CBR%20%2F%3E%26lt%3B134%26gt%3BJul%208%2009%3A45%3A42%20GUI%20%5B892%3A950%5D%3A%20ANDR%26lt%3B6%2Binfo%20%26gt%3B%20981%201016%20I%20sysui_multi_action%3A%20%5B757%2C803%2C799%2Cwindow_time_0%2C802%2C0%5D%3CBR%20%2F%3E%26lt%3B134%26gt%3BJul%208%2009%3A45%3A42%20GUI%20%5B892%3A950%5D%3A%20ANDR%26lt%3B6%2Binfo%20%26gt%3B%202159%202159%20D%20YLSystemConfigs%3A%20getKeyPackagesList%20key%20%3A%20features.request_feature_no_title_packages%2C%20package%20%3A%20com.microsoft.skype.teams.ipphone%3CBR%20%2F%3E%26lt%3B134%26gt%3BJul%208%2009%3A45%3A42%20GUI%20%5B892%3A950%5D%3A%20ANDR%26lt%3B6%2Binfo%20%26gt%3B%202159%202159%20I%20am_on_start_called%3A%20%5B0%2Ccom.microsoft.windowsintune.companyportal.views.DismissAppActivity%2ChandleStartActivity%5D%3CBR%20%2F%3E%26lt%3B131%26gt%3BJul%208%2009%3A45%3A42%20GUI%20%5B892%3A950%5D%3A%20ANDR%26lt%3B3%2Berror%20%26gt%3B%201642%201642%20E%20EnrollmentProcessor%3A%20ProcessId%3A%201642%2C%20Thread%3A%20main%2C%20Loading%20Welcome%20Activity%20with%20failure%20message%20Something%20went%20wrong.%20Let%E2%80%99s%20try%20again.%2C%20reasonCode%202%2C%20failureReason%205%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20can%20also%20see%20in%20Azure%20Active%20Directory%26nbsp%3B%3C%2FP%3E%3CDIV%20class%3D%22fxc-weave-pccontrol%20fxc-section-control%20fxc-base%20msportalfx-customHtml%20msportalfx-form-formelement%20fxc-has-label%20fxc-left-label%22%3E%3CDIV%20class%3D%22azc-form-labelcontainer%20azc-text-label%22%3ESign-in%20error%20code%3C%2FDIV%3E%3CDIV%20class%3D%22azc-formElementSubLabelContainer%22%3E%3CDIV%20class%3D%22azc-formElementContainer%22%3E%3CDIV%3E50199%3C%2FDIV%3E%3C%2FDIV%3E%3C%2FDIV%3E%3C%2FDIV%3E%3CDIV%20class%3D%22fxc-weave-pccontrol%20fxc-section-control%20fxc-base%20msportalfx-customHtml%20msportalfx-form-formelement%20fxc-has-label%20fxc-left-label%22%3E%3CDIV%20class%3D%22azc-form-labelcontainer%20azc-text-label%22%3EFailure%20reason%3C%2FDIV%3E%3CDIV%20class%3D%22azc-formElementSubLabelContainer%22%3E%3CDIV%20class%3D%22azc-formElementContainer%22%3E%3CDIV%3EFor%20security%20reasons%2C%20user%20confirmation%20is%20required%20for%20this%20request.%20Please%20repeat%20the%20request%20allowing%20user%20interaction.%3C%2FDIV%3E%3CDIV%3E%26nbsp%3B%3C%2FDIV%3E%3CDIV%3EWe%20have%20enabled%20the%20recommended%20ports%20and%20whitelisted%20the%20IP%20addresses.%3C%2FDIV%3E%3CDIV%3EPhones%20have%20the%20most%20current%20firmware%20and%20teams%20app.%3C%2FDIV%3E%3CDIV%3EAny%20suggestions%20on%20how%20to%20resolve%20the%20issue%20will%20be%20greatly%20appreciated.%3C%2FDIV%3E%3C%2FDIV%3E%3C%2FDIV%3E%3C%2FDIV%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-2526432%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EAdministrator%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EMicrosoft%20Teams%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESettings%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2526451%22%20slang%3D%22en-US%22%3ERe%3A%20Cannot%20log%20into%20teams%20enable%20phone%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2526451%22%20slang%3D%22en-US%22%3EThat%20is%20an%20MFA%20error%20I%20believe.%20If%20you%20disable%20MFA%20on%20the%20account%20does%20it%20work%3F%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2526489%22%20slang%3D%22en-US%22%3ERe%3A%20Cannot%20log%20into%20teams%20enable%20phone%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2526489%22%20slang%3D%22en-US%22%3EMFA%20is%20not%20invoked%20because%20it%20is%20connected%20to%20the%20corp%20network.%3C%2FLINGO-BODY%3E
Occasional Contributor

We are getting this issue where a user with a common area license can log into a Yealink MP56 Teams enabled phone with little to no issues.

If we try and log in a user with a phone system license we get the error "Something went wrong. Let’s try again"

 

I pulled the logs from the device and noted these -

<132>Jul 8 09:45:42 GUI [892:950]: ANDR<4+warnin> 2159 2159 W ActivityThread: handleWindowVisibility: no activity for token android.os.BinderProxy@cf8c00a
<134>Jul 8 09:45:42 GUI [892:950]: ANDR<6+info > 1202 1230 D GotoHomeHelper: onResumeUpdate com.microsoft.windowsintune.companyportal
<134>Jul 8 09:45:42 GUI [892:950]: ANDR<6+info > 1202 1221 D ApplicationObserver: onResumeUpdate: com.microsoft.windowsintune.companyportal
<134>Jul 8 09:45:42 GUI [892:950]: ANDR<6+info > 2159 2159 I am_on_create_called: [0,com.microsoft.windowsintune.companyportal.views.DismissAppActivity,performCreate]
<134>Jul 8 09:45:42 GUI [892:950]: ANDR<6+info > 981 1016 I sysui_count: [window_time_0,0]
<134>Jul 8 09:45:42 GUI [892:950]: ANDR<6+info > 981 1016 I sysui_multi_action: [757,803,799,window_time_0,802,0]
<134>Jul 8 09:45:42 GUI [892:950]: ANDR<6+info > 2159 2159 D YLSystemConfigs: getKeyPackagesList key : features.request_feature_no_title_packages, package : com.microsoft.skype.teams.ipphone
<134>Jul 8 09:45:42 GUI [892:950]: ANDR<6+info > 2159 2159 I am_on_start_called: [0,com.microsoft.windowsintune.companyportal.views.DismissAppActivity,handleStartActivity]
<131>Jul 8 09:45:42 GUI [892:950]: ANDR<3+error > 1642 1642 E EnrollmentProcessor: ProcessId: 1642, Thread: main, Loading Welcome Activity with failure message Something went wrong. Let’s try again., reasonCode 2, failureReason 5

 

I can also see in Azure Active Directory 

Sign-in error code
50199
Failure reason
For security reasons, user confirmation is required for this request. Please repeat the request allowing user interaction.
 
We have enabled the recommended ports and whitelisted the IP addresses.
Phones have the most current firmware and teams app.
Any suggestions on how to resolve the issue will be greatly appreciated.
7 Replies
That is an MFA error I believe. If you disable MFA on the account does it work?
MFA is not invoked because it is connected to the corp network.
Thanks, I already have read that one. We already have installed the latest firmware - 122.15.0.44. It only fixed the common area license accounts and not the phone system license accounts.

@Keliath I am having the same error with a Poly CCX500.  Did you happen to get this resolved?

It was our firewall blocking the teams ports. Test your Poly CCX500 on an open network and if you are able to sign in, then it is most likely firewall blocking ports.
Sorry I also forgot to mention, I changed the SNTP Server and Alternate SNTP Server by navigating to the Poly URL. Once I did that, I was able to log in on our corp network.