SOLVED

Cannot get email address - we're still setting up your team

%3CLINGO-SUB%20id%3D%22lingo-sub-103165%22%20slang%3D%22en-US%22%3ECannot%20get%20email%20address%20-%20we're%20still%20setting%20up%20your%20team%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-103165%22%20slang%3D%22en-US%22%3E%3CP%3EIn%20Microsoft%20Teams%20client%20(web%20or%20desktop)%20I%20go%20to%20Get%20email%20address%20on%20a%20channel%20and%20get%20the%20following%20error%20message%3A%20We're%20still%20setting%20up%20your%20team%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EMailbox%20for%20the%20team%20is%20created%20and%20it%20can%20receive%20mails%20alright.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20team%20was%20created%20a%20week%20ago%20(actually%20a%20migration%20of%20an%20existing%20O365%20group)%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSTRONG%3EUPDATE%202017-09-06%3C%2FSTRONG%3E%3C%2FP%3E%3CP%3EActually%20figuered%20out%20my%20issue%20today%20-%20the%20SMTP%20address%20was%20set%20to%20an%20incorrect%20value%20(e.g.%20the%20group%20alias%20instead%20of%20the%20full%20e-mail%20address)%20when%20migrating%20the%20O365%20group%20to%20a%20team.%20I%20could%20not%20find%20a%20way%20to%20recover%20from%20this%20scenario%2C%20e.g.%20setting%20the%20PrimarySmtpAddress%20on%20the%20O365%20group%20does%20not%20help.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-103165%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EMicrosoft%20Teams%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-103347%22%20slang%3D%22en-US%22%3ERe%3A%20Cannot%20get%20email%20address%20-%20we're%20still%20setting%20up%20your%20team%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-103347%22%20slang%3D%22en-US%22%3E%3CP%3ESame%20issue%20for%20all%20channels%20in%20migrated%20groups.%20When%20I%20create%20a%20Team%20via%20Teams%20Client%20(and%20NOT%20migrate%20an%20existing%20group)%20in%20the%20same%20tenant%20the%20Get%20email%20address%20link%20works%20as%20expected.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-103266%22%20slang%3D%22en-US%22%3ERe%3A%20Cannot%20get%20email%20address%20-%20we're%20still%20setting%20up%20your%20team%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-103266%22%20slang%3D%22en-US%22%3E%3CP%3EI've%20seen%20this%20get%20stuck.%20Log%20a%20support%20ticket%20to%20get%20the%20Microsoft%20engineers%20to%20look%20at%20it.%20It's%20something%20that%20only%20they%20can%20fix.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-103174%22%20slang%3D%22en-US%22%3ERe%3A%20Cannot%20get%20email%20address%20-%20we're%20still%20setting%20up%20your%20team%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-103174%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20Bernd%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Eis%20only%20this%20channel%20experiencing%20these%20difficulties%20or%20do%20other%20channels%20in%20other%20Teams%20also%20malfunction%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1504999%22%20slang%3D%22en-US%22%3ERe%3A%20Cannot%20get%20email%20address%20-%20we're%20still%20setting%20up%20your%20team%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1504999%22%20slang%3D%22en-US%22%3E%3CP%3EI%20just%20experienced%20this%20now.%20I%20can%20see%20that%20your%20post%20is%20a%20few%20years%20old%2C%20so%20it%20is%20trange%20they%20haven%C2%B4t%20been%20able%20to%20avoid%20this.%20I%20just%20created%20a%20team%20in%20the%20same%20way%20as%20I%20always%20do%2C%20by%20copying%20another%20team.%20I%20have%20created%20a%20team%20that%20I%20copy%20when%20ever%20I%20need%20a%20new%20one%2C%20so%20they%20should%20all%20be%20set%20up%20the%20same.%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F71570%22%20target%3D%22_blank%22%3E%40Carsten%20B%C3%BCttemeier%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Contributor

In Microsoft Teams client (web or desktop) I go to Get email address on a channel and get the following error message: We're still setting up your team

 

Mailbox for the team is created and it can receive mails alright.

 

The team was created a week ago (actually a migration of an existing O365 group)

 

UPDATE 2017-09-06

Actually figuered out my issue today - the SMTP address was set to an incorrect value (e.g. the group alias instead of the full e-mail address) when migrating the O365 group to a team. I could not find a way to recover from this scenario, e.g. setting the PrimarySmtpAddress on the O365 group does not help.

5 Replies

Hi Bernd,

 

is only this channel experiencing these difficulties or do other channels in other Teams also malfunction?

 

 

Best Response confirmed by Bernd Rickenberg (Occasional Contributor)
Solution

I've seen this get stuck. Log a support ticket to get the Microsoft engineers to look at it. It's something that only they can fix.

Same issue for all channels in migrated groups. When I create a Team via Teams Client (and NOT migrate an existing group) in the same tenant the Get email address link works as expected.

I just experienced this now. I can see that your post is a few years old, so it is trange they haven´t been able to avoid this. I just created a team in the same way as I always do, by copying another team. I have created a team that I copy when ever I need a new one, so they should all be set up the same.@Carsten Büttemeier 

I know this is an old thread, but just in case it helps anyone else out there - I just created a new Team and had the exact same issue.  3 days later and still getting the same error.

 

I figured it was caused by me renaming the channels after creating them (all the channels I didn't rename seemed to work ok).  Here's the solution:

 

Rename the affected channel again, eg. Channel1_archived (Note: Avoiding this step will mean you can't recreate the channel with the correct name).

Delete the renamed channel.

Re-create the channel with the correct name.

 

And all is well in the world - I can now email the channels.