Cannot create an account - "you're not on teams yet | You can't sign in here with a personal acc..."

Occasional Visitor



I've been trying to create an account and use the free MS teams.

I was able to sign up with my personal email and received an email with the headline:

Thanks for signing up for Microsoft Teams

But when I try to use it within the app, after logging in, the message "You're not on Teams yet, but you can set it up for your organization." is shown.

Whenever I try to sign up again, in the standard white login page the message "Thanks for signing up for Microsoft Teams" appears.


I've tried as well creating a new email, but the last message is shown once more.


How can I proceed with this?


Thank you,

7 Replies
Can You try sign in from another browser or from an inprivate browser session!
It’s common that cached credentials messes up login experiences

Hi @sergio-pb , 


This is a bug and there is a work around for now, but a fix is coming as it's a known issue. Please see my reply here for work around:




Hi Sergio-pb,


I have the exact same problem. I am using MS-Teams on my MacBook Pro and it worked before with my private Microsoft account. I was wondering whether Microsoft changed its policy or whether it is the typical Mac compatibility problem, but I am using the actual desktop app for Mac.

When you follow the sign up instruction, do you also get the message "switch to Skype"?


Kind regards



best response confirmed by ThereseSolimeno (Microsoft)

Hello @FL_28   This is a common question, so I did a quick search of the community and found other posts with a similar theme.  This one should answer the question:

I think I have the same problem. I have just left school, where I used teams linked to the schools email account, and am about to start college. The college have set me a link to attend a meeting to my personal email account. When I try to sign in using this account it tells me that I cannot use my personal email. I uninstalled Teams an clicked the meeting link again and downloaded a fresh version of the app. Now I can join the meeting as a guest but have no access to calendars etc. I I try and get 'A better experience by signing in' a new page opens but returns to the front page after a few minutes. What is going wrong?