Cannot Configure Yammer App - groups not appearing in search results

%3CLINGO-SUB%20id%3D%22lingo-sub-808312%22%20slang%3D%22en-US%22%3ECannot%20Configure%20Yammer%20App%20-%20groups%20not%20appearing%20in%20search%20results%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-808312%22%20slang%3D%22en-US%22%3E%3CP%3EAs%20the%20title%20says%2C%20I%20have%20been%20trying%20to%20add%20the%20Yammer%20app%20to%20one%20of%20my%20channels%20but%20I%20cannot%20configure%20it%20to%20any%20of%20my%20groups.%26nbsp%3B%20Nothing%20appears%20in%20the%20search%20results%20from%20my%20(external)%20network%2C%20and%20the%20UI%20and%20%3CA%20href%3D%22https%3A%2F%2Fsupport.office.com%2Fen-us%2Farticle%2Fadd-a-yammer-page-to-a-channel-in-teams-9fdca2b6-f03f-4632-87d1-e83b87b458b2%3Fui%3Den-US%26amp%3Brs%3Den-US%26amp%3Bad%3DUS%22%20target%3D%22_self%22%20rel%3D%22noopener%20noreferrer%22%3Ehelp%20guide%3C%2FA%3Eisn't%20giving%20me%20any%20helpful%20information%20on%20what%20I%20should%20do%20next.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F127260iA26D9AF842FE16DA%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20alt%3D%22clipboard_image_0.png%22%20title%3D%22clipboard_image_0.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20next%20thing%20I%20tried%20was%20to%20configure%20the%20connector%20instead.%26nbsp%3B%20This%20time%20I%20got%20a%20more%20helpful%20message%20stating%20that%20I'm%20not%20a%20member%20of%20any%20public%20channels%2C%20even%20though%20i%20created%20one%20less%20than%20an%20hour%20ago%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F127261i35D0D3F1D25B2A2E%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20alt%3D%22clipboard_image_1.png%22%20title%3D%22clipboard_image_1.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ESo%20I've%20hit%20a%20wall%20and%20I'm%20not%20sure%20what%20I'm%20doing%20wrong.%26nbsp%3B%20I%20even%20tried%20re-installing%20the%20Yammer%20app%2C%20but%20that%20didn't%20make%20a%20difference.%26nbsp%3B%26nbsp%3B%26nbsp%3B%20Has%20anyone%20had%20this%20issue%20before%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-808312%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EApps%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EMicrosoft%20Teams%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESettings%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EYammer%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-821188%22%20slang%3D%22en-US%22%3ERe%3A%20Cannot%20Configure%20Yammer%20App%20-%20groups%20not%20appearing%20in%20search%20results%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-821188%22%20slang%3D%22en-US%22%3EDid%20you%20try%20this%20also%20in%20a%20browser%2C%20so%20that%20you%20have%20also%20Yammer%20tab%20open%3F%20(Authentication..)%3CBR%20%2F%3EAlso%2C%20I%20noticed%20you%20mentioned%20external%20network.%20Try%20these%20first%20in%20your%20home%20network.%20Do%20you%20have%20public%20groups%20there%3F%3C%2FLINGO-BODY%3E
Frequent Contributor

As the title says, I have been trying to add the Yammer app to one of my channels but I cannot configure it to any of my groups.  Nothing appears in the search results from my (external) network, and the UI and help guide isn't giving me any helpful information on what I should do next.

 

clipboard_image_0.png

 

The next thing I tried was to configure the connector instead.  This time I got a more helpful message stating that I'm not a member of any public channels, even though i created one less than an hour ago:

 

clipboard_image_1.png

 

So I've hit a wall and I'm not sure what I'm doing wrong.  I even tried re-installing the Yammer app, but that didn't make a difference.    Has anyone had this issue before?

2 Replies
Did you try this also in a browser, so that you have also Yammer tab open? (Authentication..)
Also, I noticed you mentioned external network. Try these first in your home network. Do you have public groups there?

@AlexH980 In the left pane there is a gear/settings icon.  Click on that for the drop-down menu.  Towards the bottom will appear your top-level groups.

 

Yes, this is an odd UI choice and different than the web app.  It took me a while to find it.