Cannot assign phone number in Teams

Contributor

When trying to assign a phone number using the command Set-CsUser -Identity "username@domain.com" -EnterpriseVoiceEnabled $true -HostedVoiceMail $true -OnPremLineURI "tel:+........." in PowerShell the following error message is comming:

"There seems to be a problem with the provided SIP address. Use a SIP address that contains only standard characters, e.g. sip: username@contoso.com".

 

The SIP address is in format SIP:username@contoso.com, but I don't think, that small or capital letters make any difference.

 

I ran the command Get-CsOnlineUser in PowerShell ande received the following MCOValidationError:

"The value of the SIP address in on-premise ProxyAddresses field is not in the correct format. Correct the format in your local Active Directory to match sip:username@domain. After you correct it,the value will be updated in your Microsoft Online Services directory during the next Active Directory synchronization."

 

Tried using display name and other attribute, but received the same error message.

5 Replies
Hello @AtanasM

Can you please try this step in your on-prem Active Directory sip:username@domain.com for the specific user facing the issue.

Also check if the user has a value in msrtcsip-primaryuseraddress if that is correctly represented.

With Regards,
Satish U
Hi @Satish2805 where can I find the msrtcsip-primaryuseraddress?
Hello @AtanasM

In the on-prem Active Directory under the user profile.

With Regards,
Satish U
Is this limited to just one user? Do they have issues with Exchange Online? Also take a look at their UserPrincipalName and make sure there are no characters such as spaces or non-ascii characters hiding in there.
The issue exists only by one user and there are no issues in Exchange Online. There are no special characters in the user name.