Cannot access teams from Graph API

New Contributor

Hello,

I cannot create and query teams in Teams using the Graph API.

 

It seems like an API error because the Team is visible in Teams for Windows.

 

Steps to reproduce :

 

Error when getting the existing team :

 

{
    "error": {
        "code": "NotFound",
        "message": "No team found with Group Id b97baca3-5f1c-4df9-957e-84565abd339a",
        "innerError": {
            "message": "No team found with Group Id b97baca3-5f1c-4df9-957e-84565abd339a",
            "code": "ItemNotFound",
            "innerError": {},
            "date": "2022-05-27T15:15:48",
            "request-id": "1589738d-3a4b-4a8a-824d-31383bb5a2c4",
            "client-request-id": "ffaf5d2e-d477-d8a6-63b0-a48b9f0dcbe1"
        }
    }
}

 

5 Replies

Go to the app's API permissions page. Select Add permission and then choose Microsoft Graph in the flyout. Select Delegated permissions. Use the search box to find and select the required permissions. quickpayportal

I have all the required permissions, I tried as an application but also as a delegated user.

@antoinedeb I have same problem, I have one app for migration and since this morning is not working anymore when try to create Channel after team creation.

I checked the Group by ID and group exists.

Same here. An previously successfully tested interface suddenly stopped working today exactly as described by the OP without having touched the code. While teams created today are (still?) not accessible from within the API but available in Teams, those created before today are perfectly functional.

Now it works for me. No changes from my side, same as yesterday but Today works