Can't switch between tenants. The option to switch to other tenants in the top right isn't displayed

Copper Contributor

Hey guys,


maybe you can help me out. So one of my collegues was invited as a Guest to the customers tenant. Unfortunately he can't even switch to the customers tenant because the option is not shown next to his profile picture. We tried with the client app and the web browser. We even ask the customer to look up in his AAD to ensure that he is there as an external. So this wasn't the problem. 

He even received a mail that he was added to a new Teams.


Does anyone has an idea?


Thank you!



8 Replies

I have seen this before.

Was the users UPN/Email address changed after being added to Teams? This can cause the issue. For example, I had an address of and then about 6 months after using Teams this was changed to Whenever I get added to someone else’s tenant using the second, the same behaviour happens. When the other organisation adds the first before the change ( it works without issue.

Was wondering if that could be the case here?

Best, Chris
Did he accept the invite on the proper account and not a Microsoft account? They can follow these steps:
like they were going to leave(but don't leave obviously). They should see the other tenant here if they accepted it on the proper account. If this looks good, then just give it a little bit of time, it should pop in eventually, it took 30min to an hour for it to pop in for my guest tenant earlier, not sure how longs it's been there.
I had same issue. Avast AV decided to block Just whitelist it
Man Avast AV.

Sounds like an opportunity for Defender for Endpoint bro.

Best, Chris
Hi Chris, Thanks for your advice. Sorry to necro a thread but most of the good ones are "locked" preventing further discussion.

I have been searching around for a solution to the Teams Tenant Switcher not being visible for a client who is members of 3 organizations (and members of Teams within those organizations).

This Guest User is unable to find his tenant switcher in Teams clients, or on the web version.
I have tried deleting his (Guest) entry from the guest tenant, and then deleting his username from AAD, then re-added his username along with adding him to a Teams group just like the other people that I added previously.

All of this process has worked in the past, but it seems this one user is unable to find his tenant switcher. He has tried "Leaving" organizations several times and has been re-invited several times, but still the tenant switcher does not appear.

I wonder if there is a setting for this user that would prevent seeing other tenants?
He is definitely a "Guest" user of 2 other organizations, but those orgs do not appear in his Teams at all. There are at least 15-20 other successful guest members who can see the other organizations just fine with the exact same configuration, except this one user doesn't see his tenant switcher.
This is so confusing and I think it is a bug.
Have they ever visited the tenants in question to fully get registered via the "you've been invited to a team" e-mail? I would go into the Team in question if you can in the web, then "Get a link" to a chat. Then have that user use that link to manually get them over into that tenant. Maybe getting into the tenant will force the registration and visiting it might trigger it to get added? Or has the user already gotten in this way just can't even use the switcher is the only issue?

Only other issue I could think of is if the user has a personal Teams and o365 Teams with the same username? I've seen that before with my own personal Teams now overtaking what was the MSA version of my account that I could switch with but no longer can.

Hi Chris, Thanks for your suggestion! I tried copying links to the Team in question and provided it to the user but unfortunately they could not gain access to the tenant.
The user is now going to submit a ticket to his IT to help examine why his Teams does not show other tenants though he is a member within the other organizations/teams.
Will try to get back and post the solution on this topic if I happen to find it!
Edit 8/14/23:  My user's teams client finally is now displaying the 2/3 organizations in the tenant selection dropdown. IT did not get back with him on the ticket yet so I believe it just fixed itself over time.  Perhaps AAD needed to finish synchronizing but it took at least 4 days for the organization switcher to appear.  
If any of you are having the same issue, try opening a ticket with IT, or wait 4 days :p Teams client might finally update itself eventually. 


Thanks for confirming. May also be worth in future checking the web version to see if it does it quicker. Also flushing the cache on the desktop client to see if that speeds it up. I don't know whether it has any impact in your case, but usually when it comes to being added as a guest, web displays much quicker.

Great to see bro @Chris Webb getting back into TC after a long time out. We had a long break from it but are slowly making our way back. He's got some big solutions out of Texas. 


Best, Chris