Can’t see members in Teams group

Copper Contributor
I’m an owner in Teams, but I can’t see the Members list so that I know who I’ve already added and who I need to remove. Why can’t I see the list? I’ve checked all of the settings.
15 Replies
Next to the team name select ellipsis (...) > manage group. You can't see members there? That is where the members should be alongside the owners

Hope that answers your question

Best, Chris
No, it shows “0” members, even though I have added more than 25 people.
What is the experience in the web app ( and mobile app?

Best, Chris

@Tchess Hi,


We are experiencing the same issue.  One member of the group can see all 15 members under the 'Manage Team' area, but another sees 0.




Nick Cooling @ProximityIT 


I have the same issue 

@Nick_Cooling  @ProximityIT  
We are experiencing the same issue over different tenants. I suspect its a capacity problem due to the usage of Teams in this covid-19 time.. 

Hi @Tchess,


I came across this issue in the App not listing the members and showing as 0 but was listing them online. The owners were listing ok though and I found that if I changed an owner to a member, it refreshed the list of members in the app and then listed them all. Then I just changed the user back to an owner etc.


If you have no other owners maybe either just add a test account or use the search box for a member and try the opposite and make them an owner then change it back?


This is clearly a refresh issue with the teams app and there seems to be no other way to force a refresh. 

Thank´s RayFarthing this work!
best response confirmed by Christopher Hoard (MVP)


Try clearing cache and credential manager cache by following steps:

  1.   Fully exit the Microsoft Teams desktop client. To do this, either right click Teams from the Icon Tray and select ‘Quit’, or run Task Manager and fully kill the process.
  2.   Go to File Explorer, and type in %appdata%\Microsoft\teams.
  3.   Once in the directory, you’ll see a few of the following folders:


  1. a.  From within ‘Application Cache’, go to Cache and delete any of the files in the Cache location.

    *   %appdata%\Microsoft\teams\application cache\cache

  1. b.  From within ‘Blob_storage’, delete any files that are located in here if any.

    *   %appdata%\Microsoft\teams\blob_storage

  1. c.  From within ‘Cache’, delete all files.

    *   %appdata%\Microsoft\teams\Cache                                           

  1. d.  From within ‘databases’, delete all files.

    *   %appdata%\Microsoft\teams\databases

  1. e.  From within ‘GPUCache’, delete all files.

    *   %appdata%\Microsoft\teams\GPUcache

  1. f.  From within ‘IndexedDB’, delete the .db file.

    *   %appdata%\Microsoft\teams\IndexedDB

  1. g.  From within ‘Local Storage’, delete all files.

    *   %appdata%\Microsoft\teams\Local Storage

  1. h.  Lastly, from within ‘tmp’, delete any file.

    *   %appdata%\Microsoft\teams\tmp

For credential manager
Go to path - Control Panel\User Accounts\Credential Manager 
And clear Microsoft's credentials

Hope this will solve the issue.

Hi @Rohit_Tiwari 

Thank you very much for your answer.
It actually worked, there was no need to delete the user's credentials through the administrative platform, could you tell me if the instructions you share can be done through the power shell?
I would like to make a script that deletes those data without having to go one by one.


I happened across this thread, having the same issue. 
I was able to correct it without clearing the cache, by selection the "hide" option for the private channel I was having the issue on, waiting a moment, and then locating it in the Team and selecting "show" to re-add it to the list. 

This apparently reloads the members list at this action, as opposed to reading it from cache when it's not up-to-date. 

Thanks Ray, this worked for me too!


Same issue

It works. THANKS

@XanderAmz confirmed...this is the best solution. my only complaint is it took a week to find this post