SOLVED

Can't open links in Teams on Windows Server 2016

Steel Contributor

Hi,

since our company (Company A) moved into our head company (company B) AAD, we (A) can't open any links in the MS Teams Application from "Chats" and "Teams". Links from Viva Engage f.e. still works. Links also can be opened in the web based portal (teams.microsoft.com).

Only the VDI client (W2016) are affected, we can't find anything. (Also tried to clear cache, etc.)

Are there any suggestions, before opening a MS Case?

 

Thanks in advance,

Schnittlauch

3 Replies

Hi @Schnittlauch ,  I'm sorry to hear that you're experiencing issues with opening links in the MS Teams application after your company moved into the head company's AAD. Here are a few suggestions you can try before opening a Microsoft support case:

  1. Update MS Teams: Make sure you are using the latest version of the MS Teams application. Check for any available updates and install them if necessary. Sometimes, outdated software can cause compatibility issues.

  2. Check browser settings: Verify that your default browser is set correctly on your computer. MS Teams may rely on the default browser settings to open links. Ensure that the default browser is set to a compatible and up-to-date browser.

  3. Clear cache and cookies: Even though you mentioned that you have already tried clearing the cache, it's worth attempting again. Clear the cache and cookies of both the MS Teams application and your default web browser. Restart the application afterward and check if the issue persists.

  4. Disable browser extensions: If you have any browser extensions or add-ons installed, they could potentially interfere with the link opening functionality in MS Teams. Temporarily disable or remove any extensions related to browsers you are using and see if that resolves the problem.

  5. Try a different computer/user account: Test opening the links on a different computer or user account within your organization. This will help determine if the issue is specific to your computer or account, or if it's a more widespread problem affecting multiple users.

  6. Verify network settings: Ensure that your network settings, including proxy settings or firewalls, are not blocking MS Teams from opening links. Contact your IT department or network administrator to confirm if any network configurations could be causing the problem.

  7. Restart computer and network equipment: Sometimes, a simple restart can resolve temporary glitches or network-related issues. Restart your computer and any network equipment (routers, switches, etc.) that you have access to, and then try opening the links again.

If none of these suggestions resolve the issue, it may be necessary to open a support case with Microsoft. They can provide specific troubleshooting steps or insights into any known issues that might be affecting the MS Teams application in your environment.

 

 

 

If I have answered your question, please mark your post as Solved

If you like my response, please give it a Like :smile:

Appreciate your Kudos! Proud to contribute! :)

 

best response confirmed by Schnittlauch (Steel Contributor)
Solution

Hi Anonymous, thanks for your answer, I forgot to write you back.

 

We found the unsatisfying "solution" to this problem:
It's a known Windows Server 2016 problem.

Check out the following article for more information:

 

Link in Teams chats not opening Browser - Microsoft Q&A

->

"Got final response from Microsoft Support: this is well-known issue with Server 2016 for about a year now. As Server 2016 is out of maintenance support, there will be no fix. 
The issue is related to maximum character URL-limitation by OS.
Two possible workarounds:

  • update to Server 2019
  • disable SafeLinks Policy in Security AdminCenter (including exeption for BuiltIn-default-policy) and wait 24h

The issue propagates through all tenants starting about a year ago... so some organisations are affected for quite some time and some only recently."

 

thanks for everyone who spent time,

Schnittlauch

Only "solution" would be to disable the MS Defender Link Protection :\
1 best response

Accepted Solutions
best response confirmed by Schnittlauch (Steel Contributor)
Solution

Hi Anonymous, thanks for your answer, I forgot to write you back.

 

We found the unsatisfying "solution" to this problem:
It's a known Windows Server 2016 problem.

Check out the following article for more information:

 

Link in Teams chats not opening Browser - Microsoft Q&A

->

"Got final response from Microsoft Support: this is well-known issue with Server 2016 for about a year now. As Server 2016 is out of maintenance support, there will be no fix. 
The issue is related to maximum character URL-limitation by OS.
Two possible workarounds:

  • update to Server 2019
  • disable SafeLinks Policy in Security AdminCenter (including exeption for BuiltIn-default-policy) and wait 24h

The issue propagates through all tenants starting about a year ago... so some organisations are affected for quite some time and some only recently."

 

thanks for everyone who spent time,

Schnittlauch

View solution in original post