Can't login to Teams desktop app with error code 800700b7

Copper Contributor

Last week I suddenly could not login to Teams desktop app with my school account on my PC. The error code is 800700b7. Normally when I login the app, it will pop up a window to let me login to school system.


I tried to uninstall and re-install it and clear the cache, but all can't work. There is no system updates pending.


However, I can login with my personal account on my PC. I can login with my school account on my android phone and in browser on my PC. I can login with my school account on school computer as well.


I asked IT admit for help, but they are hard to fix it.


Hope anyone can help.error.png

8 Replies

More and more users have this issue in this week. I tried reinstall and clear Teams cache, no luck..

Anyone has solution ?




I started having this problem with the last updates I installed. I have tried signing out and in, stopping the program in Task manager, uninstalling and re-installing the desktop app, and clearing all cache and temporary files. The only thing that works is to restart my computer- then it will let me sign on until I am away from the computer for any period of time, at which point I am signed out. I'm pretty much only using the browser version at this point.

@daniel_liang I have the same issue with several users.


Things we have tried so far:

-Clearing Office Windows credentials in Credential Manager

-Uninstalling and reinstalling Teams

-Deleting and/or renaming %LocalAppData%\Microsoft\Teams\ folder

-Deleting %LocalAppData%\Packages\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy\LocalState folder and replacing with a text file named 'LocalState' to prevent recreation of the folder

-Removing account from Settings>Email, calendar, and contacts

-Restarting computer


Some of these steps have worked in some installations, but I still have several stubborn installations that won't authenticate correctly, or will auth one time and then go back into error state. Hopefully these ideas will help others who are experiencing the same issue. Some users have temporarily switched to the Teams web app (, although this connection sometimes gets errors as well and needs a reboot to work-around.


Hopefully someone can come up with a true fix for the underlying issue.


Try this:

** Exit/Quit Teams**

1. Make sure there is no other Work or school account under "Email & accounts" . If you see user personal Microsfot account, delete it. If there is no work&school account, create it.


2. Clear Teams Cache (as your mention)

3. Rename folder "Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy"

4. Reboot PC

5. Reinstall Teams desktop client

6. Test it 


Thank you


Bruce Lin

Thank you two. I tried your methods but problem is still here. However, I found that not only did Teams have this issue, I also cannot add a work or school account in setting or Office. There is no popup when I try to add it in setting as well. Maybe that is the point.

@daniel_liangI was able to successfully resolve this issue by following the uninstall steps mentioned in the following Microsoft article:


Please note that I had to uninstall both Microsoft Teams and Teams Machine-Wide Uninstaller as mentioned in the article.


Also, I cleared the Teams cache as mentioned by others in the post.


After uninstalling both apps, clearing the cache, and reinstalling teams from I was able to successfully recover from this issue.


I hope this helps.



@pkhetarp thank your reply. The problem was solved automatically several months ago but I still didn't know what actually happened. Hope your method can help other people.

Hi there, Hope this will help some of you. First sign out from MS Teams, or remove MS Teams (including cached folders from AppData), then check if laptop is joined with Azure-AD running CMD (as admin) "dsregcmd /status" . If yes, use CMD "dsregcmd /leave". Restart laptop. Clear MS credentials from Credentials Mgr and Setting-Accounts- Work or school accounts. Sign out from machine and log back in. Once back in, launch Word or Excel first to sign in. Open or re-install MS teams and sign in. If still having issue, create a new user profile.