Can't join a team I was added to

%3CLINGO-SUB%20id%3D%22lingo-sub-284238%22%20slang%3D%22en-US%22%3ECan't%20join%20a%20team%20I%20was%20added%20to%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-284238%22%20slang%3D%22en-US%22%3E%3CP%3EHello%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20was%20added%20from%20a%20business%20partner%20to%20a%20team.%20When%20I%20open%20the%20link%20in%20his%20email%20the%20Team-App%20starts%20but%20no%20team%20is%20shown.%20Do%20I%20need%20to%20use%20exactly%20the%20same%20mail-address%20of%20mine%20he%20has%20mailed%20the%20link%20to%3F%20Or%20is%20there%20another%20Issue.%20I'm%20using%20Teams%20on%20Mac.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EKind%20regards%2C%3C%2FP%3E%3CP%3EMichael%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-284238%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EMicrosoft%20Teams%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-284267%22%20slang%3D%22en-US%22%3ERe%3A%20Can't%20join%20a%20team%20I%20was%20added%20to%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-284267%22%20slang%3D%22en-US%22%3E%3CP%3ETry%20accepting%20the%20invite%20from%20a%20private%20browser%20session.%20As%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F869%22%20target%3D%22_blank%22%3E%40Chris%20Webb%3C%2FA%3E%26nbsp%3Bsuggests%20it%20could%20be%20a%20caching%20issue%20and%20this%20will%20avoid%20that%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-284246%22%20slang%3D%22en-US%22%3ERe%3A%20Can't%20join%20a%20team%20I%20was%20added%20to%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-284246%22%20slang%3D%22en-US%22%3EIf%20the%20e-mail%20he%20used%20to%20invite%20you%20is%20already%20a%20Microsoft%20Account%20or%20Office%20365%20e-mail%20then%20you'll%20need%20to%20use%20that%20e-mail.%20Usually%20clicking%20the%20link%20will%20log%20in%20using%20the%20account%20you%20choose.%20What%20I've%20also%20seen%20is%20people%20will%20have%20browser%20cached%20MSA%20accounts%20logged%20in%2C%20and%20when%20they%20click%20that%20link%20it'll%20use%20whatever%20they%20had%20logged%20in%20with%20in%20the%20cache.%3CBR%20%2F%3E%3CBR%20%2F%3EAlso%20if%20you%20already%20had%20Teams%20on%20the%20account%20you%20used%2C%20check%20in%20the%20top%20right%20corner%20by%20your%20name%20is%20a%20drop%20down%20to%20switch%20Tenants%20%22Assuming%20it%20added%20you%20to%20guest%20properly%22%20you%20might%20just%20need%20to%20switch%20to%20the%20other%20tenant%20there%20as%20well.%3C%2FLINGO-BODY%3E
Highlighted
Occasional Visitor

Hello,

 

I was added from a business partner to a team. When I open the link in his email the Team-App starts but no team is shown. Do I need to use exactly the same mail-address of mine he has mailed the link to? Or is there another Issue. I'm using Teams on Mac.

 

Kind regards,

Michael

2 Replies
Highlighted
If the e-mail he used to invite you is already a Microsoft Account or Office 365 e-mail then you'll need to use that e-mail. Usually clicking the link will log in using the account you choose. What I've also seen is people will have browser cached MSA accounts logged in, and when they click that link it'll use whatever they had logged in with in the cache.

Also if you already had Teams on the account you used, check in the top right corner by your name is a drop down to switch Tenants "Assuming it added you to guest properly" you might just need to switch to the other tenant there as well.
Highlighted

Try accepting the invite from a private browser session. As @Chris Webb suggests it could be a caching issue and this will avoid that