Can't create Teams meeting for other user

Occasional Contributor



I have one user that is unable to create Teams meetings for another user in Outlook.  They have full access to the other mailbox (they are both hosted on-premise with Exchange 2016) and can schedule regular meetings, just not Teams.  It shows the following message:


Sorry, but we cannot connect to the server right now.  Please try again later.


The error message is useless as it doesn't say which server it is trying to connect to.  I have checked our OWA and ECP, everything functions perfectly.  Has anyone else seen this before and fixed it?



9 Replies

@bec064 thanks for the reply.


Yes, as far as I can tell everything required is setup.  We have been using Teams happily for some time but I think this is the first time we have experienced this issue with 


For info, we have Exchange 2016 CU17 hosted on-prem and no mailboxes in the cloud, they are all on-prem.  The hybrid setup has been in place for some time.

@Dai_Webb So only for one user? In that case I would focus on the client (new .ost / new profile etc.) Perhaps another member has seen this before and will reply.



Sorry for the late reply.  No, it seems to be all users - I've just tried it with a few more people and they all get the same message.

Best Response confirmed by ThereseSolimeno (Microsoft)

@Dai_Webb Hi! Then I would walk through this step-by-step


Note the "To enable calendar delegation for these users" section as well.

@bec064 great suggestion, I've got further now, thank you (it was the step 2-3 part - I didn't do this previously as we don't use Skype for Business).  Now I get this error, which appears to be permissions related, but the user has full access to the recipient's calendar:




Any idea how I get past this one ?


Thanks in advance.

@Dai_Webb Hello! Well done. I believe you could be missing the -SharingPermissionFlags "Delegate" but I'm not sure if you can use this as it's EXO only.


But delegate can be set from within the Outlook client using "Delegate Access". Try them both and let me know? Thanks.

@bec064 you're right, the SharingPermissionFlags parameter doesn't exist on-prem.


I've tried delegating permissions through Outlook (logged into Windows and Outlook as the user sharing the calendar) but that hasn't helped, it still gives the same permissions error.

@Dai_Webb Thanks for the update. I noticed the error message is described here, so please verify the settings one more time.


'Issue 1: A delegate can not schedule a Teams meeting on behalf of a delegator'


If it still doesn't work I suggest you open up a support ticket with Microsoft.