Can't access my own organisation

Occasional Contributor



I used Teams over the summer to support a couple of different clients.  I set up my own Teams account with my company name associated with my email address.  This didn't then turn out to work as they had their own instance in-house and wanted to add me as a guest to their Teams - using the same email address.

Now I try to log in to Teams and am told I don't have access to my own company account - only  theirs...and it keeps on saying it needs to 'switch account' and I'm confused as its saying my Microsoft email is linked to two account - one I set up myself  and one that "my IT department" set up - I have no IT department.


Clearly somehow wires are crossed but I can't uncross them - any advice?

To complicate things even further I'm a Mac user on Safari - and Teams doesn't like Safari so I'm having to use Chrome or the App - the app won't open at all - just spinning wheel - and yes  I've deleted the app and reloaded it AND tried to log into Teams via  Chrome.

20 Replies

@Rachel_Jackson Thank you for raising. I have had exactly the same issue in the same circumstances. 


I am using a HP Laptop with Windows 10 so should not had the platform comatability issues mentioned in the last para.


I too would need to know what the fix for this is.

@Rachel_Jackson Hi, don't I think I understand exactly, but to start with do this using Incognito session as you don't want mixed up credentials.


If you have a Teams free org. you can manage it yourself


If you are a guest user at other organizations I suggest you leave them using the "Access Panel" option.


If you can't leave the org. you'll have to reach out the concerned admin to remove your guest account from their Azure AD (and the Azure AD recycle bin as well). There's a 24 hour delay before permanent deletion of the account.


You should also sign in to your personal account settings (the personal email address) to verify that you're not using any aliases or associated addresses to remove any link between them.

I'll try that


Oddly I now find I have two Microsoft accounts - both associated with the same email address so maybe that's why Teams is confused  @ChristianBergstrom 

I tried to leave the took me took their page and made me give a texted code - and then said unexpected error...and I'm stuck

What is an Incognito session?
Re: Can't access my own organisation
I tried to leave the took me took their page and made me give a texted code - and then said unexpected error...and I'm stuck

Also it then starts asking me about becoming the admin and a whole host of tech stuff I don't understand? Who the hell is the admin if I'm not?

@ChristianBergstrom thank you for the reply. When I try and leave the organisation of a client I get the unhelpful message 


"an unexpected error has occurred"


I have contacted my clients support people.



@Rachel_Jackson Agreed this is a poor user experience for small business that does not have and IT department. It was not made clear that there would be consequences of using my company email within the Azure AD of another organisation. 

@Rachel_Jackson Hi, see this page


If you're not able to leave the org. then reach out to the org. that you're a guest user.

I don't think that is the issue - I think its a bigger issue about multiple accounts and emails

@Rachel_Jackson Hence why you need to use Incognito mode when verifying the above mentioned steps.

me too

@Francis_Gresham I totally understand that this can be confusing. But guest access is one of the fundamentals of using Teams. It's built for collaboration. When configured it's easy to manage and invite other people to one's org. even for end-users. This can be done with Teams free as well. When doing that the guests are being added to the concerned Azure AD by default. And you're going to stay there (the invited guest account) if you don't leave the org. when done working with them. Sometimes the org. deletes the account for you but it's not something you should rely on.


Hope you get it sorted. I've mentioned all I know that could cause the initial issue and how to proceed. Good luck!

All very well @ChristianBergstrom but we've both logged into Azure (didn't even know what it was til now) and when you click on Leave Organisation you just get an error message saying 'unexpected error' and can't leave. I've contacted both organisations but its chaos

@Rachel_Jackson Hi, if you have created your own organization by signing up for Teams free you can manage that org. yourself. Then you can go to and view at all your own org. settings and users etc.


If you would like to leave an org. as a guest (not your own) you must go to as described in the previous reply and leave the org. If you cannot leave, the org. admin has to do it for you. This is only applicable if an org. has invited you using your personal address and you have accepted that invite as well (meaning, been working with a team in Teams at that org.). When the invite is redeemed your personal account is added to their Azure AD as a guest user with status "accepted".


For avoiding mixed credentials, cache related issues, use the incognito mode in the browser.

So - on the azure portal I can't leave without the Unexpected error message...and I have no allocated admin on the myapplications link as I'm a small company with an Office 365 account and I have never been aware that Azure existed...and apparently now I need an admin?
This only seems to apply to a business account but I have a family account as far as I'm aware

@Rachel_Jackson Hello again, why would you want to leave your own organization? That is if you have signed up for Teams free? But now you mention Office 365 Family? I just don't understand.


It's really difficult trying to assist when not knowing exactly what you have done or how your business is set up.


I assume that you have not created an own org. with Teams free. You have just been invited to other organisations and they have sent the invite to your address and you have ended up in their Azure AD.


So, you can leave an org. yourself, or have the other org. remove you if you receive an error. As far as I understand you can't do it so you need to contact the org. you have been working with and have their admins remove your account.

I created a free teams account under my organisation. I don’t want to leave my own organisation. I want to leave the two other orgs listed - they are now listed on my azure AD because they gave me guest access and also it appears because I invited individuals into teams on my own account.

The mention of office family relates to the question of why I even have an azure AD account. They are set up automatically for 365 users. But some of the things I’m being suggested involved going into Microsoft account as an admin - which I don’t have. It seems Azure is designed for admin people and I’m not one. It’s unnerving to find a whole new layer of digital accounts related to my email when all I did was buy Microsoft 365

I have a similar if not the same problem. I want to use Teams, have and Office 365 account but when I try to open Teams I get this message:


This for my account that I use for my family, its not a business account and I don't want to use another e-mail address.

Please could someone help and let me know how to enable my own Teams account.

Many thanks