Can't Access Meeting Options

New Contributor

I logged in to the Microsoft Teams application with my work account - I then created a meeting, and clicked on Meeting Options. And I got this: "Only meeting organizers can make changes Your account,, doesn't have permissions to make changes."

26 Replies
best response confirmed by guy_glantser (New Contributor)
Looks like you have signed into Teams in your web browser and then switched organization to another (Microsoft?). Open and make sure that you are in your home organization.

@Linus Cansby , thanks a lot!

Problem solved!


Yes, it's an irritating design flaw (I'd say bug but MS don't like that). It does not launch the browser apparently needed to access the options (no idea why they can't just be given inside the desktop client anyway) using the right user context. I happen to have accounts in 5 office 365 tenants and it's almost impossible to get this right.


Another way to do it is to open a browser in a private window, copy the link from the failed window and sign in with the account you were using in teams - that way you don't end up screwing up your other connections in other tenants. 
An option to open in a private window would probably be good - but much better display the option inside the app in the current session. I have user voiced this.

Thanks Ian!

Okay Microsoft, we are ready for you to fix this issue. What on earth could be the problem?

All of the suggestions do not work. I  have only one MS Teams desktop application, logged in through web app to Teams - still not able to change the Meeting Options.

hi i'm unable to access meeting options
something went wrong-try again later comes on appearing,pls help 
@Linus Cansby 

Same thing is happening for me. @DrAnu68 

No that is not the same problem. I was able to get mine to work by logging out of all other non-organization Google Accounts on my computer and actually deleting them from my Chrome Browser.  I think the issue is that Teams was "confused" between Google Accounts. @ThereseSolimeno 

@Linus Cansby Hi, I am having the same issue. Could you clarify what you mean by "confirm you are in your home organization"?  I am signed in to Teams with the same account in both browser and app, but still get the same message.  

@Ian Cunningham Private window solved the problem for me!

@guy_glantser I have multiple user accounts but logging into a browser with cleared cache or an incognito window didn't solve this issue for me. What did was recreating the meeting from scratch from the Microsoft Teams Calendar interface rather than doing it via Outlook.

Can't access meeting options it's showing me something wrong

@guy_glantser None of the solutions here worked for me. I had to manually create a new entry by hand copying over the items. I think this is due to plugin updates and the old entry being created with an old plugin version. After that, I was able to access the meeting options.

@Linus Cansby 

I have multiple accounts with Teams but I checked the website and was with the same organizer's account but receive the same message when I like to change the meeting options. We have two accounts for our institutions (one short version and one is our full name before @). I guess this is the issue that the Teams cannot understand if I am using the short version or full name (it brings my short version email and say "Your account, behkou@..., doesn't have permissions to make changes". Any solution?


I found the reason for it! The Outlook created Teams meeting with another account of myself while it's weird since I created Teams meeting with specific account! I guess my Outlook needs restarting!

cant login to trem meeting
can not access meeting option


When I organize a meeting, I cannot have access to my meeting options.


It's written

Something went wrong

Reload the page or , if this keeps happening, try again later. 


Thanks in advance


Dora Tilemachou