Can't accept invite to join Team from outside organization

New Contributor

I have received an invite link and when I try to use the link it keeps defaulting to my internal organizations Team only. I've turned off block 3rd party, signed out of Microsoft Teams, tried an incognito window, tried Chrome and Edge browsers, tried on my mobile device, tried clicking the link, and copying the link into a browser, tried the app and the web app, closed all browser windows, rebooted the computer, ......


frustrated and need help.


3 Replies

@Graig_N first i will recommend you confirm if external access is turned on on your tenant or that specific organization you are getting the invite from is in the list of you allowed tenant if you are running a closed federation. 


also, confirm if you can see the icon a the top of your teams client 

Best Response confirmed by Graig_N (New Contributor)



If they have invited you using your own Microsoft 365 account then what should happen is the new Teams tenant gets added to the list of tenants you have access to in the top right of Teams looks like this:- 




Pop into the web client and see if this has appeared if it is not showing in the desktop client. 


It doesn't matter if you have external sharing turned off the settings are all controlled in other tenant. 


@Andrew Hodges 


Thanks. It was a correct email name issue. It's been resolved, but if I didn't know how the tenant function worked I would never have figured it out.