Can not delete team chat messages despite policy change?

Occasional Contributor

 "Microsoft Teams & Skype for Business Admin Center", "Messaging Policies", "Global.." (the only policy), "Owners can delete sent messages" is set to "On".


Yet, messages other than the owners chat messages can not be deleted. Is this setting working? Or, am I doing this wrong somehow?




23 Replies
I do know there are a lot of bugs right now in the teams and Skype admin portal! It could be related to this!

best response confirmed by Adam_Griffin (Occasional Contributor)

Hello Adam,


Good morning ... just create a new policies and apply , it worked for me.



TeamsMessage.jpglet me know if you still face this issues.




Make sure that the Setting inside the Team is checked. The policy basically sets the ability to do it and the default, not necessarily turn it for all existing teams if it's set. Go to the Team, manage the Team > Settings > Member Permisisons, should see the Owner can delete all messages there as well. See if that could be the case?

Thanks Adam and Chris

This does indeed make the delete option appear after I create the policy and apply it to the users in the team. Did have to close the teams app and open again to see the result. Thank you!


Why isn't the global policy working as intended? If it isn't, is there an easy way to apply the policy to every single user in a company? (500+ users would be an awful lot of clicking)

I did verify that these were set correctly. Thanks!

Oh wait, nevermind. I see that the policy only has to be applied to those that would be "owners" and then they can delete the chats where needed.

@Chris Webb I created a new messaging policy to include the "Owners can delete sent messages" option, and assigned it to myself. I signed out of Teams, then signed back in and went to a team I'm owner of, went to Manage Team > Settings > Member Permissions but see no corresponding option to allow owners to delete messages.


I know it's been a while since this thread was updated so I went looking through other settings. I do see a Guest Permissions section but don't see another section for Owners.


Has the setting moved or does it work differently now, or might this be a bug?


Any help appreciated. Thanks!

Probably a case of give it some time and it'll work later type of deal. Usually these policies can take an hour or so to take hold.

@Chris Webb We are having an issue with the owner of Teams being able to delete the messages that members of the Team send in Conversations. Under Settings --> Member Permissions, there is no option for "Owners can delete all messages" in my coworker's Team like there is on my Teams. Why does his Teams not have this option in Settings like I do? Is there a way that we can restore it?


Thank you for your help.

@Thuyavan Ganesan 


I need to delete a video recording in microsoft teams. But i am not able do it. It is showing recording failed to upload to Streams



@Thuyavan Ganesan : Isn't the requirement is for owners to delete the messages? What it looks like in screen shot is you are deleting your own post. Am I understanding it correct?

Here to say that here we are, at the very end of 2020 almost exactly two years later from Adam_Griffin's post, and my experience is identical. Added 'owners can delete' permission to global policy, nothing happened. Created new policy with delete permissions, applied to myself, logged out of teams and back in, and magically I can delete things.

It is now 2021 @evilcreamsicle and I am also seeing the same thing!  I have:

  • Enabled the global policy setting: 'Owners can delete sent messages | ON'.
    • GlobalPolicy_OwnersCanDelete.jpg
  • Verified the Team policy setting: 'Owners can delete all messages'.
    • TeamPolicy_OwnersCanDelete.jpg
  • Verified the "delete option" is available in both the desktop and web app.
    • Team_DeleteOptionAvailable.jpg

My problem now is that clicking "delete" does NOTHING!!!!  Clicking delete in either Teams app is simply like poking a dead body with a stick.....

Poking Dead Body wirth Stick.gif



@surferstylee I am now having this issue. I've spent 4 hours on the phone with support, and they're telling me it's "normal" for the delete option to not work....

Preposterous nonsense.  It also doesn't matter what kind of account is involved either. Why have the option if it's not designed to work?

So how did you get it to work? lol..... Inquiring minds want to know.

@nz2ocasey , do you have the 2 settings enabled?

  1. 'Owners can delete sent messages | ON' - Global Policy Setting
  2. 'Owners can delete all messages' - Local Team Policy Setting (app)

If so, are you able to see the delete option in Teams?  Have you tried via web app?



Good afternoon,

Thank you for your reply. When I said same issue, I meant exactly same as what you were encountering, as I had scoured the whole thread for possible solutions.


What I verified (in fact, repeatedly with Microsoft Support - lol....) :

  1. Those same two settings in:
    Global Policy in the Teams Admin Center,
    and the app's seettings/policy.
  2. That I was in fact an owner (and.... a global aadmin)
  3. Issue occurs after 24 hours from turning the setting off, and then back off again (allow for replication)...
  4. Issue occurs on Android, web, desktop, and additionally the same for one of our other global admins.
  5. Upon clicking on the delete option (which IS available), nothing happens. No deletion, and neven after a delay.

What I found weird, was:

  • When I tried to turn the option OFF, it would literally turn itself back on, and the last MS Support person (Jared) saw it too,  since we were sharing screens.
  • Earlier when I was talking to Nitesh (MS Support), we both noted that I could delete from the General channel of a different team in the same tenant.... but not that particular team.... Then the issue got worse, and I couldn't delete from either of the three.
  • When Nitesh (MS Support, earlier representative) was basically perplexed and said "let me call you back (and never did)," I contacted someone for a followup, and they said that "it's normal to click on delete and it not delete."
  • Then they said it is related to the current incident....
    But that incident actually relates to using a personal Microsoft account with the same email address/username as a Work/Business/Enterprise Microsoft account.... 
    My personal account is an address, my business account is a different tenant, and I have another tenant, which also has a different account. All logins are totally different/separated.
    Therefore, you would think that the incident is unrelated to this issue.

What did I do to fix it? I didn't, TECHNICALLY fix it, but I found a possible workaround in a non-MS group.... So... I'll say that the support I received from the US was decidedly better....and confirmed, something isn't right.... but, the fact that they couldn't take the ticket away from India's reps who were pretending to not hear me, is a problem.


  1. I created a brand new policy, with same settings.
  2. Applied it to my admin account.
  3. Waited, and at  about 11pm I could delete...

The problem though, is when I repeat the same steps for my other owner/admin, it does NOT resolve the issue....


Not sure how I'm supposed to feel considering we have Office Enterprise...and that my OTHER (day job) uses the same for over 50,000 licensed employees....

@nz2ocasey.....  It is odd that you would run into those challenges after making the same configurations I outlined.  I wish I could provide some detailed insight as to why you are experiencing the challenges you described, but I am unaware of what would be the root cause my friend.

Good luck with it moving forward and at least the challenges keep us with a job!! :rolling_on_the_floor_laughing: