Camera showing Black Screen only when using Teams app, works with Web version

Occasional Contributor

Hi guys,

A client is using Windows 10 x64 running v1909 on a MacBook Pro 13" (2019, 4 Thunderbolt Ports) and oddly enough the Teams app now shows the Camera as a Black Image as the Preview. It's listed in Device Manager as FaceTime HD Camera. Zoom and Web Teams works completely fine. Even opening the MS Store Camera App loads the Camera fine. It's just isolated to the Teams App, I'll list what I've tried already below, really hoping you can help in any way.


-Re-installed Teams x64

-Attempted to install Teams x86 - No change

-Removed Camera Driver and re-installed via Bootcamp drivers

-Re-installed ALL Bootcamp drivers from the latest available updated

-Cleared Teams cache folder

-Office Quick Repair/Full Repair


The problem still exists but only with the Windows app version of Teams.


If you have any ideas or thoughts please let me know.

Thank you,



40 Replies

@TechManish Your solution worked perfectly.


I had this problem, Windows 10 with Bootcamp, MacBook Pro 2019 model, and your echo command that inserted this into the persistent.conf file is what worked to fix it.


Thanks for the fix... I've had black camera in Teams for months, while all other teleconference apps, the windows camera app, and the Teams web app worked fine. Only Teams Windows App showed the camera enabled, but black and no video. Following your instructions by closing out Teams completely, running the echo command, and restarting Teams and the video came up. This was without having to boot into the Mac side, or having to reboot the machine, or do anything else.

You may try the following steps to fix the issue.


  1. Log out of your Teams account.
  2. Launch the Task Manager and locate all Microsoft Teams processes running in the background.
  3. Right-click on each process and select End task.
  4. Close the Task Manager app and launch Teams again.

If it it not working, you can just try update the program or just uninstall and reinstall the program itself to see if the issue persists. 

@TechManish having the same issue on my macbook air running OS Catalina from Apple but the cmd script didn't do the trick. Where can i find the appdata?



Hi you can find the AppData where the persistent.conf file is here:




Note that in Windows Explorer, AppData doesn't show because it's a hidden folder, but it is there. If you start typing it into the textbox for the Path at the top of Windows Explorer it will show.




@aiasso ? Thanks but i'm running IOS and don't have a file explorer, where can i find it through finder?

@TechManish I just wanted to double-check the spelling of that command: is it 'Capture' or 'Capturer'?

I have the same issue. What worked for me is deleting my camera driver. For some reason while deleted, the video started working in Teams.

It's not a permanent fix as it goes back to black one the driver is automatically reinstalled.

Changing the setting to Media Foundation is what worked for me. Thank you for sharing.
@TechManish Thank you! This worked for us as well.
P.S.: No need to open cmd as Admin, users can edit anything in %appdata% without elevated rights.
Same Problem here. Using teams on macbook M1, 2020, Big Sur.

@TechManishI have the same issue, but I am using Mac OS. When I plug in my external USB Camera, Teams app shows a black screen for Camera. However, the camera works for everything else such as photo booth, zoom, even MS Teams meetings on any browser.


I tried rebooting, removing and reinstalling, giving app permission to the camera, etc. No luck :(


Any suggestion?

@yahawiliThanks for your reply. But I am running Mac OS, not Windows on a Mac.

I don't have zoom installed in this machine, so I guess the other suggestion doesn't apply either.


Oh I see. I did not realize that. All I would say is the issue was the cached Teams files were corrupt or incompatible or something. Reinstalling does not fix this issue until and unless you delete the cached folder/files. I'm not a mac person, but I would assume if you have a way to rename the cached folder for Teams and try running teams. If it fixed the problem, then delete the rename folder. Otherwise, you can always rename it back.

@aizlam Try to Sign out from Teams and then sign back in again. The suggestion mentioned by TechManish only works half/half in our environment, the sign out / sign in seems to always work, however, a small percentage have to do this every day and for most it sticks and fixes the problem permanently.  

Unfortunately, this didn't work for me :(
I just tried it again, no luck.

Hi @harminderchagger   Does this prior post related to what you're experiencing? Check out best response and subsequent responses.  If not, please let us know: Re: Weird error - camera showing black and white - Page 3 - Microsoft Tech Community


Here's another unverified article on this: [SOLVED] Microsoft Teams Black Screen Issues (2022) (

Make sure that you've allowed access to your camera in your privacy settings: system preferences - security & privacy - camera (on the left) - see if Microsoft teams is ticked