Bug - Teams Android-Unable to switch orgs

Steel Contributor

I'm guest in multiple orgs. As of today I'm no longer able to switch from my home org into any of the orgs I'm a guest in. I tap the guest org, the app flashes, and I remain in the original home org.

Have done the usual troubleshooting: cache clear, reset database, clear app data, uninstall/reinstall.

This is an Intune managed device, with a work profile, fwiw.

Anyone else seeing this before I submit a bug report?


33 Replies
I noticed the same issue today and found an older thread from 2019 referencing a correlation with having the device registered with your home organization *in the Authenticator app*.

I just "Unregistered" the device from Authenticator, and I'm able to switch to a Guest org (Microsoft in this case) now.

This did not affect my Intune compliance for enterprise app/data access but presumably it means I can't use the Authenticator app for Passwordless anymore if I want to be able to switch orgs in Teams. Seems like a bug...
Update -- I was wrong about the Intune compliance not being unregistering from Authenticator. My enterprise apps did soon after require me to re-register the device in Company Portal, and switchingOrgs in Teams broke again.
I am experiencing the same issue. Did anyone find a solution yet?
No, it still is not working for me either. I reported it a week ago. I find this stuff hard to believe. I would expect this to impact thousands (if not more) users. Maybe we're the only three people in the world with managed devices who use Teams as guests. /s

@Bob Manjoney As of this morning's app update I am now experiencing this exact issue.  

@Mike_Nys Had the same issue yesterday. Removing device registration from Microsoft Authenticator immediately enabled me to get guest access again. Now for the consequences of that move..... 

Same issue here.
Same issue here.
Same here, unregistering device from Authenticator works as expected, but on the other hand, Outlook stops working prompting to log in, so is a choose between Teams and Outlook.
I have even tried with previous Teams versions, and same issue occurs.
This discussion is 14 days old and we had not any answer from @microsoft :\
I use the Blackberry Email client rather than Outlook. It prompted me once for creds and MFA after I unregistered but has been fine for a couple of days since then. Workable solution for me until MS sorts this nonsense out. I am not holding my breath.
Same problem for us... All our organizations android phones stopped working, and we can't switch over organizations, maybe someone gets any solution from MS?
Ok, we've now had several people confirm this behavior. I had submitted this issue a while back, but have gotten no reply. I have no idea if it's a known issue, whether it was received, if it's being worked on, if it's low priority, if it's "not really a bug" etc.

@Bob Manjoney 


The funniest thing, if you configure company portal for example using user 1 credentials, and run teams in user 2 credentials, that's works perfect.... it's the kinda stupid thing.. Looks like the problem appears when company portal user and teams user are the same.



Just adding this in, in case MS looks at # of people having the issue. @Bob Manjoney, did you open a ticket on this (or did anyone else) and if so can you keep us apprised?

I have a 14 person engineering team impacted by this issue right now (12 Android users, 2 iOS people that work fine), all client communications are negatively impacted.

best response confirmed by ThereseSolimeno (Microsoft)
This may have been fixed with a recent Teams update. I just updated apps on several devices and Teams version 1416/ was installed and I'm once again able to switch among orgs with our registered/managed devices. Can anyone else corroborate?

Hello,@Bob Manjoney 


I just checked and this is fixed for me as well -- Version 1416/



@Bob Manjoney is it still working for you? I checked this morning and it worked, but now again bug is happening :(

Oh geez. Yes, at the moment, on my 2 devices (Samsung Galaxy S20 and Surface Duo) both are working, but I haven't checked in with others yet.