[BUG] Microsoft Teams not letting me sign out of my work account.

Copper Contributor

So I have a job interview for a different job tomorrow and it's going to be on Microsoft Teams. I tried testing it out today, but when I start it up, it says " You're missing out! Ask your admin to Enable Microsoft Teams for (company name)" as seen in the screenshot.


When I click Sign out or Use a different account, it just brings me to this blank screen and stays that way for hours.


My personal computer isn't even logged in to that work email it's referencing. I've also used a different email for Team in the past. I've tried uninstalling, and re-installing it, but it comes up with the same message. 
Does anybody know how I can fix it? I can't possibly do a job interview using the work email of the job I'm currently working.





6 Replies
Hi, for starters you can always use the web version and you don't even have to be signed in (usually) so that might calm you down a bit :) When it comes to your issue though I suggest you try this script to reset your desktop client autostart settings just copy and paste it into PowerShell.

If it still doesn't work you might want to try to wipe all the locations described here and reinstall again.

@ChristianJBergstrom Hi there, thanks so much for the reply. I  just tried both of these multiple times. in different orders and it still didn't work :( I'm really not sure whats going on

. I did end up just using the web version of Teams, but still ran into issues where, even though I was logged in on the browser, I kept showing up as (Guest). I just hope that didn't effect the interviewers perception of me

best response confirmed by ThereseSolimeno (Microsoft)

@OmnidyneI managed to fix this on my computer. Had to remove the account association completely from my computer (university account). Go to "email & accounts" in windows settings, find "access work or school" and disconnect the account that keeps trying to sign in to teams. I then did the above steps and removed teams completely before reinstalling and finally I have a "fresh" install of teams.

Great suggestion. Had unfortunately missed the above reply.. sorry about that.

@ChristianJBergstrom  is a real problem on a Mac because if you change organisations, the organisation login window has no cancel or logout button. If you close the window, Teams says there is an error and has a logout link that doesn’t work. Very frustrating. Have every other M365 apps logged into my new workplace but Teams is a bugger.