Breadcrumb navigation disappears after opening and closing document within Teams desktop

This thread has been locked for new comments by a moderator, if you have a new similar issue then please start a new thread.

To provide some background, our organization currently uses the latest stable client of Microsoft Teams and we've recently deployed updated OneDrive sync app policies to enable Known Folder Moves, enforce the use of the Production ring, and more.


This morning I was asked about the breadcrumb trail in Teams no longer appearing after clicking to a view a file in Teams such as a Word document. I was able to reproduce her issue by following the steps below. 


I did some searching around and I found users reporting this same behavior as far back as Fall 2021. If it helps, the issue occurs only in the Teams desktop app (the browser app does not exhibit this behavior).


  1. Navigate to a Teams Channel > Files.
  2. Open a subfolder, in this case Intune. Followed by another subfolder, Certificate Connector Upgrade.
  3. Open a Word document within Teams.
  4. Click Close in the upper-right to close the document. 

Before opening the document


After opening the document



14 Replies

@BShipe FWIW I tried to recreate this but never had a problem, breadcrumb stays viewable.

Thank you for testing! I pulled out a second workstation just to see what the experience was like there, and the breadcrumbs seemed to persist as expected.

It may be time for a Teams cache reset for the end-user, so I'll try that avenue. Think it's safe to say that the breadcrumbs should persist which is the answer I was looking for.

@BShipe Im experiencing this as well and I have tried on several machines with the same result.  I also tried to clear the cache with no success.

I was able to reproduce the issue following your steps. It seems this is a bug and Microsoft will most likely address the issue in future update. my desktop client is 32 bit version

Interesting. I asked one of our employees to try and reset the cache while I was out of the office last week. Will need to follow up with them but this is unfortunate to hear!


Updating this post as to mention that I'm on a test laptop this week with a fresh install of Teams on it, and I confirmed that my client is updated (and not in Public Preview). It is experiencing the issue with the breadcrumbs disappearing once you open a document in Teams and close it.

Hi @BShipe 


Same thing happens to me all the time - sometimes the breadcrumbs appear, but once I dive down into a folder to a file, the disappear.

Is there a fix for this yet?



Hi @BShipe ! 
I have the exact same issue in both desktop and web Teams app. Can't find why... 

@m-emeraud - Interesting that it's occurring for you in the web app as well! 


Appreciate others posting here to report that they too are experiencing this on their devices. I know that this issue was reported back in late 2021 as well and I guess it was only a matter of time before members of our tenant began to notice it.


I will go ahead and submit a Premier ticket for this to see if that gains traction.

Thanks very much for opening a case with Microsoft! Also thanks for your details and snips above in describing the issue. Made it very easy to follow along and duplicate to confirm the problem

Thanks so much! It's good to be in this community and share the issues and hopefully, fixes!


Replying here with a short update. I had time today to upload the PSR and HAR from one of my problematic devices for the engineer assigned to my Case to review. I'll follow back up in this thread once I have something more substantial to offer, but if anyone stumbles across this thread and happens to have more insight... it sounds like multiple folks out there are experiencing this issue!
We are noticing the same behavior, the bread crumb trail disappears after closing out a file opened in the Teams window. This happens on both Desktop and Web versions, it also happens after clearing the cache.
best response confirmed by Therese_Solimeno (Moderator)
This will be my final update on this item. I closed our MS case late last week after I was suddenly unable to reproduce this issue on my devices, as was the individual in our org that was consistently having the issue.

We did not take any measures beyond obtaining logs and submitting them for review. The only guidance we received prior to closing the case was to take the usual troubleshooting steps and try closing Teams, clearing the cache, etc. -- things I'm sure everyone in this thread has tried before.

I hope this issue works itself out for others here!
It appears that this is resolved now so MS has fixed whatever was wrong. Thanks