Blur Background on Mac OS

Copper Contributor

I am using a Macbook Pro to work remotely.  The blur background feature is helpful, but it appears to be absent in Teams for Mac.  I noticed the blur feature support page says it's not available on Linux yet but does not mention Mac.


I was quite sure they said Mac support was coming at last or the previous year MS Ignite conference.  Am I missing something?


I've tried with my internal Macbook camera and an external logitech, neither of which seem to work.  I have also downloaded the latest release of Teams for Mac.


If this is supposed to be available, what am I missing?


51 Replies


There should be no space after the hyphen.

sysctl -a | grep avx2



@kathysgeek, OK. I get this now:


hw.optional.avx2_0: 0

@ericsarSo you are in the same boat as the rest of us with 2013 era Macbooks.
There is no Avx2.0 so Microsoft disabled all bluring and background features.
There has been no resolution to my knowledge.

@kathysgeek, I see. I found this page in my search for a solution to the message,

hw.optional.avx2_0: 0:


Any thoughts on whether this is worth pursuing?

The authors of the „yices“ app provide two sources: one with AVX2.0 instructions (the dafault) and one without AVX2.0 instructions. So the yices app users are happy as the authors provide an alternative for old HW.
However, this does not help for our background blur unless MS provides an AVX2.0-free solution as well.

Gotcha, @Grandswiss. Thanks for clarifying this. So we'll just have to wait for Microsoft then. Calling MS Teams Team... any chance you can provide an update on this soon? :)



Teams uses the AVX2 cpu capabilities to deliver this visual effect without taxing the cpu or gpu, any alternative would be likely to be unacceptable as your machine would be struggling. Staying with old hardware is fine, but there's a practical limit to how new features will back port.

@Steven Collier 


The fact that Zoom and other similar products easily do background processing on AVX1 processors shows that AVX2 is not's just a decision that the Teams development group have made to not have to code to two versions of the AVX CPU instruction set extensions.  AVX2 introduced 256 bit integers and added FMA (more efficient floating-point operations), so I'm sure that made it somewhat easier to code some of the operations, but it's absolutely not a technical's a decision to orphan somewhat older processors that are still extremely capable for background processing.


The proof is in the pudding:  Zoom flawlessly runs background (video-based, even) processing on the same CPU that Teams refuses to do background processing at all (even where they used to do blurring), with no major stress on the processor.  Zoom does have a reasonable cutoff:  there are combinations of older processors and GPUs where Zoom won't do background processing, but it's a far more appropriate cutoff that doesn't unnecessarily exclude very capable CPUs.


So please don't frame this decision as one that was necessitated by the March of Progress or super creaky old CPUs or something...this is just about the Teams development group not wanting to write additional code to support a previous and marginally older but still extremely capable version of the AVX CPU instruction extensions.

Looks like Microsoft have updated and start accepting again AVX1 computers.

I have a mid-2013 MacBook air that has AVX2 but still cannot use the background, and yes, it was previousy available.



Thanks for this update and the links. However, I didn't see where the fix is, except for what "Alex" says: "We have fixed the issue to enable Background effects and Background Blur for machines with AVX CPUs."


Did I miss something? 



Hi there, late 2014 MBA here without AVX2.0.


I can't see the options on-screen but if I press Shift+Cmd+P during a call my background gets blurred.


Hope it helps.

Kudos to the Teams development group for doing the right thing.  I tested the new version on my Mac Pro (2013), and I can now see the menu item, and all the background effects work like a charm with the processor's AVX 1.0 extensions.

@MontyPyspockwhat version do you use? I have (5.5.2020). Does not seem to work on my MBP, mid2012.



Same here. I have Does not seem to work on my MBP (early 2013), nor do I see the option to do so from the "...".

@doug4772 I got the same result on my MacBook Pro (i5 2018) too. Odd, as AVX2 dates back several years. Turns out there's another command to show extended instruction sets:

sysctl -a | grep machdep.cpu.leaf7_features


Hi @Grandswiss

I have MBP late 2011, and AVX 1.0. It wasn't working for me before, which brought me to this thread. In fact I use Skype and it works perfectly on that as reported by others above. 

Here is what worked for me. 
1. Go to Settings --> General --> tick Disable GPU hardware acceleration (requires restarting Teams)
2. Restart Teams app and on your 1st video call it should give an option to include background effect

Hope it works for you too. :)

@_vyom_this resolved my issue. Thank you! 


I see the following on my MacBook Air (Retina,13-inch, 2018):

$ sysctl -a | grep machdep.cpu.leaf7_features

machdep.cpu.leaf7_features: RDWRFSGS TSC_THREAD_OFFSET SGX BMI1 AVX2 SMEP BMI2 ERMS INVPCID FPU_CSDS MPX RDSEED ADX SMAP CLFSOPT IPT MDCLEAR TSXFA IBRS STIBP L1DF SSBD I have AVX2...I get the feature to Show Background Effects in calls...I see the Backgound Effects sidebar appear. Issue is...I do not get a "/Backgrounds" or "/Backgrounds/Uploads"folder under my  "~/Library/Application/Support/Microsoft/Teams" folder. If I create them...and add a .jpg pic, it does not show up in the Background Effects sidebar...even after restarting Teams. I am on Teams ver is the latest the site lets me download as of Aug 18, 2020.


Just to let you know: With version blur and backgrounds work now even without AVX2. If I execute "sysctl -a | grep -i avx", my older MacBook Pro returns "hw.optional.avx1_0: 1, hw.optional.avx2_0: 0" (=AVX1.0 yes, AVX2.0: no). But it can blur now, what it did not offer in a previous version :)


I have a 2020 MacBook Pro, which I assume has enough graphic processing power to do anything Microsoft would want to throw at it.


If I log out of Teams then join someone else's Teams call as a guest, I have the background blur slider switch available, and it works fine.


If I log into my university email account and join some else's Teams call as a registered user, the background blur option is not available.


For what it's worth.