SOLVED

Azure DevOps connector can't connect to organizations from second tenant

%3CLINGO-SUB%20id%3D%22lingo-sub-358732%22%20slang%3D%22en-US%22%3EAzure%20DevOps%20connector%20can't%20connect%20to%20organizations%20from%20second%20tenant%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-358732%22%20slang%3D%22en-US%22%3E%3CP%3EWe%20have%20two%20tenants%2C%20like%20so%3A%3CBR%20%2F%3E%3CBR%20%2F%3E%3C%2FP%3E%3CUL%3E%3CLI%3ETenant%20A%20at%20tenanta.visualstudio.com%3CUL%3E%3CLI%3EOrganization%20A%3C%2FLI%3E%3CLI%3EOrganization%20B%3C%2FLI%3E%3C%2FUL%3E%3C%2FLI%3E%3CLI%3ETenant%20B%20at%26nbsp%3Btenantb.visualstudio.com%3CUL%3E%3CLI%3EOrganization%20C%3C%2FLI%3E%3C%2FUL%3E%3C%2FLI%3E%3C%2FUL%3E%3CP%3EI%20cannot%20configure%20the%20Azure%20DevOps%20Connector%20to%20connect%20to%20Organization%20C.%3CBR%20%2F%3E%3CBR%20%2F%3EIn%20the%20configure%20form%20I%20have%20my%20account%20selected.%20I%20have%20the%20same%20account%20for%20both%20tenants.%20I%20have%20also%20tried%20adding%20another%20account%2C%20but%20it%20simply%20takes%20me%20through%20SSO%20login%20and%20I%20can't%20select%20the%20other%20tenant.%3CBR%20%2F%3E%3CBR%20%2F%3EIn%20the%20Organization%20drop-down%2C%20I%20only%20see%20Organization%20A%20and%20B.%3CBR%20%2F%3E%3CBR%20%2F%3EPlease%20help.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-358732%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EAzure%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EConnectors%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EDevOps%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EMicrosoft%20Teams%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-358777%22%20slang%3D%22en-US%22%3ERe%3A%20Azure%20DevOps%20connector%20can't%20connect%20to%20organizations%20from%20second%20tenant%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-358777%22%20slang%3D%22en-US%22%3E%3CP%3EYou%20hit%20the%20nail%20on%20the%20head.%20Thank%20you!%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-358752%22%20slang%3D%22en-US%22%3ERe%3A%20Azure%20DevOps%20connector%20can't%20connect%20to%20organizations%20from%20second%20tenant%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-358752%22%20slang%3D%22en-US%22%3EAFAIK%2C%20the%20Devops%2FVSTS%20instance%20and%20the%20Teams%20instance%20have%20to%20be%20in%20the%20same%20AAD%20Tenant%20to%20Connect%3CBR%20%2F%3E%3CBR%20%2F%3E%3CA%20href%3D%22https%3A%2F%2Fmarketplace.visualstudio.com%2Fitems%3FitemName%3Dms-vsts.vss-services-teams%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fmarketplace.visualstudio.com%2Fitems%3FitemName%3Dms-vsts.vss-services-teams%3C%2FA%3E%3CBR%20%2F%3E%3CBR%20%2F%3EHere%20it%20looks%20like%20.Org%20C%20is%20in%20a%20different%20tenant%20so%20it%20looks%20like%20it%20won%E2%80%99t%20connect%20in%20this%20scenario.%3CBR%20%2F%3E%3CBR%20%2F%3EHope%20this%20answers%20your%20question.%3CBR%20%2F%3E%3CBR%20%2F%3EBest%2C%20Chris%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1233270%22%20slang%3D%22en-US%22%3ERe%3A%20Azure%20DevOps%20connector%20can't%20connect%20to%20organizations%20from%20second%20tenant%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1233270%22%20slang%3D%22en-US%22%3E%3CP%3Ethat's%20kind%20of%20a%20lame%20answer%20(aka%2C%20tough%20luck%2C%20not%20gonna%20work)%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20too%20am%20having%20a%20similar%20issue.%26nbsp%3B%20I've%20been%20googling%20around%2C%20I'm%20probably%20having%20the%20same%20problem%2C%20only%20I%20have%20absolutely%20no%20organizations%20to%20see%20(Failed%20to%20find%20an%20organization%20after%20logging%20in%20as%20myself%20(company%20email).%20How%20can%20I%20even%20tell%20what%20tenant's%20I'm%20using%3F%26nbsp%3B%20It%20doesn't%20seem%20to%20be%20very%20easy%20to%20find%20this%20out.%20My%20employer%20has%20several%20tenants%20(you%20can%20guess%20why).%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20installed%20the%20MicrosoftTeams%20powershell%20module%20then%20ran%20connect-microsoftteams.%26nbsp%3B%20There%20i%20see%20my%20tenantid.%26nbsp%3B%20I%20couldn't%20find%20it%20in%20the%20teams%20admin%20portal%2C%20but%20that's%20probably%20because%20I%20don't%20have%20permissions%20(I'm%20guessing).%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ESo%2C%20I%20have%20half%20the%20equation%2C%20I%20know%20my%20teams%20tenantid.%26nbsp%3B%20How%20do%20I%20tell%20the%20tenant%20for%20azure%20devops%3F%20Here%20I%20am%20a%20project%20collection%20admin.%26nbsp%3B%20web%20page%20tells%20me%20nothing%20(in%20organization%20settings).%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1494466%22%20slang%3D%22en-US%22%3ERe%3A%20Azure%20DevOps%20connector%20can't%20connect%20to%20organizations%20from%20second%20tenant%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1494466%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F584589%22%20target%3D%22_blank%22%3E%40marct22%3C%2FA%3E%26nbsp%3B%20Very%20poor%20design.%20Like%20AzDO%20very%20much%2C%20but%20would%20need%20to%20use%20something%20else%20like%20Jira%20-%20team%20needs%20to%20collaborate%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
New Contributor

We have two tenants, like so:

  • Tenant A at tenanta.visualstudio.com
    • Organization A
    • Organization B
  • Tenant B at tenantb.visualstudio.com
    • Organization C

I cannot configure the Azure DevOps Connector to connect to Organization C.

In the configure form I have my account selected. I have the same account for both tenants. I have also tried adding another account, but it simply takes me through SSO login and I can't select the other tenant.

In the Organization drop-down, I only see Organization A and B.

Please help.

4 Replies
Highlighted
Solution
AFAIK, the Devops/VSTS instance and the Teams instance have to be in the same AAD Tenant to Connect

https://marketplace.visualstudio.com/items?itemName=ms-vsts.vss-services-teams

Here it looks like .Org C is in a different tenant so it looks like it won’t connect in this scenario.

Hope this answers your question.

Best, Chris
Highlighted

You hit the nail on the head. Thank you!

that's kind of a lame answer (aka, tough luck, not gonna work)

 

I too am having a similar issue.  I've been googling around, I'm probably having the same problem, only I have absolutely no organizations to see (Failed to find an organization after logging in as myself (company email). How can I even tell what tenant's I'm using?  It doesn't seem to be very easy to find this out. My employer has several tenants (you can guess why).

 

I installed the MicrosoftTeams powershell module then ran connect-microsoftteams.  There i see my tenantid.  I couldn't find it in the teams admin portal, but that's probably because I don't have permissions (I'm guessing).

 

So, I have half the equation, I know my teams tenantid.  How do I tell the tenant for azure devops? Here I am a project collection admin.  web page tells me nothing (in organization settings).

 

Highlighted

@marct22  Very poor design. Like AzDO very much, but would need to use something else like Jira - team needs to collaborate