Audio cuts out when adding someone to a call

Copper Contributor

A couple of our users are having some interesting issues with Teams audio. Here's an example scenario:


Person A calls Person B (or vice versa, doesn't make a difference), and this all works fine, but when either of them add Person C to the call, Person A's audio just completely dies - mic stops working, speakers stop working. This persists even after the call ends, and eventually needs a reboot to go back to normal.


This doesn't happen in pre-arranged Teams meetings, and happens when using both the built in mic/speakers on the laptop, and also on a separate headset/mic combo. It also doesn't happen if Person A is added to an existing call.


I've made sure all the drivers are updated, latest Windows updates and latest version of Teams. Even a re-install of Teams doesn't solve the problem.


Microsoft support have just gone down the route of "recreate the user on the machine", which is not an ideal solution if this happens to more and more of our users.


Has anyone else encountered this before? If so, is there any other way around it that doesn't involve deleting and recreating the user on the machine?

9 Replies
I’ve dealt with many Teams Calling issues, but haven’t encountered this one. Have you identified any commonality between the affected users, i.e. a particular laptop or headset model in use? Does deleting and re-creating the user account actually resolve the issue?
Only commonality is that they both use Dell Latitude 5520 laptops - and I will be recreating one of them on Thursday to see if it actually works, was trying to find another solution that didn't involve that first :)
Both use different headsets as well.
Dell support have also landed on the "recreate the user" response as well, so I guess I better try it.

@MikeWoolcock If A and B are on the same network the call will start as peer to peer, but when you add C then it will switch to being brokered through the cloud. Can you verify that this isn't related to any kind of firewalls? Maybe try it again without being on the company network.

Interesting, I was not aware of that. I will test all of this with the user this afternoon and report back!
I had a good load of tests with the user - connected to our network, connected to a mobile hotspot, other participants on and off the work network, still no luck.

Even tried recreating the user's profile on the laptop, and still no luck.

It's gone back to Microsoft support now, but if it survives a user profile recreation, I'm starting to think it must be some sort of bug within Teams and how it interacts with the audio driver, but that's just a guess atm!

Will see what they come back with.
Hi Mike, any luck in finding a solution for this, I have similar issue with Dell 7420 laptops.
Also seeing the same issue with Dell Latitude 5521. Windows version 21H1. Am going to try upgrading Windows version will report back.
Suspecting something going on with Realtek audio driver in this case maybe.
best response confirmed by MikeWoolcock (Copper Contributor)



I actually did! Funnily enough, it was something I tried previously that didn't work, but when I tried it with Microsoft on the phone, it worked (sod's law innit).


What we did was uninstall Teams through control panel, then delete the Teams folder from the appdata\local and appdata\roaming folders, and basically just deleting any Teams folder that we could find in any Microsoft or Office folder - Program files/Program Data etc, then rebooted and re-installed, and that seemed to do the trick.


Hopefully it works for you!

@MikeWoolcock I have been experiencing the exact same thing on a Dell Latitude 5521.


Adding a third person to an call kills audio. Also, receiving a call from outside my organisation kills audio. One on ones within my organisation work fine.


I can fix it without a reboot by killing teams, then getting Windows to repair the sound drivers, then restarting teams and rejoining the call (unless with outside my organisation which fails repeatedly).


Will try your "clean everything" and re-install now, thank you.