Attaching a gif displays "Sent a gif"


This just started happening recently. When I am chatting with someone and I use the GIF icon to attach a gif, I see the gif just fine until I post the message, at which time the gif goes away and is replaced by a link titled "Sent a GIF". Clicking on the link takes me to the image on 


The person I'm chatting with sees it fine.

Is there a setting for this somewhere? Why is this happening?

37 Replies

Hi @Jeffery Hallett  You might want to follow the suggestions offered in this unverified resource: Fix Microsoft Teams Not Displaying Images and GIFs - Technipages

Thanks for the suggestion. Unfortunately it had no effect.
I also tried the Teams web interface -- same result.
I also tried Teams on two other computers -- same result.
All gifs sent or received appear as link titled "Sent a GIF"
Bump. My entire team is experiencing this issue as well. The only place we seen embedded GIFs properly now is on the Teams mobile app.
The issue occurs for both the Teams Desktop and web apps on all tenants. It started approximately 3-4 days ago.

I'm glad to know I'm not the only one, @mmmoore2288 

This is still an issue for me.

I'm also experiencing this now. Very annoying. It takes away all the fun and expression.

BTW. In my case the recipient doesn't see the gif either. They see a similar link.

Agreed. Both the recipient and the sender only see the "Sent a GIF" message.

We are are a multi-tenant organization, and we've noticed that this only occurs on some of the Azure tenants, not all of them. Some of the tenants we can control as general admin, some we cannot.

We have tried setting the Giphy content settings on the Mircosoft Teams Admin settings to "Not Restricted", but still no change on the tenant we can control. If anyone has any suggestions of what else we might try, I'm happy to give them a shot.

IMPORTANT UPDATE: @Jeffery Hallett and everyone following this thread, our team found something interesting. 


The GIFs only appear to show the problematic "Sent a GIF" message when the originating from Giphy. If you copy in a GIF from another website, like for example, the embedding works.




Thank you @TerpnInMN, but I believe this is a different issue than the thread you referenced.


In this case GIFs are not disabled, but GIFs from specifically are not properly embedded into messages. Instead a "Sent a GIF" message appears for all users on GIFs from, but not for GIFs from other websites.


Below I have pasted all of the settings from the main instance of Teams that my group controls the tenant for. All of the settings appear to be in line with the article you referenced, yet we still have this issue.



best response confirmed by Jeffery Hallett (Contributor)

ANOTHER IMPORTANT UPDATE: @Jeffery Hallett, we have discovered that the issue only occurs for "Guest" users in Teams. Users that are native to the Azure tenant do not see this issue.


Since I have both a native and a guest account on Teams, I was able to test this issue, as shown below.


View from the native tenant account:



View from the guest user account:



Thanks for pointing out this detail, @mmmoore2288 and I have now confirmed your finding.


I am an IT consultant and as such am a Guest on all my clients' Teams. I have brought hundreds of users to Teams but now can't enjoy this simple feature.


It's annoying that this has suddenly popped up. I hope Microsoft adds an adjustable setting for this in the near future.

I have the exact same issue as a guest user on another companys tenant. Also started just very recently (end og august). Suuuper annoying I totally agree!
Same for me having a guest account at Microsoft. I've asked the Teams team about it and will update if/when I get a response.


Same issue here with guest account. But... when you open a "Pop-Up Chat" as separate window, the gifs are working. Could you please verify this, if this also works on your clients?




@herrmeyer yes, having the conversation in an external window works for me as well! Very nicely found :)



Glad to hear it is working... so the question is "why does it work in an external and not in the main window 🤷‍:male_sign:?". O please Microsoft, fix this issue soon. I have many chats and I do not want to open a separate "pop-out chat" for everybody.
+1 here. We also have this same issue for all our guest account users :( We'd also found the pop-out chat to be working as a "workaround"

Please fix this Microsoft, we're having to resort to words to communicate with our partners and it's simply not as effective :D
Same issue for me as a guest user. Would love to see a fix.

By the way... I have this issue for 2-3 weeks now. No update from ms, no response here or anywhere. Did nobody on ms recognize this issue? Or did nobody declarate this as an issue?

If not, where can I sent or place problems to (This is a real question, I don't know where to place issues I am having with ms products)?