Assign a Telephone Service Number to a Resource Account

Occasional Contributor



I want to assign a SfB Online Service number to a Resource Account, but its not working. I cannot assign it via TAC because absolutely no numbers are shown, and I cannot assign it vie SfB Admin Center because this feature is already migrated to the TAC :(


Therefore I tried it vie Powershell, but I get an error:


Set-CsOnlineVoiceApplicationInstance -Identity -TelephoneNumber +34943123412

WARNING: The following Application Instance not present in BVD: f262200f-1696-4421-90b5-3e14d0dbae87
Cmdlet invocation error
+ CategoryInfo : NotSpecified: (:) [Set-CsOnlineVoiceApplicationInstance], CmdletInvocationException
+ FullyQualifiedErrorId : Error processing cmdlet request,Microsoft.Rtc.Management.Hosted.Bvd.SetVoiceAppEndpointC
+ PSComputerName :

Could anybody help? :)




19 Replies

FYI: There is a problem right now at MS with the number assignement of Call Queues. MS is working on that. As a workaround you can use an Auto Attendan instead of a call queue, assigning numbers to AAs is working! ;)





Hi all,


I have the same problem with both IVR & Queue. Waiting resolution of this issue and except requested to transform service number to user number in order to route the office number to Teams user in failover mode I didn't find any workaround (customer migration to Phone System with Calling Plan tomorrow morning !)

In my experience with same licenses on both ressource account (AA/IVR or Queue) I can see service number for Queue but not for AA/IVR. In any case I cannot assign phone number


I assigned Phone System and Calling Plan to Ressource Account as required in this update  I don't know if it's the root cause but for each Ressource Account MCO licenses are always in PendingInput status indefinitely.






Calling Plan = 120 ' FR


ServicePlan ProvisioningStatus
----------- ------------------
MCOPSTN5 PendingInput
MCOEV PendingInput
MIP_S_CLP1 Success
BPOS_S_TODO_2 Success
STREAM_O365_E3 Success
Deskless Success
FLOW_O365_P2 Success
POWERAPPS_O365_P2 Success
TEAMS1 Success
SWAY Success
INTUNE_O365 PendingActivation


@timokli  We are having same issue with both AA's and Call Queues, hope MS fixes this soon.  We just ported two offices and can't get the main numbers working.

@Mark Linman and all-


Same issue here.  I ported a number in as a service number and went to assign it to a call queue.  It would  give me a "saved successful" banner but upon page refresh, the assigned number was gone.  Opened a ticket with MS Support and was simply told it was a provisioning issue (since now we have to temporarily license resource accounts...).  24 hours later the issue persisted.  Off to Google I went.  


Managed to fix it with PowerShell:


Set-CsOnlineApplicationEndpoint -Uri -PhoneNumber +19999999999  


Sent 4 follow up emails to MS Support on my ticket and have yet to receive a response.  Regardless - the above PS fixed the Call Queue issue for me.  Hopefully it will help someone else.

best response confirmed by ThereseSolimeno (Microsoft)

@timokli  when using the search field it is counter-intuitive. Try searching without a + and instead include the area code with spaces i.e. "1 479 555 5555"



We are having the same issue. Ported numbers this past Friday and I'm unable to set those same numbers to the newly created call queue resource accounts. Have been working with Microsoft support and engineers with little progress. If you request new service numbers using Skype legacy portal, those numbers work. Seems to only be happening with ported numbers.


Our current workaround to ensure we are still receiving calls versus line down is to switch the service type numbers to user type numbers and assign them to licensed mailboxes.


A more current conversation taking place here -

@Sebastian Heredia we had the same issue with ported service numbers being down because they couldn't be assigned in Teams anymore (even though number assignment worked the week prior during pre-migration testing). Microsoft support wasn't very responsive, and even sent some PowerShell scripts that didn't work. I finally got the client's main number back online by following these steps.

  1. Create a new resource account using PowerShell with this cmdlet: New-CsOnlineApplicationInstance -UserPrincipalName -ApplicationId “ce933385-9390-45d1-9512-c8d228074e07” -DisplayName "Your Display Name"
  2. Assign licenses to the new resource account in O365 admin.
  3. Wait a few minutes until the license is applied (can take up to 24 hours). If you get the BVD message as in the original post, wait longer. One of our service numbers was immediately available, but another number took overnight to update.
  4. Assign a number to the resource account using this PowerShell cmdlet: Set-CsOnlineVoiceApplicationInstance -Identity -TelephoneNumber +12065555555
  5. Confirm settings using this PowerShell cmdlet: Get-CsOnlineApplicationInstance -Identity The phone number should show up at the bottom.
  6. Go into Teams admin panel and assign the new resource account to the proper call queue or auto attendant.
  7. Test the number (success!)

Hi @Laura Curtis ,


I have created an account and assigned it a domestic calling and msoft e5 account. Is there another license that it needs?



Hi @JP223, not with the E5 license. You'll need E5 plus Domestic Calling, and that's it. If you've got E3, you'll need Domestic Calling plus Cloud PBX. Make sure the resource account is listed as a Service account in Skype for Business Admin. If the number you want to use is not a Service number but a User number, you'll need to email to request they convert the User number to a Service number.



This still seems to be an ongoing issue. I have been through the whole process with MS Support who have been trying to help me assign service numbers to resource accounts. This includes the whole powershell setup as listed in the replies.


Has anyone heard from MS if this is something they are able to fix? I am suprised to see it has been going on for so long. I am lucky as these are routing numbers I need and I had the main numbers setup whilst we were on SfB. I can imagine MS are upsetting alot of customers if they are unable to route their main line numbers.

@David Stowers 

Thanks for this post, this fixed it for me.  Definitely counterintuitive because when you do the search the + sign IS in the results.

Thank you. I have a support ticket open with Microsoft because I could not assign a ported number that had been converted from user to service number for 5 days so far. The issue was that the resource account was assigned to an auto attendant already. Trying to assign the number to the resource account would generate an error. I removed the resource account from the auto attendant after reading your steps, and then it let me assign the number! I then re-applied the resource account to the auto attendant and all applied appropriately.

@David Stowers 


Why is this not at the top of the discussion as the solution.  Thank you, thank you, thank you!!!!

David, you are the man! i cannot beleive MS support did not even mention this, i have had 2 support tickets open, 3 engineers, 2 weeks later and they still couldnt work it out! your message solved it instantly! number assigned to resource account finally!


Thank you.

@bluelights No problem.  They have a lot of holes in the UI side, especially when it comes to searches.  I'm still trying to figure out how to properly do a wild card search in Azure AD.

If you are assigning an onprem/hybrid non-MS number you have to use powershell.

@David Stowers  This is true. you have to avoid + up front when searching numbers. I also noticed that the Resource Account in Office 365 / Azure must have same location as the country of the number. When the Location of the account was US, I could not find polish number. After correction of the location I could. I found it out thanks to Power Shell error notification "The Telephone Number assignment failed. The country of the user’s Usage Location US and the country of the Telephone Number PL do not match."

Yup. Removing the + in the search field worked for me. Thank you! Was banging my head on the wall til I found your post.

Oh my god really 
Is that all it was!

All they need to do is put in a little tip on the screen to say you dont need to include the plus symbol
@David Stowers 

@Laura Curtis I tried using those commands, but PowerShell gives me a message saying 'Set-CsOnlineApplicationEndpoint' is not a recognizable cmdlet.

What do I need to do or install?