Adding MS Planner tab in MS Teams error Failed to update plan


When adding a MS Planner tab to Teams - a user is getting this error "Failed to Update Plan" The tab does not get added to the channel, however a Plan appears in MS Planner only. failedotupdateplan.png

MS Planner:msplannersample.png

Has anyone experienced this - and found a resolution?

7 Replies
I had the exact same problem, seems like a bug to me.
I deleted and created a new channel and that solved the problem for me...

@Thomas_Steibl thank you for the suggestion. We did try deleting and adding a new channel - however the user was still unable to create a planner tab.
We were fortunate that the Team had not been used too much - so we deleted the entire Team and created a new Team - the user can create planner tabs on the new Team.

Something with the original Team was not working - not sure what else would have caused that.


Has anyone else experienced this bug too?


It happened to my colleague too. And he's still not able to add a new planner or even an existing one as a Channel TAB.


@Thomas_Steibl same thing happened to me. I believe this error occurred once I tried to edit the planners that were created in our ms team, on the planner website. I tried to remove access for members from planners that were created within the team, and when I did this the members were removed from the team entirely. I even removed myself from the team by accident and had to be added back in. Then when I was back in the team I could not access any of the planners anymore. I would get the message "You need permission to access this plan" and when I would click the button "request access to group" I would be led to a website that says "the resource cannot be found". When trying to create a new planner for myself in the group I got the same "Failed to create the plan" error you had mentioned. I had to have the other owner of the team (the one who was not deleted from the team) go into their planner website and add me to the planner they created for me from there. Once I was added everything went back to normal. good luck with you and your colleague. 


@Thomas_Steibl It looks as this is a known bug. See (Section Tabs). The workaround: Members do not have a problem to add a planner. Therefore use a user who is member or change the role of your user temporarily. Did that help?



Having the same problem. Also discussed here:


I created many teams with Teams Powershell - i added them directly as Owners (which seems to be the problem).

But now i have the problem that even newly created teams with the same name (naming convention) fail (powershell or client what so ever).



@Lori Brady 

Maybe not the solution for every planner problem out there. But our planner got repaired.

It was the Displayname of the Teams - so if this error arises - rename the Teams name (without copy and pasting it from somewhere).

At the end of our Displayname there was a invisible character. Maybe i copied the name from Excel or a chat into the Displayname field.


Took us (MS and me) a lot time - but it got solved!