Add Members to Private Channels

%3CLINGO-SUB%20id%3D%22lingo-sub-1838488%22%20slang%3D%22en-US%22%3EAdd%20Members%20to%20Private%20Channels%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1838488%22%20slang%3D%22en-US%22%3E%3CP%3EPowershell%20command%20to%20add%20member%20to%20Private%20channel%20stopped%20working%20since%20yesterday.%20we%20are%20also%20not%20able%20to%20add%20members%20using%20Teams%20admin%20pannal.%3C%2FP%3E%3CP%3Ehere%20is%20the%20error%20message%20I%20am%20getting%20when%20I%20try%20to%20add%20members%20to%20Teams%20pricate%20channels.%3C%2FP%3E%3CP%3E%3CSPAN%3EAdd-TeamChannelUser%20%3A%20Error%20occurred%20while%20executing%20Add-TeamChannelUser%20Code%3A%20BadRequest%20Message%3A%20Role%3A%20'member'%20is%20invalid.%20Valid%20values%20are%20'Owner%2C%20Guest'%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1838488%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EMicrosoft%20Teams%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1838700%22%20slang%3D%22en-US%22%3ERe%3A%20Add%20Members%20to%20Private%20Channels%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1838700%22%20slang%3D%22en-US%22%3ESame%20here%2C%20but%20it's%20been%20at%20least%202%20%2F%203%20days%20of%20it%20not%20working.%20Sorry%20I%20can't%20add%20anything%20more%20useful%20to%20the%20conversation.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1840791%22%20slang%3D%22en-US%22%3ERe%3A%20Add%20Members%20to%20Private%20Channels%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1840791%22%20slang%3D%22en-US%22%3EWe%20are%20facing%20the%20exact%20same%20problem.%20We%20really%20hope%20to%20find%20some%20workaround%20as%20we%20have%20time%20pressure.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1843395%22%20slang%3D%22en-US%22%3ERe%3A%20Add%20Members%20to%20Private%20Channels%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1843395%22%20slang%3D%22en-US%22%3EIt%20looks%20like%20we%E2%80%99re%20not%20the%20only%20one.%20There%20is%20a%20Reddit%20thread%20going%20on%20about%20it%3A%3CBR%20%2F%3E%3CBR%20%2F%3E%3CA%20href%3D%22https%3A%2F%2Fwww.reddit.com%2Fr%2FMicrosoftTeams%2Fcomments%2Fjj2yp7%2Farror_addteamchanneluser%2F%3Futm_source%3Damp%26amp%3Butm_medium%3D%26amp%3Butm_content%3Dpost_body%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fwww.reddit.com%2Fr%2FMicrosoftTeams%2Fcomments%2Fjj2yp7%2Farror_addteamchanneluser%2F%3Futm_source%3Damp%26amp%3Butm_medium%3D%26amp%3Butm_content%3Dpost_body%3C%2FA%3E%3CBR%20%2F%3E%3CBR%20%2F%3E%3CBR%20%2F%3E%3C%2FLINGO-BODY%3E
Highlighted
New Contributor

Powershell command to add member to Private channel stopped working since yesterday. we are also not able to add members using Teams admin pannal.

here is the error message I am getting when I try to add members to Teams pricate channels.

Add-TeamChannelUser : Error occurred while executing Add-TeamChannelUser Code: BadRequest Message: Role: 'member' is invalid. Valid values are 'Owner, Guest'

4 Replies
Highlighted
Same here, but it's been at least 2 / 3 days of it not working. Sorry I can't add anything more useful to the conversation.
Highlighted
We are facing the exact same problem. We really hope to find some workaround as we have time pressure.
Highlighted
It looks like we’re not the only one. There is a Reddit thread going on about it:

https://www.reddit.com/r/MicrosoftTeams/comments/jj2yp7/arror_addteamchanneluser/?utm_source=amp&utm...


Highlighted

Anyone found a filed bug-report for this? Or even found any place where we can file this as a bug?  

 

I've done what I could, filed a Documentation bug; 

Add-TeamChannelUser Role Member is invalid · Issue #6781 · MicrosoftDocs/office-docs-powershell (git...