SOLVED
Home

Active Directory Entry out-of-sync when creating new call queues

%3CLINGO-SUB%20id%3D%22lingo-sub-393073%22%20slang%3D%22en-US%22%3EActive%20Directory%20Entry%20out-of-sync%20when%20creating%20new%20call%20queues%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-393073%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20Guys%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI'm%20having%20a%20weird%20issue%20on%20multiple%20tenants.%3C%2FP%3E%3CP%3EWhen%20I'm%20creating%20Call%20Queues%20(both%20via%20PowerShell%20and%20via%20GUI)%2C%20I'm%20getting%20the%20error%20%22Active%20Directory%20Entry%20out-of-sync).%3C%2FP%3E%3CP%3EThe%20queues%20are%20created%20with%20the%20onmicrosoft-domain.%20Sometimes%20this%20happens%20after%20I%20successfully%20created%20around%205%20queues%2C%20sometimes%20it%20happens%20instantly.%26nbsp%3B%3C%2FP%3E%3CP%3EWhen%20this%20happens%2C%20I'm%20also%20receiving%20the%20message%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%22Failed%20to%20save%20your%20call%20queue.%20If%20the%20problem%20continues%2C%20please%20contact%20Microsoft%20Customer%20Service%20and%20Support%22%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAfter%20waiting%201%20day%2C%20I'm%20again%20able%20to%20create%20queues%20without%20issues%20until%20this%20happens%20again.%3C%2FP%3E%3CP%3EI'm%20having%20this%20issue%20on%20multiple%20tenants.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAny%20ideas%20what%20is%20happening%20here%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-393073%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EMicrosoft%20Teams%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESettings%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-393740%22%20slang%3D%22en-US%22%3ERe%3A%20Active%20Directory%20Entry%20out-of-sync%20when%20creating%20new%20call%20queues%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-393740%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F80266%22%20target%3D%22_blank%22%3E%40Ryan%20Steele%3C%2FA%3E%26nbsp%3BIt%20looks%20like%20this%20is%20the%20solution!%20Haven't%20used%20it%20yet%20when%20it%20starts%20to%20block%2C%20but%20the%20command%20seems%20to%20work.%20Thanks!%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-393730%22%20slang%3D%22en-US%22%3ERe%3A%20Active%20Directory%20Entry%20out-of-sync%20when%20creating%20new%20call%20queues%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-393730%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F80266%22%20target%3D%22_blank%22%3E%40Ryan%20Steele%3C%2FA%3E%26nbsp%3BI'm%20going%20to%20check%20this%20upcoming%20friday%20to%20see%20if%20it%20solves%20the%20issue.%3C%2FP%3E%3CP%3EI'll%20come%20back%20to%20you%20with%20the%20result%20!%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-393152%22%20slang%3D%22en-US%22%3ERe%3A%20Active%20Directory%20Entry%20out-of-sync%20when%20creating%20new%20call%20queues%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-393152%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F299317%22%20target%3D%22_blank%22%3E%40Andreas_94-%3C%2FA%3E%26nbsp%3BI've%20seen%20this%20as%20well.%20You%20may%20find%20that%20the%20issue%20is%20strictly%20cosmetic%20and%20does%20not%20affect%20the%20functionality%20of%20the%20call%20queue.%20I%20enquired%20with%20Office%20365%20support%20about%20this%20issue%20and%20was%20given%20the%20following%20PowerShell%20commands%20to%20run%20which%20may%20resolve%20the%20issue%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CH3%20id%3D%22toc-hId-1485098078%22%20id%3D%22toc-hId-1508339738%22%3EAuto%20Attendant%20out%20of%20sync%20error%3C%2FH3%3E%3CPRE%3E%24oaa%20%3D%20Get-CsOrganizationalAutoAttendant%20-PrimaryUri%20%22sip%3Aoaaxxxxxxxxxxxxxxxxxxxxxx%22%3CBR%20%2F%3ESet-CsOrganizationalAutoAttendant%20-Instance%20%24oaa%3C%2FPRE%3E%3CP%3EReplace%20the%20PrimaryURI%20with%20the%20one%20from%20the%20affected%20Auto%20Attendant.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CH3%20id%3D%22toc-hId--1067058883%22%20id%3D%22toc-hId--1043817223%22%3ECall%20Queue%20out%20of%20sync%20error%3C%2FH3%3E%3CPRE%3ESet-CsHuntGroup%20-PrimaryUri%20sip%3Ahg_xxxxxxxxxxxxxxxxxxxxxxxxxxx%3C%2FPRE%3E%3CP%3EReplace%20the%20PrimaryURI%20with%20the%20one%20from%20affected%20Call%20Queue.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Andreas_94-
New Contributor

Hi Guys

 

I'm having a weird issue on multiple tenants.

When I'm creating Call Queues (both via PowerShell and via GUI), I'm getting the error "Active Directory Entry out-of-sync).

The queues are created with the onmicrosoft-domain. Sometimes this happens after I successfully created around 5 queues, sometimes it happens instantly. 

When this happens, I'm also receiving the message:

 

"Failed to save your call queue. If the problem continues, please contact Microsoft Customer Service and Support"

 

After waiting 1 day, I'm again able to create queues without issues until this happens again.

I'm having this issue on multiple tenants. 

 

Any ideas what is happening here?

3 Replies
Solution

@Andreas_94- I've seen this as well. You may find that the issue is strictly cosmetic and does not affect the functionality of the call queue. I enquired with Office 365 support about this issue and was given the following PowerShell commands to run which may resolve the issue:

 

Auto Attendant out of sync error

$oaa = Get-CsOrganizationalAutoAttendant -PrimaryUri "sip:oaaxxxxxxxxxxxxxxxxxxxxxx"
Set-CsOrganizationalAutoAttendant -Instance $oaa

Replace the PrimaryURI with the one from the affected Auto Attendant.

 

Call Queue out of sync error

Set-CsHuntGroup -PrimaryUri sip:hg_xxxxxxxxxxxxxxxxxxxxxxxxxxx

Replace the PrimaryURI with the one from affected Call Queue.

@Ryan Steele I'm going to check this upcoming friday to see if it solves the issue.

I'll come back to you with the result !

Highlighted

@Ryan Steele It looks like this is the solution! Haven't used it yet when it starts to block, but the command seems to work. Thanks!

Related Conversations