Transcripts in dark mode not visible

Brass Contributor

I musst say although not perfect transcripts is an amassing feature, specially since oyu have the Recordings & Transcripts tab in the meeting details panel as part of the Meeting summary. 


now is an user have the Dark mode in teams, the transcripts are not visibel. only after we highlighted content we realized that the text is there, is simply dark as well therefore not readable.


if you jump to the Default Theme, then you can read. is this a known bug ? the text of the transcrips should be white for users who use the Dark Theme in Teams isnt it ? 


The version of teams i am looking at this bug is -> Microsoft Teams Version (64-bit). It was last updated on 12/04/2021.

27 Replies
This bug still exists in Version
This bug exists in the Teams for GCC rollout from this week as well

Bug still there Last updated 14th September 2021.
Download to docx is my workaround till it's fixed.

I check mine it is (64-bit), have tried to manual update several times but said I have the latest version. Check in github, so far the latest preview build version is (64-bit). Check in whatpulse there is dated 14Sept, but sometime you may get the exploration build or continuous deployment build there, so not recomended to get the version there.
Just now I tried to turn on caption in Dark mode, the transcripts appears in white text and clearly seen.

Thanks for the advice. Yes I found out about the version from whatpulse.
I just installed and unfortunately I still have the same issue in Recording & Transcripts, I am not sure how it works for you? When I hover over the text it displays fine for that specific line, but I cannot read the whole transcript, the text is almost the same colour as the background. I have checked and confirmed the version I am on is definitely

For anyone looking to download a specific version you can change the version in this URL:
I used to follow version in whatpulse then download manually if there is new version until I found this
Can you provide a sceenshoot how your transcripts window look like?
This has been a problem for 5 months now? :flushed_face:

Yes, still a problem with me on (64-bit). First time seeing a Transcript today, thought it was really useful... except I had to hover over each line, line by line, to read it.

I'm not an overall fan of dark mode (here, now, observing the Teams site in "eye searing" white), but Teams' design style looks more normal in a dark theme.

With so many people practically being offended by the mere existence, let alone default, of light themes, it's genuinely surprising that MS didn't notice this bug and fix it before shipping. Even more so to still have it a problem 5 months later.

@FalconFour @BlackGS 

Does complete reinstal Teams (with clearing app cache) can solve it?

Mine works just fine.

Screenshot (10).png

What windows do you use? I tried in win 10 & 11Beta both are fine. 

How if you change the windows theme colour, will do anyhting to the text?

This bug still there in v (64-bit). :( only recently started on my desktop


I have a similar issue, but not with transcripts just general chat text.
When text is copied from other (usually Microsoft related) sources, it isn't always visible when I'm in dark mode. If it switch to light mode, the text displays.



As you can see, the first part of the sentence displays in dark mode but not the second part. No issue in light mode.

I'm using MS Teams (64-bit)

I also just tried the browser version (in MS Edge) and the same thing happens.

@Alphons68 I get the same definitely in public preview, plus sometimes my arrow keys stop working. Plus SharePoint tabs prompt for login, but its is public preview. 


What I do with text like this is highlight it and click on the font colour and hit automatic fixes it. I know not ideal but that's my quick fix for that 





Still a thing in version Just got a chat with this issue a few minutes ago. I could just barely see the text in dark mode (my default). Looks totally fine in light mode.




Right same experience here, No long-term fix yet 🤷‍:male_sign:
Was there ever a solution to this? This thread hasn't been touched in 6 months. Here is my Teams version. You have Microsoft Teams Version (64-bit). It was last updated on 2/12/2022.
I have not seen it fixed yet
my version is Version (64-bit), and i have not seen it resolved either
Does anyone know is it fixed for any latest Teams versions?
It has not. My last teams update is from 02/28/2022 v. (64 bit)