Click to call (tel:) links not working

Copper Contributor

Recently switched over to the Teams Preview and noticed that the click to call (Teams Voice) functionality doesn't seem to be working.

 

mrsikora_0-1680195954812.png

 

Selecting "Microsoft Teams (work preview), pops up the following in Teams:

 

mrsikora_1-1680196086168.png

 

When I click "Call", it simply closes the modal without any action (equivalent of clicking "Cancel"). Prior to the Public Preview, it would make the call.

 

Any others experiencing this?

 

Would figure that this is a pretty standard functionality that they would have worked on from the onset.

 

Perhaps something broke it?

16 Replies
Same behavior for deep links.
Office Integration: No reaction, if you click "Call" Icon in Outlook Contact card. Chat icon in Outlook contact card works, it opens chat window to this contact.
There’s still quite a bit being worked on for the new Teams. There’s some general info here: https://adoption.microsoft.com/en-us/new-microsoft-teams/

If it’s a feature you’re using regularly as part of your critical workflow, it’s probably worth switching back.
Any workaround to this issue yet?

@Alessio Pagni Not that I'm aware of. Just waiting on their standard updates. Worst case I would guess in the fall when product is formally released.

I hope, this will work when "deep links" in general are implemented.

we still have this issuein our company - somebody had a solution for this?

@Greysi 

@PascalJung Haven't seen or found a solution so I reverted back to the current release. Hopefully this PRE release will be made final in the next couple months. It's definitely better, but I notice a number of functions that don't work and were helpful to me.

In Teams Log (Ctrl+Alt+Shift+1) summary.txt, you can see following error, when trying to dial a phone number from outlook contact card:

Latest errors for XXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX
2023-09-05T11:13:39.479Z Err OfficeIntegration: Failed to start call
2023-09-05T11:13:39.468Z Err resolverUncaughtErrorBoundary__doNotAssignToGraphQLTeam: Uncaught error in a GraphQL resolver, at field selection path: getUsers

for me, this indicates, an issue in new Teams client.
Click to call now works in the last two latest releases of Teams... the most recent PRE and now NEW.
What version? Cause Mine's still busted.
Teams version 23217.806.2340.1703.

* In the windows search bar type "default apps" and click "Enter."
* On the right side where it says "Enter a file type or link type" type "tel" and "Enter."
* Under that you should see if you have a default app set up for "tel" links. Make sure that it is set up for the most current Teams app which is "Microsoft Teams (work or school)" for me.
For me, it's clicking any URL's on website tabs / sharepoint lists from user cards that won't let me chat or call anyone. Works fine from edge itself. It's like Teams doesn't allow the links to be clicked just a blank screen.

@mrsikora thanks for the hint.

I've tried your suggestion and seems something better, but..

  • tel:<phone number> (like tel:+123456789) is working
  • tel:<other user's sip uri> (like tel:email address removed for privacy reasons) is not working, as it seems the client places a call to +email address removed for privacy reasons

 

Anyway, the protocol handler version used by the previous client version was callto: . Is it known whether callto: will be added to the new client as well?

@rum80 I don't know anything about emails in the tel: field. I believe that's only for phone numbers. Their mich be another protocol like callto: as you mentioned to handle. Have you tried adding teams to that also?

Searched and there was another question on this and MS said it doesn't support callto: with the following "solution":

Post: https://learn.microsoft.com/en-us/answers/questions/1179266/callto-working-in-teams
Link to solution: https://learn.microsoft.com/en-us/microsoftteams/platform/concepts/build-and-test/deep-link-workflow...

It seems that is not working properly yet. We have contacts stored in E.164 format, when we click on it the new Teams strip the +, and as a result the called number is wrong (+39 39 xxx). Do you know if is there a solution for this?