Azure Bot not available after updating to New Teams "You cannot send messages to this bot"

Copper Contributor

Ever since switching to the new teams, I've been unable to chat with any of the Azure Bots we've created. Part of our business is creating custom bots for our customers, but we're starting to get more and more complaints that they experience the same thing.


In the 'classic' teams, we don't see this message, and everything works as expected. We can also receive messages in the new teams, we only can't send messages in the new teams.


Does anyone have any idea how we could solve this?




5 Replies
I am facing the same and there are few more others who have opened threads at the tech community about it; but nothing so far.

One workaround though, did your users try from the phone app? that works for me. Another is on the desktop app, right click on the bot (via the …. at the context menu) and click ‘Mark as unread’ . That would allow users to send messages to the bot through the desktop app for sometime.

@bbagaria thanks for the suggestion, we indeed tried that, and that does still work. Also the web version of teams works, in case you were unaware (that might be a slightly more convenient way for customers using their PC).

The interesting thing I forgot to mention is that we have about 10 bots created through Azure Bots, and 2 through the BotFramework. And somehow, one of the two created through the bot framework IS available in the new teams. I have been comparing all settings I could find, and haven’t been able to find any differences, but this means that there is probably some other workaround somewhere…

Oh! for me neither web nor new or old teams works. Its a dead end. With an outage like this I really am loosing hope on azure bot services. I have a support ticket also opened, but support has no clue of it.

I tried PVA as well in the past and half of the documented things in PVA are not supported. I have a feeling that its time to look at a better stable platform then to MS.
Interesting! Maybe something in the publishing (manifest) settings?
My 4 bots aren't published as an app, I've just shared the direct link with a few people in my organization. I thought this was the problem, but, apparently, no :\
Mine are not published as app either. Its via the direct link.