I cannot use Teams... I am losing my mind trying to

Copper Contributor

I tried to post this discussion under my work email Teams account and it does nothing. When registering to post a discussion, I am presented with two accounts to choose from, I select my work one, and it just refreshes to the same page. Hence I'm posting from my personal account. That issue is frustrating and makes no sense but is secondary to the following...

 

When I receive a Teams invite from a client, in the last couple of months I have been having problems getting in. It goes around in a massive pointless circle. I click the invite link, I chose the option to 'Open Microsoft Teams'. I get a box with the message 'You're missing out! Ask your admin to enable Microsoft Teams for *my work email address*. It says I'm currently signed in on my work email address and to 'Select Sign up for Teams to continue'.

 

So I click that then enter my work email address and it says 'Looks like you're using a work or school account' and to sign in. So I click 'Sign In' and it gives me a box 'Welcome to Microsoft Teams!' and the option to Continue as *my work email address*. So I choose that and it goes right back to 'You're missing out!'.

 

How on earth am I supposed to use Teams to collaborate with my clients?!! There is no one else but me in my business, there is no IT Admin to check with. Can someone please help?!!

5 Replies

H, I'm having the same problem

Sorry to hear this!

On which platform you are seeing these issues? Also, for your work email address, are you paying for Teams or have been using Microsoft Teams Free (classic) before?

Miikka (Teams PM)

@Miikka Oksanen 

Running Teams in Windows 10.

I have been using Teams (Free classic it appears) for 3-4 years with no problems - suddenly, for one client only, I am told that I cannot connect as "The account you're using doesn't have access to this meeting. Sign in with the account the invite was sent to and try again". A colleague that uses a completely separate account (from a different company) also had this same issue. 

I tried "upgrading" from Classic Free to the current Free version but this didn't seem to make any difference. As it was important to join the series of meetings I ended up upgrading to the "essentials" version - and low and behold suddenly my account did have access to the meeting!

So - I regard this as a Microsoft induced issue to force from a free to a paid for version. As soon as this series of meeting have concluded I will be deleting Teams and cancelling my subscription, falling back on Zoom which doesn't seem to care what account I am logging in with.

Try creating a separate profile in Edge explorer.
Don't, and never have used Edge explorer. Don't understand why this would help unless MS deliberately blocks none Edge users in this way.