MP4 audio only, video is blank/black

Occasional Visitor

Hello, perhaps this is a bug or pilot error, we'll see.

 

I'm running Windows 11.  On both Firefox and Chrome, some recently sharepoint shared MP4 videos (HEVC encoding) that I uploaded manually are not displaying their video, but the audio plays fine.  In the upper left of the player page is reads "Stream", so hopefully I am reaching the right community.  The curious/suspicious/embarrassing/infuriating thing is when I enable "Noise suppression" on the player, the video is displayed along with muted/garbled audio whenever music plays.

If I download the video file from Sharepoint, I can play it locally with VLC or Windows Media properly.

The magic "just works" formula I am searching for here is:  Noise suppression=false + playing video frames=true + streaming=true.  ;)  Is there a non-player mode/parameter I could toggle on a share link that would let the browser do the streaming on the video file directly?

 

Thanks,
Dave Woldrich

9 Replies

@ProvokerDave - Sorry you ran into this problem. I think you've figured out what's going on, thanks for the investigation it helps us narrow down what's happening.

 

Our player tries to figure out the best way to play the video depending on a bunch of factors. It seems like it thought it could play it via progressive download (which means it relies on the browser/OS to directly play the video), but in this case it seems that your video doesn't actually play via progressive due to your browser/OS combo. It should have picked adaptive bitrate streaming or should have fallen back to it upon detection of an error. But that didn't happen either it seems. 

 

As a workaround if you create your share link as a "View" and "Block download" then it FORCES our player to do adaptive bitrate streaming for someone with that access. (Assuming the person doesn't also have edit access through some other SP permissions, as SP permissions are additive).

 

Would it be possible for you to share the actual video that has the problem or make a new one that has the same problem and open up a support ticket? If you can get the problem video to our support team they can route it up to us in the Product Group and we can dig deeper into how we can fix this and make sure the right thing happens. 

 

@Marc Mroz Hi Marc, I had exactly the same problem today and your workaround worked for me.

 

I would be able to provide you with the "faulty" video file for further investigation to fix the issue, if you like.

You could open a support ticket or have your admin do that. Or you could see if you can get me the problematic video via direct message here on the tech community.

@Marc Mroz 

Are you any closer to a solution on this one, or in need of a(nother) sample video?

I'm having the same issue with a HEVC video - toggling Noise Suppression on and back off makes it work, but obviously I'd prefer it to 'just work'.

@Phil_Temple-Watts - If you could open a support case and get them the video with the issue and you have the support person escalate the case to the Stream product group, one of our engineers could debug with your specific video to see if we can figure out what the issue is. 

I've sent through the video - hopefully the support agent will bring it to the attention of the Stream product group.

 

The case number is 1049091592.

@Phil_Temple-Watts - I checked with our support team here inside Microsoft and they are saying that case number isn't a valid case number for Microsoft Support. Is there a different case number you can share? 

@Marc Mroz 

I'm not sure what to tell you...

@Marc Mroz 

I checked the link where I uploaded the video, and there was nothing there, so who knows where the case went. The link to it still brings up the chat transcript, but I won't post it here as it includes my mobile number.

 

A sample video is attached.