SOLVED

Unable to Publish

%3CLINGO-SUB%20id%3D%22lingo-sub-79476%22%20slang%3D%22en-US%22%3EUnable%20to%20Publish%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-79476%22%20slang%3D%22en-US%22%3E%3CP%3EI%20have%20uploaded%20a%20video%20my%20orgs.%20Stream%20site%20so%20it%20now%20sits%20in%20the%20My%20Video%20section%20and%20I%20can%20watch%20it.%26nbsp%3B%20However%2C%20when%20I%20click%20the%20Publish%20Now%20button%20or%20link%2C%20the%20cursor%20briefly%20changes%20to%20a%20no%20entry%20sign%20and%20nothing%20happens!%26nbsp%3B%20There%20is%20no%20feedback%20like%20error%20messages.%26nbsp%3B%3C%2FP%3E%3CP%3EDo%20i%20need%20to%20be%20assigned%20a%20specific%20role%20or%20function%20to%20be%20able%20to%20publish%20videos%20to%20my%20organisation%3F%26nbsp%3B%20It%20looks%20like%20I%20am%20the%20first%20person%20in%20my%20org.%20to%20use%20the%20Stream%20service.%3C%2FP%3E%3CP%3EThanks%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-79476%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ECreate%20Content%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EGeneral%20questions%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-79483%22%20slang%3D%22en-US%22%3ERe%3A%20Unable%20to%20Publish%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-79483%22%20slang%3D%22en-US%22%3E%3CP%3EThanks%20for%20all%20of%20your%20investigations.%26nbsp%3B%20Yes%20I%20did%20not%20mention%20that%20I%20was%20inside%20a%20firewall%20as%20the%20video%20uploaded%20OK.%26nbsp%3B%20I%20have%20passed%20on%20your%20suggestions%20to%20our%20IT%20department%20and%20I%20will%20test%20the%20Publish%20action%20again.%26nbsp%3B%20I%20would%20like%20to%20keep%20using%20this%20service%20in%20our%20business%20so%20this%20would%20be%20a%20blocker.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-79481%22%20slang%3D%22en-US%22%3ERe%3A%20Unable%20to%20Publish%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-79481%22%20slang%3D%22en-US%22%3E%3CP%3EHi%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fpowerusers.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F9641%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3E%40Man1x%3C%2FA%3E%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAfter%20further%20investigation%20we%20do%20believe%20your%20organization%20network%20has%20a%20firewall%20or%20proxy%20server%20that%20is%20intercepting%20and%20manupulating%20traffic%20in%20a%20way%20that%20it%20breaks%20Microsoft%20Stream%20functionality.%20More%20specifically%2C%20HTTP%20PATCH%20requests%20(and%20possibly%20DELETE)%20are%20being%20modified%20by%20the%20proxy%20in%20a%20way%20that%20make%20them%20invalid%20when%20received%20by%20our%20service.%20It%20looks%20like%20this%20may%20happen%20with%20firewall%20devices%2Fservers%20which%20are%20not%20up-to-date%20with%20HTTP%20standards.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAt%20this%20time%20the%20only%20recommendation%20we%20have%20is%20to%20contact%20your%20IT%20adminstrator%20about%20this%20issue%20and%20verify%20the%20possibility%20to%20upgrade%20your%20proxy%2Ffirewall%20software%20or%20change%20its%20rules%20in%20a%20way%20it%20doesn't%20intercept%20traffic%20to%20*.microsoftstream.com%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%20Thanks%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E-Rodrigo%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-79480%22%20slang%3D%22en-US%22%3ERe%3A%20Unable%20to%20Publish%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-79480%22%20slang%3D%22en-US%22%3E%3CP%3EHey%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fpowerusers.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F9641%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3E%40Man1x%3C%2FA%3E%2C%26nbsp%3Bwe%26nbsp%3B%3CEM%3Eare%3C%2FEM%3E%20in%20fact%20seeing%20your%20requests%20on%20the%20back-end%2C%20but%20there%20are%20some%20strange%20things%20we%20are%20seeing.%20%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EFor%20starters%2C%20the%20HTTP%20requests%20that%20are%20expected%20to%20be%20PATCH%20are%20coming%20in%20as%20%22METHOD_OTHER%22%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAre%20you%20by%20chance%20running%20behind%20some%20sort%20of%20proxy%2Ffirewall%20that%20could%20be%20adding%20headers%20to%20your%20requests%3F%26nbsp%3B%20We%20are%20also%20seeing%20a%20buch%20of%20%22X-SSL%22%20related%20headers%20that%20we%20are%20not%20used%20to%20seeing%20from%26nbsp%3Busers.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-79479%22%20slang%3D%22en-US%22%3ERe%3A%20Unable%20to%20Publish%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-79479%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%20still%20not%20publishing%2C%20so%20here%20is%20my%20Session%20ID%3A%3C%2FP%3E%3CDIV%20class%3D%22ngdialog%20dialog-box%20about-dialog-box%20ng-scope%22%3E%3CDIV%20class%3D%22ngdialog-content%22%3E%3CDIV%20class%3D%22dialog-container-outer%20row%20row-size0%22%3E%3CDIV%20class%3D%22dialog-container%20column%20large-centered%20large-8%20medium-centered%20medium-10%20small-centered%20small-11%22%3E%3CDIV%20class%3D%22dialog-content%22%3E%3CDIV%20class%3D%22row%22%3E%3CDIV%20class%3D%22column%20x-small-12%22%3E%3CDIV%20class%3D%22data-container%22%3E%3CDIV%3E%3CSPAN%20class%3D%22ng-binding%22%3E5c0b89d7-8f0e-467b-b878-410b8e379bcb%3C%2FSPAN%3E%3C%2FDIV%3E%3C%2FDIV%3E%3C%2FDIV%3E%3C%2FDIV%3E%3C%2FDIV%3E%3C%2FDIV%3E%3C%2FDIV%3E%3C%2FDIV%3E%3C%2FDIV%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-79478%22%20slang%3D%22en-US%22%3ERe%3A%20Unable%20to%20Publish%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-79478%22%20slang%3D%22en-US%22%3E%3CP%3EHi%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fpowerusers.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F9641%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3E%40Man1x%3C%2FA%3E%2C%20could%20you%20please%20help%20us%20with%20some%20more%20information%3C%2FP%3E%0A%3CUL%3E%0A%3CLI%3ETry%20publishing%20again%2C%20if%20it%20fails%3C%2FLI%3E%0A%3CLI%3EClick%20on%20the%20%22%3F%22%20in%20the%20top%20left%20part%20of%20navigation%20header%2C%20click%20%22About%20Microsoft%20Stream%22.%26nbsp%3B%3C%2FLI%3E%0A%3CLI%3EOn%20the%20screen%20that%20shows%20up%2C%20please%20note%20your%20session%20ID%20and%20share%20with%20us%20so%20that%20we%20can%20look%20up%20logs%20to%20see%20what's%20happening.%3C%2FLI%3E%0A%3C%2FUL%3E%0A%3CP%3Ecc%3A%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fpowerusers.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F1079%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3E%40adarsh%3C%2FA%3E%3C%2FP%3E%0A%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20451px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F16124iF3358F7FBB77673E%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22About.png%22%20title%3D%22About.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1548107%22%20slang%3D%22en-US%22%3ERe%3A%20Unable%20to%20Publish%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1548107%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F42102%22%20target%3D%22_blank%22%3E%40Vishal%20Sood%3C%2FA%3E%26nbsp%3BI'm%20having%20this%20same%20issue%2C%20session%20ID%20is%26nbsp%3B%3CSPAN%3E0d46bf22-d6a2-466c-ac44-e7a18007d769.%20I've%20uploaded%20this%20video%20several%20times%20and%20for%20some%20reason%20it%20won't%20publish.%20Can%20you%20please%20help%3F%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
New Contributor

I have uploaded a video my orgs. Stream site so it now sits in the My Video section and I can watch it.  However, when I click the Publish Now button or link, the cursor briefly changes to a no entry sign and nothing happens!  There is no feedback like error messages. 

Do i need to be assigned a specific role or function to be able to publish videos to my organisation?  It looks like I am the first person in my org. to use the Stream service.

Thanks

6 Replies
Highlighted

Hi @Man1x, could you please help us with some more information

  • Try publishing again, if it fails
  • Click on the "?" in the top left part of navigation header, click "About Microsoft Stream". 
  • On the screen that shows up, please note your session ID and share with us so that we can look up logs to see what's happening.

cc: @adarsh

About.png

 

Highlighted

Hi, still not publishing, so here is my Session ID:

5c0b89d7-8f0e-467b-b878-410b8e379bcb

Hey @Man1x, we are in fact seeing your requests on the back-end, but there are some strange things we are seeing.  

 

For starters, the HTTP requests that are expected to be PATCH are coming in as "METHOD_OTHER"

 

Are you by chance running behind some sort of proxy/firewall that could be adding headers to your requests?  We are also seeing a buch of "X-SSL" related headers that we are not used to seeing from users.

Highlighted
Best Response confirmed by anonymous-user (Regular Contributor)
Solution

Hi @Man1x,

 

After further investigation we do believe your organization network has a firewall or proxy server that is intercepting and manupulating traffic in a way that it breaks Microsoft Stream functionality. More specifically, HTTP PATCH requests (and possibly DELETE) are being modified by the proxy in a way that make them invalid when received by our service. It looks like this may happen with firewall devices/servers which are not up-to-date with HTTP standards.

 

At this time the only recommendation we have is to contact your IT adminstrator about this issue and verify the possibility to upgrade your proxy/firewall software or change its rules in a way it doesn't intercept traffic to *.microsoftstream.com

 

  Thanks,

 

-Rodrigo

Highlighted

Thanks for all of your investigations.  Yes I did not mention that I was inside a firewall as the video uploaded OK.  I have passed on your suggestions to our IT department and I will test the Publish action again.  I would like to keep using this service in our business so this would be a blocker.

Highlighted

@Vishal Sood I'm having this same issue, session ID is 0d46bf22-d6a2-466c-ac44-e7a18007d769. I've uploaded this video several times and for some reason it won't publish. Can you please help?