Streams URL not working with www

%3CLINGO-SUB%20id%3D%22lingo-sub-1540919%22%20slang%3D%22en-US%22%3EStreams%20URL%20not%20working%20with%20www%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1540919%22%20slang%3D%22en-US%22%3E%3CP%3EWondering%20if%20anything%20has%20changed%20wrt%20to%20steams%20url.%26nbsp%3B%20It%20used%20to%20be%20possible%20to%20access%20stream%20via%202%20URLs%3A%26nbsp%3B%3C%2FP%3E%3CP%3E-%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fweb.microsoftstream.com%2F%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%22%3Ehttps%3A%2F%2F%3CSTRONG%3Eweb%3C%2FSTRONG%3E.microsoftstream.com%2F%3C%2FA%3E%3C%2FP%3E%3CP%3E-%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fweb.microsoftstream.com%2F%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%22%3Ehttps%3A%2F%2F%3CSTRONG%3Ewww%3C%2FSTRONG%3E.microsoftstream.com%2F%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAs%20of%20the%20last%20few%20days%2C%20looks%20like%20new%20videos%20that%20are%20uploaded%20are%20not%20accessible%20via%20the%20%3CSTRONG%3Ewww%3C%2FSTRONG%3E%20URL.%26nbsp%3BBut%20seems%20to%20work%20fine%20for%20previously%20uploaded%20videos.%26nbsp%3B%20The%20error%20in%20the%20browser%20console%20is%20related%20to%20CORS.%26nbsp%3B%20All%20seems%20to%20work%20fine%20when%20I%20turn%20on%20CORS%2C%20however%2C%20it%20was%20not%20previously%20required.%26nbsp%3B%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20main%20issue%20here%20is%20that%20audit%20logs%20for%20stream%20report%20the%20URL%20with%20www%2C%20so%20it%20becomes%20inconsistent%20comparing%20the%20video's%20actions.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHas%20anyone%20run%20into%20this%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1541034%22%20slang%3D%22en-US%22%3ERe%3A%20Streams%20URL%20not%20working%20with%20www%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1541034%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F737683%22%20target%3D%22_blank%22%3E%40vesper2000%3C%2FA%3E%26nbsp%3B%20Can%20reproduce%20your%20problem.%20Seams%20the%20%22www%22%20should%20be%20replaced%20by%20%22web%22%20in%20the%20Audit%20logs.%20Reported%20an%20issue!%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1541186%22%20slang%3D%22en-US%22%3ERe%3A%20Streams%20URL%20not%20working%20with%20www%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1541186%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F15303%22%20target%3D%22_blank%22%3E%40Tomislav%20Karafilov%3C%2FA%3E%26nbsp%3BThank%20you!%3C%2FP%3E%3CP%3EDo%20you%20have%20a%20link%20where%20I%20can%20track%20the%20status%20of%20the%20issue%3F%26nbsp%3B%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1541231%22%20slang%3D%22en-US%22%3ERe%3A%20Streams%20URL%20not%20working%20with%20www%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1541231%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F737683%22%20target%3D%22_blank%22%3E%40vesper2000%3C%2FA%3E%26nbsp%3B%20Sorry%2C%20no!%20I%20will%20come%20back%20here%20if%20I%20get%20response!%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1542252%22%20slang%3D%22en-US%22%3ERe%3A%20Streams%20URL%20not%20working%20with%20www%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1542252%22%20slang%3D%22en-US%22%3E%3CP%3EInterestingly%20enough%2C%20my%20Stream%20videos%20default%20to%20the%20%22web%22%20prefix%2C%20but%20I%20am%20now%20having%20to%20replace%20that%20with%20%22www%22%20to%20get%20them%20to%20work.%20I%20can't%20access%20anything%20related%20to%20MS%20Stream%2C%20including%20the%20main%20page%20without%20replacing%20web%20with%20www.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
New Contributor

Wondering if anything has changed wrt to steams url.  It used to be possible to access stream via 2 URLs: 

https://web.microsoftstream.com/

https://www.microsoftstream.com/

 

As of the last few days, looks like new videos that are uploaded are not accessible via the www URL. But seems to work fine for previously uploaded videos.  The error in the browser console is related to CORS.  All seems to work fine when I turn on CORS, however, it was not previously required.  

 

The main issue here is that audit logs for stream report the URL with www, so it becomes inconsistent comparing the video's actions.

 

Has anyone run into this?

4 Replies

@vesper2000  Can reproduce your problem. Seams the "www" should be replaced by "web" in the Audit logs. Reported an issue!

@Tomislav Karafilov Thank you!

Do you have a link where I can track the status of the issue?  

@vesper2000  Sorry, no! I will come back here if I get response!

Interestingly enough, my Stream videos default to the "web" prefix, but I am now having to replace that with "www" to get them to work. I can't access anything related to MS Stream, including the main page without replacing web with www.