SOLVED

Stream webpart for Sharepoint 2013 or 2016 on-prem

%3CLINGO-SUB%20id%3D%22lingo-sub-131598%22%20slang%3D%22en-US%22%3EStream%20webpart%20for%20Sharepoint%202013%20or%202016%20on-prem%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-131598%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20everyone%2C%3C%2FP%3E%0A%3CP%3EIs%20there%20any%20update%20regarding%20the%20availability%20of%20a%20Stream%20webpart%20running%20on%20on-prem%20Sharepoint%202013%20or%202016%20%3F%3C%2FP%3E%0A%3CP%3EThanks.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-354738%22%20slang%3D%22en-US%22%3ERe%3A%20Stream%20webpart%20for%20Sharepoint%202013%20or%202016%20on-prem%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-354738%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F186004%22%20target%3D%22_blank%22%3E%40Mary%20Marasco%3C%2FA%3E%26nbsp%3B%20-%20Hi%20Mary.%20Did%20you%20get%20any%20resolution%20on%20this%20issue%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F114%22%20target%3D%22_blank%22%3E%40Marc%20Mroz%3C%2FA%3E%26nbsp%3B%20-%20Marc%2C%20are%20you%20able%20to%20help%20with%20this%20at%20all%3F%20On%20a%202013%20SP%20team%20site%2C%20the%20embed%20code%20only%20seems%20to%20work%20in%20Chrome%20and%20not%20IE11.%20Do%20you%20know%20if%20a%20fix%20will%20be%20applied%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EJames%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-312611%22%20slang%3D%22en-US%22%3ERe%3A%20Stream%20webpart%20for%20Sharepoint%202013%20or%202016%20on-prem%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-312611%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F114%22%20target%3D%22_blank%22%3E%40Marc%20Mroz%3C%2FA%3E%26nbsp%3BI%20know%20the%20issue%20from%202017%20was%20fixed%2C%20however%20I%20have%20an%20issue%20happening%20now.%20SP2013%2C%20running%20on%20IE11%20and%20the%20embedded%20Stream%20video%20does%20not%20show%20(actually%20nothing%20shows%20in%20that%20space)%2C%20but%20the%20same%20SP2013%20site%20brought%20up%20in%20Chrome%20works%20just%20fine.%26nbsp%3B%20I%20did%20a%20bit%20of%20research%20and%20someone%20said%20to%20add%20the%20MS%20Stream%20URL%20to%20our%20trusted%20sites%20in%20IE......%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-133698%22%20slang%3D%22en-US%22%3ERe%3A%20Stream%20webpart%20for%20Sharepoint%202013%20or%202016%20on-prem%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-133698%22%20slang%3D%22en-US%22%3E%3CP%3EJust%20to%20confirm%20that%26nbsp%3BStream%20on%20our%20tenant%20(Europe)%20has%20been%20updated%20the%20last%20week-end%20to%20version%201.0.930.10%20and%2C%26nbsp%3Bas%20announced%20by%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F114%22%20target%3D%22_blank%22%3E%40Marc%20Mroz%3C%2FA%3E%2C%20it%20fixed%20the%20embed%20Stream%20video%20issues%20on%20both%20our%20on-prem%20SP%202013%20and%20SP%202016!%3C%2FP%3E%0A%3CP%3EThanks%20a%20lot.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-132343%22%20slang%3D%22en-US%22%3ERe%3A%20Stream%20webpart%20for%20Sharepoint%202013%20or%202016%20on-prem%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-132343%22%20slang%3D%22en-US%22%3EMany%20thanks%20Marc%20for%20this%20explanation%20and%20the%20previous%20one.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-132046%22%20slang%3D%22en-US%22%3ERe%3A%20Stream%20webpart%20for%20Sharepoint%202013%20or%202016%20on-prem%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-132046%22%20slang%3D%22en-US%22%3E%3CP%3EAdding%20the%20answer%20to%20your%20other%20issue%20about%20Full%20screen.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3ESince%20your%20page%20is%20in%20IE10%20document%20mode%20(SP%20sets%20that%20in%20the%20page%20header)%2C%20full%20screen%20on%20any%20iframe%20is%20not%20supported.%20Support%20for%20taking%20iframes%20full%20screen%20is%20in%20IE11%20document%20mode%20and%20beyond%20only.%20This%20is%20a%20limitation%20of%20the%20older%20render%20engine%20of%20IE10%20mode.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-132044%22%20slang%3D%22en-US%22%3ERe%3A%20Stream%20webpart%20for%20Sharepoint%202013%20or%202016%20on-prem%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-132044%22%20slang%3D%22en-US%22%3E%3CP%3EThe%20screenshot%20you%20attached%20is%20a%20bug%20we%20have%20already%20fixed%20but%20didn't%20deploy%20yet.%20It%20was%20an%20issue%20with%20how%20our%20embed%20renders%20on%20IE%20when%20the%20page%20forces%20IE10%20document%20mode%20(which%20SP%20pages%20do).%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EThe%20fix%20should%20be%20headed%20out%20to%20Production%20in%20our%20next%20round%20of%20releases%20which%20happen%20every%20few%20weeks%20or%20so.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-131782%22%20slang%3D%22en-US%22%3ERe%3A%20Stream%20webpart%20for%20Sharepoint%202013%20or%202016%20on-prem%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-131782%22%20slang%3D%22en-US%22%3E%3CP%3EThanks%20for%20your%20answer%20Marc.%3C%2FP%3E%0A%3CP%3EActually%20I%20already%20tried%20to%20embed%20some%20Stream%20videos%20into%20our%20on-prem%20SP%20thanks%20to%20the%20iFrame.%20However%20I'm%20getting%20weird%20behaviors%3A%20there%20are%20some%20graphical%20disposition%20issues%20of%20the%20video%20control%20icons%20(please%20see%20attached%20screenshot%2C%20issues%20are%20highlighted%20in%20magenta)%20and%20the%20full%20screen%20mode%20is%20not%20working...%20Am%20I%20the%20only%20one%20getting%20such%20wrong%20result%3F%3C%2FP%3E%0A%3CP%3EThat's%20why%20I%20was%20believing%20a%20dedicated%20web%20part%20could%20fix%20those%20issues.%20If%20not%2C%20is%20there%20any%20way%20to%20fix%20it%3F%3C%2FP%3E%0A%3CP%3EThanks%20for%20your%20help.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-131612%22%20slang%3D%22en-US%22%3ERe%3A%20Stream%20webpart%20for%20Sharepoint%202013%20or%202016%20on-prem%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-131612%22%20slang%3D%22en-US%22%3E%3CP%3EThe%20Stream%20webpart%20is%20really%20just%20a%20small%20wrapper%20for%20our%20Channel%20and%20Video%20embed%20code.%20As%20such%20you%20could%20use%20both%20embed%20codes%20today%20in%20SP%20on-prem.%26nbsp%3BWe%20don't%20have%20any%20plans%20at%20this%20time%20to%20back%20port%20our%20Stream%20webpart%20back%20to%20on-prem.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EYou%20can%20get%20a%20iframe%20embed%20code%20for%20a%20video%20in%20Stream%20via%20%22Share%20%26gt%3B%20Embed.%22%3C%2FP%3E%0A%3CP%3EWe%20don't%20expose%20a%20way%20to%20get%20the%20channel%20embed%20code%20for%20a%20channel%20in%20Stream%20but%20you%20could%20construct%20your%20own%20iFrame%20that%20looks%20just%20like%20the%20one%20used%20by%20the%20SP%20Stream%20webpart%20yourself.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EGet%20the%20channel%20page%20URL%20for%20a%20channel%20and%20insert%20%2Fembed%2F%20into%20that%20URL%20so%20it%20looks%20like%20this...%3C%2FP%3E%0A%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fweb.microsoftstream.com%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fweb.microsoftstream.com%3C%2FA%3E%3CSTRONG%3E%2Fembed%2F%3C%2FSTRONG%3Echannel%2F35b06fbc-3d7c-4869-a218-200e9baf7999%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EThen%20set%20that%20URL%20with%20%2Fembed%2F%20in%20it%20into%20the%20SRC%20of%20an%20iFrame.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Occasional Contributor

Hi everyone,

Is there any update regarding the availability of a Stream webpart running on on-prem Sharepoint 2013 or 2016 ?

Thanks.

8 Replies
Highlighted

The Stream webpart is really just a small wrapper for our Channel and Video embed code. As such you could use both embed codes today in SP on-prem. We don't have any plans at this time to back port our Stream webpart back to on-prem.

 

You can get a iframe embed code for a video in Stream via "Share > Embed."

We don't expose a way to get the channel embed code for a channel in Stream but you could construct your own iFrame that looks just like the one used by the SP Stream webpart yourself.

 

Get the channel page URL for a channel and insert /embed/ into that URL so it looks like this...

https://web.microsoftstream.com/embed/channel/35b06fbc-3d7c-4869-a218-200e9baf7999

 

Then set that URL with /embed/ in it into the SRC of an iFrame.

 

 

Highlighted

Thanks for your answer Marc.

Actually I already tried to embed some Stream videos into our on-prem SP thanks to the iFrame. However I'm getting weird behaviors: there are some graphical disposition issues of the video control icons (please see attached screenshot, issues are highlighted in magenta) and the full screen mode is not working... Am I the only one getting such wrong result?

That's why I was believing a dedicated web part could fix those issues. If not, is there any way to fix it?

Thanks for your help.

Highlighted
Best Response confirmed by Jean-Philippe Grange (Occasional Contributor)
Solution

The screenshot you attached is a bug we have already fixed but didn't deploy yet. It was an issue with how our embed renders on IE when the page forces IE10 document mode (which SP pages do).

 

The fix should be headed out to Production in our next round of releases which happen every few weeks or so.

Highlighted

Adding the answer to your other issue about Full screen.

 

Since your page is in IE10 document mode (SP sets that in the page header), full screen on any iframe is not supported. Support for taking iframes full screen is in IE11 document mode and beyond only. This is a limitation of the older render engine of IE10 mode.

Highlighted
Many thanks Marc for this explanation and the previous one.
Highlighted

Just to confirm that Stream on our tenant (Europe) has been updated the last week-end to version 1.0.930.10 and, as announced by @Marc Mroz, it fixed the embed Stream video issues on both our on-prem SP 2013 and SP 2016!

Thanks a lot. 

Highlighted

@Marc Mroz I know the issue from 2017 was fixed, however I have an issue happening now. SP2013, running on IE11 and the embedded Stream video does not show (actually nothing shows in that space), but the same SP2013 site brought up in Chrome works just fine.  I did a bit of research and someone said to add the MS Stream URL to our trusted sites in IE......?

Highlighted

@Mary Marasco  - Hi Mary. Did you get any resolution on this issue?

 

@Marc Mroz  - Marc, are you able to help with this at all? On a 2013 SP team site, the embed code only seems to work in Chrome and not IE11. Do you know if a fix will be applied?

 

James