Problems embeding and linking videos in a SharePoint 2013 site

%3CLINGO-SUB%20id%3D%22lingo-sub-94178%22%20slang%3D%22en-US%22%3EProblems%20embeding%20and%20linking%20videos%20in%20a%20SharePoint%202013%20site%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-94178%22%20slang%3D%22en-US%22%3E%3CP%3EI%20am%20currently%20testing%20Stream%20as%20a%20replacement%20for%20our%20on-prem%20video%20portal%20based%20on%20SharePoint%202013.%20I%20want%20to%20show%20videos%20from%20Stream%20either%20by%20using%20a%26nbsp%3Blink%20or%20embedded%20in%20a%20page%20on%26nbsp%3Bour%20SharePoint%202013%20intranet%2C%20but%20it%20doesn't%20work.%20If%20I%20use%20a%20link%20and%20insert%20it%20(using%20Video%26nbsp%3Band%20Audio%26nbsp%3B-%26gt%3B%20From%20Address)%2C%20I%20get%20en%20error%3A%20%22Media%20failed%20to%20load%22.%20If%20I%20try%20to%20embed%20the%20video%20(using%20Video%26nbsp%3Band%20Audio%20-%26gt%3B%20Embed)%2C%20the%20full%20screen%20function%20doesn't%20work%20(but%20the%20video%20plays%20ok).%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAny%20suggestions%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-96032%22%20slang%3D%22en-US%22%3ERe%3A%20Problems%20embeding%20and%20linking%20videos%20in%20a%20SharePoint%202013%20site%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-96032%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20Amit%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAs%20I%20wrote%2C%20%26nbsp%3BI%20want%20to%20show%20videos%20from%20Stream%20either%20by%20using%20a%26nbsp%3Blink%20or%20embedded%20in%20a%20page%20on%26nbsp%3Bour%20%3CU%3ESharePoint%202013%20intranet.%3C%2FU%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%26nbsp%3Bdon't%20know%20if%20full%20screen%20videos%20has%20been%20disabled%2C%20but%20if%20will%20ask%20around.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHer%20is%20a%20sample%20embed%20code%3A%3C%2FP%3E%3CPRE%3E%26lt%3Biframe%20width%3D%22640%22%20height%3D%22360%22%20src%3D%22https%3A%2F%2Fweb.microsoftstream.com%2Fembed%2Fvideo%2F18ac0742-9477-43a5-a93d-9c4af1301bc8%3Fautoplay%3Dfalse%22%20frameborder%3D%220%22%20allowfullscreen%20%26gt%3B%26lt%3B%2Fiframe%26gt%3B%3C%2FPRE%3E%3CP%3E%2FJakob%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-95981%22%20slang%3D%22en-US%22%3ERe%3A%20Problems%20embeding%20and%20linking%20videos%20in%20a%20SharePoint%202013%20site%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-95981%22%20slang%3D%22en-US%22%3E%3CP%3EHi%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F28745%22%20target%3D%22_blank%22%3E%40Jakob%20Rohde%3C%2FA%3E.%20For%20SharePoint%2C%20there%20are%20two%20ways%20you%20can%20embed%20videos%20from%20Stream%20into%20SharePoint%20-%20and%20that%20depends%26nbsp%3B%20on%20the%20version%20of%20SharePoint.%26nbsp%3B%20You%20can%20use%20either%20the%20embed%20code%20directly%20or%20use%20the%20Microsoft%20Stream%20webpart%20directly%20(if%20you%20are%20using%20SharePoint%20Online).%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3ECan%20you%20confirm%20if%20you%20are%20using%20SharePoint%20online%20or%20on-premises%3F%26nbsp%3B%20It%20is%20possible%20that%20something%20is%20missing%20in%20the%20on-premises%20cases%20which%20would%20help%20us%20to%20figure%20out.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EAddiitonally%2C%20it%20would%20help%20if%20you%20can%20share%20the%20embed%20code%20you%20are%20pasting%20into%20SharePoint.%20It's%20possible%20that%20the%20version%20of%20SharePoint%20you%20are%20using%20is%20blocking%20the%20fullscreen.%20Can%20you%20also%20open%20up%20the%20browser%20console%20(by%20hitting%20F12)%20then%20selecting%20the%20fullscreen%20button%20when%20the%20console%20is%20open%20to%20see%20if%20there%20are%20any%20errors.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-95905%22%20slang%3D%22en-US%22%3ERe%3A%20Problems%20embeding%20and%20linking%20videos%20in%20a%20SharePoint%202013%20site%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-95905%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%20can%20you%20explain%20your%20setup%20a%20little%20more%3F%26nbsp%3B%3C%2FP%3E%0A%3CUL%3E%0A%3CLI%3EIs%20your%20SharePoint%20on-prem%3F%3C%2FLI%3E%0A%3CLI%3EAre%20you%20able%20to%20capture%20the%20network%20trace%20and%20send%20it%20to%20us%3F%3C%2FLI%3E%0A%3C%2FUL%3E%0A%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F43541%22%20target%3D%22_blank%22%3E%40Amit%20Rajput%3C%2FA%3E%26nbsp%3B-%20anything%20else%20we%20need%20to%20understand%20this%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E
Frequent Contributor

I am currently testing Stream as a replacement for our on-prem video portal based on SharePoint 2013. I want to show videos from Stream either by using a link or embedded in a page on our SharePoint 2013 intranet, but it doesn't work. If I use a link and insert it (using Video and Audio -> From Address), I get en error: "Media failed to load". If I try to embed the video (using Video and Audio -> Embed), the full screen function doesn't work (but the video plays ok).

 

Any suggestions?

3 Replies

Hi, can you explain your setup a little more? 

  • Is your SharePoint on-prem?
  • Are you able to capture the network trace and send it to us?

@Amit Rajput - anything else we need to understand this?

Hi @Jakob Rohde. For SharePoint, there are two ways you can embed videos from Stream into SharePoint - and that depends  on the version of SharePoint.  You can use either the embed code directly or use the Microsoft Stream webpart directly (if you are using SharePoint Online). 

 

Can you confirm if you are using SharePoint online or on-premises?  It is possible that something is missing in the on-premises cases which would help us to figure out.

 

Addiitonally, it would help if you can share the embed code you are pasting into SharePoint. It's possible that the version of SharePoint you are using is blocking the fullscreen. Can you also open up the browser console (by hitting F12) then selecting the fullscreen button when the console is open to see if there are any errors.

 

Hi Amit

 

As I wrote,  I want to show videos from Stream either by using a link or embedded in a page on our SharePoint 2013 intranet.

 

I don't know if full screen videos has been disabled, but if will ask around.

 

Her is a sample embed code:

<iframe width="640" height="360" src="https://web.microsoftstream.com/embed/video/18ac0742-9477-43a5-a93d-9c4af1301bc8?autoplay=false" frameborder="0" allowfullscreen ></iframe>

/Jakob