MS stream error in the HTTpV2 framing layer.

Highlighted
Regular Contributor

Hi guys,

I have installed latest OMS agent on Debian 10.
When I have tried to configure custom log collection - configuration has been completed successfully, however data collection is failing.

As I can see - there is a connectivity error:

root@mrvserversmall:/opt/microsoft/omsconfig/Scripts# runuser -l omsagent -c /opt/microsoft/omsconfig/Scripts/PerformRequiredConfigurationChecks.py
Opened the dsc host lock file at the path '/opt/dsc/dsc_host_lock'
Error occured during operation PerformRequiredConfigurationChecks. r = 1
{
"ErrorType": null,
"OtherErrorType": null,
"OwningEntity": "OMI:CIMOM",
"MessageID": "OMI:MI_Result:1",
"Message": "cURL failed to perform on this base url: we-agentservice-prod-1.azure-automation.net with this error message: Stream error in the HTTP/2 framing layer. Make sure cURL and SSL libraries are up to date.",
"MessageArguments": [],
"PerceivedSeverity": 7,
"ProbableCause": 0,
"ProbableCauseDescription": "Unknown",
"RecommendedActions": null,
"ErrorSource": null,
"ErrorSourceFormat": null,
"OtherErrorSourceFormat": null,
"CIMStatusCode": 1,
"CIMStatusCodeDescription": null,
"OMI_Code": 1,
"OMI_Category": 0,
"OMI_Type": "MI",
"OMI_ErrorMessage": "A general error occurred, not covered by a more specific error code."
}
Operation failed.

Error occured during operation PerformRequiredConfigurationChecks. r = 1
{
"ErrorType": null,
"OtherErrorType": null,
"OwningEntity": "OMI:CIMOM",
"MessageID": "OMI:MI_Result:1",
"Message": "cURL failed to perform on this base url: we-agentservice-prod-1.azure-automation.net with this error message: Stream error in the HTTP/2 framing layer. Make sure cURL and SSL libraries are up to date.",
"MessageArguments": [],
"PerceivedSeverity": 7,
"ProbableCause": 0,
"ProbableCauseDescription": "Unknown",
"RecommendedActions": null,
"ErrorSource": null,
"ErrorSourceFormat": null,
"OtherErrorSourceFormat": null,
"CIMStatusCode": 1,
"CIMStatusCodeDescription": null,
"OMI_Code": 1,
"OMI_Category": 0,
"OMI_Type": "MI",
"OMI_ErrorMessage": "A general error occurred, not covered by a more specific error code."
}
Operation failed.

I have checked CURL:
libcurl3-gnutls is already the newest version (7.64.0-4).
libcurl4 is already the newest version (7.64.0-4).

also:
l:~# ls -la /opt/omi/lib/libcurl.so*
lrwxrwxrwx 1 root root 34 Oct 13 21:37 /opt/omi/lib/libcurl.so.3 -> /lib/x86_64-linux-gnu/libcurl.so.4
lrwxrwxrwx 1 root root 34 Oct 13 21:37 /opt/omi/lib/libcurl.so.4 -> /lib/x86_64-linux-gnu/libcurl.so.4

 

Can anyone help me how to solve this?

Regards,
Lewis

1 Reply
Highlighted

@Lewis-H - Does this have anything to do with Microsoft Stream (our enterprise video solution)? Or did you accidentally post this in the wrong forum?