MS Stream Embeds in modern SharePoint pages requires log in or routes to stream in mobile

%3CLINGO-SUB%20id%3D%22lingo-sub-1042469%22%20slang%3D%22en-US%22%3EMS%20Stream%20Embeds%20in%20modern%20SharePoint%20pages%20requires%20log%20in%20or%20routes%20to%20stream%20in%20mobile%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1042469%22%20slang%3D%22en-US%22%3E%3CP%3EWhen%20using%20the%20MS%20Stream%20embed%20in%20modern%20pages%2C%20the%20video%20will%20render%20as%20preview%20box%20requiring%20additional%20user%20authentication%20by%20opening%20the%20video%20in%20MS%20Stream.%3C%2FP%3E%3CP%3EI%20tested%20a%20workaround%20including%26nbsp%3B%20'%3F%3CSPAN%3Edomain_hint%3Dyourdomain'%20in%20the%20URL%2C%20but%20this%20renders%20the%20video%20as%20black%20box%20with%20play%20icon%20which%20then%20opens%20in%20MS%20Stream%20without%20additional%20authentication.%26nbsp%3B%20This%20happens%20for%20both%20SharePoint%20App%20and%20in%20mobile%20browser.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EIdeally%20we%20would%20like%20the%20mobile%20user%20(iOS)%20to%20share%20the%20same%20experience%20the%20desktop%20user%20gets%20when%20viewing%20the%20video%20embedded%20in%20a%20page.%26nbsp%3B%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3EI%20looked%20through%20various%20older%20posts%20on%20similar%20issues%2C%20is%20there%20a%20known%20cause%2F%20resolution%20that%20I%20overlooked%3F%26nbsp%3B%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1042469%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EMS%20Stream%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EMS%20Stream%20Authentication%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EMS%20Stream%20embed%20mobile%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
Occasional Contributor

When using the MS Stream embed in modern pages, the video will render as preview box requiring additional user authentication by opening the video in MS Stream.

I tested a workaround including  '?domain_hint=yourdomain' in the URL, but this renders the video as black box with play icon which then opens in MS Stream without additional authentication.  This happens for both SharePoint App and in mobile browser.

 

Ideally we would like the mobile user (iOS) to share the same experience the desktop user gets when viewing the video embedded in a page. 

I looked through various older posts on similar issues, is there a known cause/ resolution that I overlooked? 

1 Reply

@VictaulicKatK - If you use the Stream webpart (not Embed webpart) then that has the best experience in SP Mobile (and web) we could do at the time. In the Stream webpart we try and pass tokens from Stream to SP directly. However that doesn't happen with the embed webpart for a Stream iFrame.

 

On iOS in SP mobile using the Stream webpart you'll see a box saying if the webpart is a video/channel and a button to open a pop-up to view. 

 

On Android in SP Mobile using the Stream webpart, the video/channel will just render directly on the page as you'd see in web. 

 

This is the best we could figure out with our current architecture and the limitations Apple puts on iFrames. 

 

We are going to be looking at different ways to integrate with SP in 2020 that are built on a different architecture. If that pans out then we might have a better experience all around in the future.