Issue with authorization access for Teams group member to Stream video

New Contributor

Anyone got trouble like my Teams members in the following picture. The problem is they used to access video posted on MS Stream until last week. Now all these video show a warning that they can not access anymore.

2018-03-25.png

14 Replies

We are having the same issue.

 

Starting a few days ago at random some users have been unable to see videos or channels on Stream.

 

Sometimes a user will be unable to see the channel at all and sometimes just a specific video.

 

I have had some success removing the user from the group, then re-adding them. At least that worked yesterday, now today they've lost access again.

@David Nguyễn - From the screen shot it looks like the users are accessing stream videos that are linked/embedded into a OneNote, and then that OneNote is a tab in Teams. Does it work if the users open up the OneNote directly or is it still the same?  Can users go to the linked video directly in Stream does that work? The message says they don't have access, I'm wondering if someone changed the permissions on the video itself?

 

@Jeff Ammons - How are the videos added into Teams in your case? Are they putting the videos in a OneNote which is then a tab in teams like the above example, or are they using the Stream tab direction in teams?

 

@Saili Raje - Can you take a look at this?

@Marc Mroz - The Class Notebook is a default tab when we create a team as class in MS Teams. And for the case in my picture, it used to work well since a year ago (video playing as an embed directly on page). I found out that the trouble come from Stream access control since the video is posted in a private group. This user also a member of that private group so he can watch the video until last week.
One more point is that I'm the owner of that channel and I blocked permission that group members can control my video.

@David Nguyễn and @Jeff Ammons - Do you happen to know if your groups/teams use "hidden membership"? I just talked with one of our on call engineers and there is an open incident related to Stream not being able to recognize the correct membership of a group when hidden membership is enabled for the group. This just started happening since our last deployment. We are actively working on fixing this issue and getting it deployed as fast as we can but it will likely take a few days or so. As a workaround if a member is upgraded to be an owner of the group Stream works correctly.  So sorry for this bug.

Hi, @Marc Mroz.

 

I'm not familiar with hidden membership.

 

In my case I created groups in Teams and added Class Notebooks. Then I create Group Channels in Stream for each group (usually 2-4 channels per group).

 

Once I publish a lecture video, I paste the link into OneNote.

 

This has been working great since back in the fall.

 

Last week I got my first report of a student who couldn't view a video.

 

I've had spotty success removing users from groups and adding them back. Sometimes that works and sometimes it either doesn't work at all or works temporarily.

 

In some cases they can see the channel, just not any videos in it.

 

I've also tried manually adding a student directly to the video itself and sometimes that works.

 

I will try making them owners next.

 

I do have a support ticket open #:7707118.

 

Thanks for your help!

It seems like your issue is related to the Hidden Membership issue we are looking into to fixing. If your organization uses the SDS service to create Teams/Groups automatically for classes, that tool always sets the membership to hidden.

 

Update on Fix: 

It turns out this issue seems harder to fix/address than we thought originally yesterday. The issue is that we change significantly how we sync group membership into Stream (to help improve scale/performance of syncing) and with this change we introduced this problem. We are in discussions with the AAD team inside MS to try and track down the correct way for us to fix this problem. It will likely take us some time to find the right fix and deploy it. So sorry.

@David Nguyễn @Jeff Ammons 

 

Update on Fix:

We are working on a hot fix right now that should be done soon. It will take a few days to fully deploy that hot fix to all regions, but you should have this working again soon. Sorry for our bug.

 

For the hot fix we ended up rolling back to part of the previous behavior to address this issue in the short term and are working on a better longer term fix that still accomplishes the scale/performance improvements we were originally targeting.

@Marc Mroz 
Hi,

 

The issue still persists. It worked fine until last month but now the connection seems to be broken again, and we can't access Stream videos, as well as Forms, from Class Notebook inside the Teams desktop app.

This issue is happening in our tenant as well.  I have users that can see the Stream/Channel just fine, all videos as they are shared with everyone; tenant wide.  When I place the channel into a Teams tab, the issue arrives.  No solution that I can find and no reason the users should not be allowed to see the content.  Is this not a very important issue to consider and try to get fixed asap?  Sure doesn't seem to be based upon the timeline in this thread.  Anyone call into premier support to try and drive a solution out and if so, can you provide us with the details of that conversation?  Support here appears to not really care much about this, unfortunately!

Same issue here, can't access to video in some Teams (i newly joined the Teams to help a student with the same error).

I added 2 others test accounts, and it work fine for them.

I checked the permissions in stream with my admin account, everything looks good, the group have the right permissions.

Do you have  any ideas ?

Maybe linked to the update of teams (we've just received the news features for small groups during a meeting).

 

Thanks a lot

Same here. We create groups in Teams. Then we grant viewing permissions to those groups in Stream. Some group members can access their videos, some cannot. We were waiting several days to allow the permissions to get synced between Teams and Stream.

 

This is really awkward. We send links to people, but we never know if they actually can access their videos. I think we really need a fix here ... Any help? Maybe @ChrisKnowlton?

Good morning Marc, did you ever receive a fix for this? We are finding the same issue whereby some of our students cannot see meeting recordings.. are you able or willing to share some pointers? we also use school data sync and are finding it very difficult to understand why a number of students just get the "hmm it seems you don't have access microsoft stream"

Many thanks for any help you can give.
Hello, Microsoft? Are you there? Knock, knock. Excuse me, but we are posting issues that need your attention here and there hasn't been any response to this thread, by anyone related to Microsoft that I can tell. Why are we posting our issues here if Microsoft is just going to ignore us? Do I really give a rats tukus about a badge here? We need assistance, not badges!