Embedded Sign in does not work

%3CLINGO-SUB%20id%3D%22lingo-sub-192517%22%20slang%3D%22en-US%22%3EEmbedded%20Sign%20in%20does%20not%20work%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-192517%22%20slang%3D%22en-US%22%3E%3CP%3EI%20am%20using%20Stream%20to%20embed%20video%20content%20in%20our%20FreshDesk%20Knowledgebase.%20The%20video%20works%20fine%20for%26nbsp%3Banyone%20who%20is%20already%20signed%20in%20to%20MS%20Stream%2C%20but%20only%20I%20and%20one%20other%20coworker%20are.%20No%20one%20else%20uses%20it.%26nbsp%3B%3CBR%20%2F%3E%3CBR%20%2F%3EThe%20issue%20is%20that%20in%20the%20embedded%20player%2C%20the%20sign-in%20and%20sign-up%20links%20do%20literally%20nothing.%20They%20do%20not%20pop-up%2C%20they%20do%20not%20pop%20out.%20I%20can%20see%20in%20the%20bottom%20left%20of%20my%20browser%20that%20it's%20trying%20to%20pull%20something%20from%20a%20MS%26nbsp%3BStream%20URL%2C%20but%20literally%2C%20nothing%20happens.%26nbsp%3B%3CBR%20%2F%3E%3CBR%20%2F%3E%3C%2FP%3E%3CP%3EAfter%20the%20user%20goes%20directly%20to%20the%20Stream%20site%20and%20signs%20up%2C%20they%20can%20then%20view%20the%20video%20without%20any%20issue.%26nbsp%3B%3CBR%20%2F%3E%3CBR%20%2F%3EWhat's%20the%20point%20of%20having%20a%20%22sign-in%20%2F%20sign-up%22%20link%20if%20it%20doesn't%20work%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-192525%22%20slang%3D%22en-US%22%3ERe%3A%20Embedded%20Sign%20in%20does%20not%20work%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-192525%22%20slang%3D%22en-US%22%3E%3CP%3ESorry%20you%20are%20running%20into%20issues.%20I%20just%20tried%20to%20reproduce%20the%20issue%20on%20a%20test%20tenant%20and%20clicking%20the%20sign%20in%20button%20on%20embed%20pop-up%20the%20sign%20in%20window%20so%20I%20could%20sign%20in%20correctly.%20I'm%20not%20sure%20why%20you%20are%20seeing%20the%20problem%20you%20are%20seeing.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3ECould%20you%20open%20up%20a%20support%20ticket%20so%20we%20can%20help%20get%20fiddler%20traces%20and%20what%20not%20and%20have%20our%20support%20team%20investigate%20further%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-192521%22%20slang%3D%22en-US%22%3ERe%3A%20Embedded%20Sign%20in%20does%20not%20work%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-192521%22%20slang%3D%22en-US%22%3E%3CP%3EChrome%2C%20Chrome%20incognito%2C%20and%20Firefox%20all%20have%20the%20same%20issue%2C%20inside%20the%20intranet%20and%20outside%20the%20intranet.%20All%20Windows%2010.%20Same%20results%20with%20and%20without%20popup%20blockers.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWhen%20I%20used%20Firefox%20(I%20was%20NOT%20signed%20in%20to%20Microsoft%20on%20Firefox)%20I%20got%20the%20same%20result.%20Then%2C%20I%20opened%20a%20new%20FF%20tab%20and%20logged%20into%20MS%20Online.%20When%20I%20went%20back%20to%20my%20tab%20with%20my%20embedded%20Stream%20Video%20on%20it%2C%20it%20was%20no%20longer%20asking%20for%20sign-in.%3CBR%20%2F%3E%3CBR%20%2F%3ESo%20it%20works%20IF%20you%20manage%20to%20already%20be%20signed%20up%2Fsigned%20in%2C%20but%20the%20video%20will%20not%20pop%20out%20a%20window%20or%20box%20for%20you%20to%20sign%20in.%26nbsp%3B%3CBR%20%2F%3E%3CBR%20%2F%3EIt%20doesn't%20seem%20like%20a%20good%20process%20to%20have%20to%20explain%20to%20every%20user%20that%20they%20have%20to%20go%20to%20a%20different%20site%20and%20sign%20in%20before%20any%20videos%20will%20work%20-%20especially%20since%20I%20can't%20see%20a%20way%20to%20get%20to%20MS%20Stream%20from%20the%20embedded%20video.%20You%20just%20have%20to%20know%20where%20to%20go.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-192520%22%20slang%3D%22en-US%22%3ERe%3A%20Embedded%20Sign%20in%20does%20not%20work%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-192520%22%20slang%3D%22en-US%22%3E%3CP%3EWhat%20browser%2FOS%20are%20you%20using%20when%20you%20have%20this%20problem%3F%20Have%20you%20tried%20a%20different%20browser%20and%20see%20if%20has%20the%20same%20problem%3F%20It%20might%20be%20related%20to%20IE%20intranet%20zone%20issues%20if%20you%20are%20using%20IE%20(or%20maybe%20Edge).%20If%20that's%20the%20issue%2C%20see%20this%20other%20thread%3A%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2FMicrosoft-Stream-Forum%2FStream-video-shared-on-Yammer-login-is-required%2Fm-p%2F110074%22%20target%3D%22_blank%22%3Ehttps%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2FMicrosoft-Stream-Forum%2FStream-video-shared-on-Yammer-login-is-required%2Fm-p%2F110074%3C%2FA%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1313984%22%20slang%3D%22en-US%22%3ERe%3A%20Embedded%20Sign%20in%20does%20not%20work%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1313984%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F145951%22%20target%3D%22_blank%22%3E%40Andrew%20Hurley%3C%2FA%3E%26nbsp%3Bdid%20you%20find%20a%20resolution%3F%26nbsp%3B%20I'm%20having%20the%20same%20trouble%2C%20and%20it's%20inconsistent.%26nbsp%3B%20Sometimes%20it%20works%2C%20sometimes%20it%20doesn't.%26nbsp%3B%20It%20makes%20it%20a%20pretty%20useless%20application%20for%20embedding%20videos%20if%20they%20have%20to%20open%20Stream%20in%20another%20window%20first%2C%20eh%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E
New Contributor

I am using Stream to embed video content in our FreshDesk Knowledgebase. The video works fine for anyone who is already signed in to MS Stream, but only I and one other coworker are. No one else uses it. 

The issue is that in the embedded player, the sign-in and sign-up links do literally nothing. They do not pop-up, they do not pop out. I can see in the bottom left of my browser that it's trying to pull something from a MS Stream URL, but literally, nothing happens. 

After the user goes directly to the Stream site and signs up, they can then view the video without any issue. 

What's the point of having a "sign-in / sign-up" link if it doesn't work?

4 Replies

What browser/OS are you using when you have this problem? Have you tried a different browser and see if has the same problem? It might be related to IE intranet zone issues if you are using IE (or maybe Edge). If that's the issue, see this other thread:https://techcommunity.microsoft.com/t5/Microsoft-Stream-Forum/Stream-video-shared-on-Yammer-login-is...

Chrome, Chrome incognito, and Firefox all have the same issue, inside the intranet and outside the intranet. All Windows 10. Same results with and without popup blockers. 

 

When I used Firefox (I was NOT signed in to Microsoft on Firefox) I got the same result. Then, I opened a new FF tab and logged into MS Online. When I went back to my tab with my embedded Stream Video on it, it was no longer asking for sign-in.

So it works IF you manage to already be signed up/signed in, but the video will not pop out a window or box for you to sign in. 

It doesn't seem like a good process to have to explain to every user that they have to go to a different site and sign in before any videos will work - especially since I can't see a way to get to MS Stream from the embedded video. You just have to know where to go.

Sorry you are running into issues. I just tried to reproduce the issue on a test tenant and clicking the sign in button on embed pop-up the sign in window so I could sign in correctly. I'm not sure why you are seeing the problem you are seeing.

 

Could you open up a support ticket so we can help get fiddler traces and what not and have our support team investigate further?

@Andrew Hurley did you find a resolution?  I'm having the same trouble, and it's inconsistent.  Sometimes it works, sometimes it doesn't.  It makes it a pretty useless application for embedding videos if they have to open Stream in another window first, eh?