SOLVED

Chrome: Stream embed only works incognito

%3CLINGO-SUB%20id%3D%22lingo-sub-1466507%22%20slang%3D%22en-US%22%3EChrome%3A%20Stream%20embed%20only%20works%20incognito%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1466507%22%20slang%3D%22en-US%22%3E%3CP%3EWe've%20started%20embedding%20Stream%20videos%20into%20our%20SharePoint%20online%20modern%20sites%20-%20it%20produces%26nbsp%3Ba%20really%20slick%20end%20product.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EOnly%20problem%20is%20that%20most%20of%20our%20users%20use%20Chrome%2C%20and%20these%20videos%20only%20play%20when%20we're%20in%20Chrome's%20incognito%20mode%20or%20in%20Internet%20Explorer.%20The%20error%20our%20users%20get%20is%20%22Expansion%20is%20not%20supported%20on%20'settings%2Cpermissions%2CservicePlans'%22.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWhat%20setting%20do%20I%20have%20to%20change%20in%20Chrome%20to%20get%20these%20things%20to%20play%20in%20non-incognito%20Chrome%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1467034%22%20slang%3D%22en-US%22%3ERe%3A%20Chrome%3A%20Stream%20embed%20only%20works%20incognito%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1467034%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F121378%22%20target%3D%22_blank%22%3E%40Caite%20Stevens%3C%2FA%3E%26nbsp%3B%20Delete%20the%20whole%20browser%20cache%20under%20%22Data%20Protection%20and%20Security%22.%20Close%20all%20browser%20instances%2C%20open%20a%20new%20one%20and%20go%20only%20to%20the%20SharePoint%20site.%20Should%20work%20now.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1467383%22%20slang%3D%22en-US%22%3ERe%3A%20Chrome%3A%20Stream%20embed%20only%20works%20incognito%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1467383%22%20slang%3D%22en-US%22%3E%3CP%3EUnfortunately%20that%20did%20not%20work%20for%20me%20-%20I%20cleared%20the%20cache%2C%20closed%20out%20all%20Chrome%20instances%2C%20reopened%2C%20and%20access%20is%20still%20denied.%20The%20end-user%20sees%20a%20message%20in%20Chrome%20that%20says%2C%20%22The%20channel%20could%20not%20be%20found%22%2C%20but%20if%20they%20visit%20in%20IE%2C%20the%20videos%20pop%20right%20up.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIt%20stinks%2C%20because%20we%20generally%20avoid%20using%20IE%20because%20it's%20slow%20and%20crash-prone.%20Chrome%20is%20so%20much%20more%20stable.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1467458%22%20slang%3D%22en-US%22%3ERe%3A%20Chrome%3A%20Stream%20embed%20only%20works%20incognito%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1467458%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F121378%22%20target%3D%22_blank%22%3E%40Caite%20Stevens%3C%2FA%3ELet%C2%B4s%20start%20from%20the%20beginning.%20I%20use%20Chrome%20in%20Version%2083.0.4103.97%20and%20every%20scenario%20with%20the%20SharePoint%20Stream%20web%20part%20works%20on%20my%20side.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E-%20Can%20the%20user%20play%20the%20video%20directly%20in%20Stream%3F%3C%2FP%3E%3CP%3E-%20What%20source%20do%20you%20use%20in%20the%20Stream%20web%20part%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1467828%22%20slang%3D%22en-US%22%3ERe%3A%20Chrome%3A%20Stream%20embed%20only%20works%20incognito%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1467828%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F15303%22%20target%3D%22_blank%22%3E%40Tomislav%20Karafilov%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHi%20-%20I%20am%20on%20the%20same%20version%20of%20Chrome.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EUser%20can%20play%20the%20video%20directly%20in%20Stream.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIn%20the%20web%20part%2C%20I%20have%20tried%20linking%20directly%20to%20the%20video%20and%20directly%20to%20the%20channel.%20Neither%20works.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1467856%22%20slang%3D%22en-US%22%3ERe%3A%20Chrome%3A%20Stream%20embed%20only%20works%20incognito%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1467856%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F121378%22%20target%3D%22_blank%22%3E%40Caite%20Stevens%3C%2FA%3E%26nbsp%3B%20Did%20you%20give%20the%20embed%20web%20part%20a%20chance%3F%20Go%20in%20Stream%20to%20share%20a%20video%20and%20choose%20the%20embed%20tab.%20Copy%20the%20iframe%20code%20into%20the%20SharePoint%20embed%20web%20part.%20Just%20an%20other%20test.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1469152%22%20slang%3D%22en-US%22%3ERe%3A%20Chrome%3A%20Stream%20embed%20only%20works%20incognito%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1469152%22%20slang%3D%22en-US%22%3E%3CP%3EThis%20worked%20for%20me.%20It%20made%20me%20sign%20in%20a%20second%20time%2C%20but%20the%20videos%20did%20show%20up.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20am%20glad%20to%20have%20this%20option%20-%20hopefully%20Microsoft%20will%20address%20this%20little%20inconvenience.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Ethank%20you!%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1508567%22%20slang%3D%22en-US%22%3ERe%3A%20Chrome%3A%20Stream%20embed%20only%20works%20incognito%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1508567%22%20slang%3D%22en-US%22%3E%3CP%3ESo%20back%20to%20this%20-%20I%20feel%20like%20Stream%20is%20not%20ready%20for%20prime%20time.%20Today%20I'm%20back%20with%20problems%20in%20displaying%20videos%20in%20SharePoint%20online%20sites%20using%20Chrome%2C%20and%20it's%20the%20same%20issue%20whether%20I%20add%20a%20%22Stream%20video%22%20or%20an%20%22Embed%20link%22.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIt%20will%20show%20thumbnails%20of%20every%20video%20I%20have%20no%20problem%2C%20but%20the%20second%20I%20try%20to%20narrow%20it%20down%20to%20a%20specific%20channel%20or%20video%2C%20I%20get%20this%20%22Expansion%20not%20supported%22%20error%20message.%20The%20videos%20generally%20work%20in%20Internet%20Explorer%2C%20but%20we%20hate%20IE%20because%20it's%20slow%20and%20crashes%20a%20lot.%20Why%20Microsoft%20is%20still%20tying%20outdated%20IE%20to%20its%20products%20and%20security%20settings%2C%20I%20have%20no%20idea.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI'm%20at%20the%20point%20where%20I%20feel%20like%20we%20have%20to%20abandon%20Stream%20completely%20because%20it's%20so%20unreliable%20-%20and%20go%20back%20to%20uploading%20videos%20to%20the%20SharePoint%20site%2C%20and%20referencing%20from%20there.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1508966%22%20slang%3D%22en-US%22%3ERe%3A%20Chrome%3A%20Stream%20embed%20only%20works%20incognito%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1508966%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F121378%22%20target%3D%22_blank%22%3E%40Caite%20Stevens%3C%2FA%3ENot%20nice!%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F114%22%20target%3D%22_blank%22%3E%40Marc%20Mroz%3C%2FA%3E%20or%20someone%20from%20the%20Stream%20Team%3A%20Can%20you%20help%20here%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1522469%22%20slang%3D%22en-US%22%3ERe%3A%20Chrome%3A%20Stream%20embed%20only%20works%20incognito%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1522469%22%20slang%3D%22en-US%22%3EI%20am%20also%20having%20the%20same%20problem%20as%20you.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1635634%22%20slang%3D%22en-US%22%3ERe%3A%20Chrome%3A%20Stream%20embed%20only%20works%20incognito%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1635634%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F121378%22%20target%3D%22_blank%22%3E%40Caite%20Stevens%3C%2FA%3E%26nbsp%3BI'm%20also%20getting%20the%20same%20issue%20in%20Chrome%20and%20the%20new%20Chromium-based%20Edge.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ESuper%20frustrating%20as%20we're%20trying%20to%20embed%20Stream%20videos%20into%20our%20user%20guides%20and%20they%20will%20only%20play%20in%20InPrivate%20or%20Incognito%20modes!%20I%20read%20somewhere%20it%20was%20to%20do%20with%20cross-site%20tracking%2C%20I've%20tried%20changing%20settings%2Fgroup%20policy%20around%20these%20options%20but%20to%20no%20avail.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIf%20you%20find%20a%20solution%2C%20please%20let%20us%20know!%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Contributor

We've started embedding Stream videos into our SharePoint online modern sites - it produces a really slick end product.

 

Only problem is that most of our users use Chrome, and these videos only play when we're in Chrome's incognito mode or in Internet Explorer. The error our users get is "Expansion is not supported on 'settings,permissions,servicePlans'".

 

What setting do I have to change in Chrome to get these things to play in non-incognito Chrome?

10 Replies

@Caite Stevens  Delete the whole browser cache under "Data Protection and Security". Close all browser instances, open a new one and go only to the SharePoint site. Should work now.

Unfortunately that did not work for me - I cleared the cache, closed out all Chrome instances, reopened, and access is still denied. The end-user sees a message in Chrome that says, "The channel could not be found", but if they visit in IE, the videos pop right up. 

 

It stinks, because we generally avoid using IE because it's slow and crash-prone. Chrome is so much more stable. 

@Caite StevensLet´s start from the beginning. I use Chrome in Version 83.0.4103.97 and every scenario with the SharePoint Stream web part works on my side.

 

- Can the user play the video directly in Stream?

- What source do you use in the Stream web part?

@Tomislav Karafilov 

 

Hi - I am on the same version of Chrome. 

 

User can play the video directly in Stream. 

 

In the web part, I have tried linking directly to the video and directly to the channel. Neither works. 

best response confirmed by Caite Stevens (Contributor)
Solution

@Caite Stevens  Did you give the embed web part a chance? Go in Stream to share a video and choose the embed tab. Copy the iframe code into the SharePoint embed web part. Just an other test.

This worked for me. It made me sign in a second time, but the videos did show up.

 

I am glad to have this option - hopefully Microsoft will address this little inconvenience. 

 

thank you!

So back to this - I feel like Stream is not ready for prime time. Today I'm back with problems in displaying videos in SharePoint online sites using Chrome, and it's the same issue whether I add a "Stream video" or an "Embed link". 

 

It will show thumbnails of every video I have no problem, but the second I try to narrow it down to a specific channel or video, I get this "Expansion not supported" error message. The videos generally work in Internet Explorer, but we hate IE because it's slow and crashes a lot. Why Microsoft is still tying outdated IE to its products and security settings, I have no idea. 

 

I'm at the point where I feel like we have to abandon Stream completely because it's so unreliable - and go back to uploading videos to the SharePoint site, and referencing from there.

 

 

@Caite StevensNot nice! @Marc Mroz or someone from the Stream Team: Can you help here?

I am also having the same problem as you.

@Caite Stevens I'm also getting the same issue in Chrome and the new Chromium-based Edge.

 

Super frustrating as we're trying to embed Stream videos into our user guides and they will only play in InPrivate or Incognito modes! I read somewhere it was to do with cross-site tracking, I've tried changing settings/group policy around these options but to no avail.

 

If you find a solution, please let us know!