Caption auto-generation not working

%3CLINGO-SUB%20id%3D%22lingo-sub-90369%22%20slang%3D%22en-US%22%3ECaption%20auto-generation%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-90369%22%20slang%3D%22en-US%22%3E%3CP%3EI've%20uploaded%20a%20few%20test%20videos%20in%20the%20past%20and%20they%20have%20all%20been%20captioned%20just%20fine%20however%20after%20uploading%20three%20yesterday%20(in%20English%20with%20clear%20audio)%20no%20captions%20have%20been%20generated.%26nbsp%3B%3C%2FP%3E%3CP%3EThis%20is%20the%20primary%20reason%20we're%20interested%20in%20Stream%20as%20it%20cuts%20down%20on%20a%20time-consuming%20task%20for%20us.%20Faces%20detection%20has%20been%20applied%20and%20%22generate%20captions%22%20is%20ticked%20in%20the%20file%20options.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAnyone%20have%20any%20idea%2C%20or%20is%20there%20anywhere%20that%20any%20errors%20would%20be%20shown%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-94666%22%20slang%3D%22en-US%22%3ERe%3A%20Caption%20auto-generation%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-94666%22%20slang%3D%22en-US%22%3E%3CP%3EUpdate%3A%20turns%20out%20this%20was%20already%20documented%2C%20%26nbsp%3Bbut%20not%20very%20easily%20discoverable.%20%26nbsp%3BWe%20will%20augment%20the%20visibility%20of%20this%20section%20of%20the%20documentation.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EFor%20reference%2C%20it%20can%20be%20found%20under%20%22Considerations%22%20here%3A%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fstream.microsoft.com%2Fen-us%2Fdocumentation%2Fstream-portal-autogenerate-captions%2F%23considerations%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fstream.microsoft.com%2Fen-us%2Fdocumentation%2Fstream-portal-autogenerate-captions%2F%23considerations%3C%2FA%3E%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-93390%22%20slang%3D%22en-US%22%3ERe%3A%20Caption%20auto-generation%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-93390%22%20slang%3D%22en-US%22%3E%3CP%3EApologies%20for%20the%20confusion.%26nbsp%3B%20We%20will%20update%20the%20documentation%20to%20reflect%20our%20current%20coverage.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-93249%22%20slang%3D%22en-US%22%3ERe%3A%20Caption%20auto-generation%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-93249%22%20slang%3D%22en-US%22%3E%3CP%3EThanks%20Adarsh%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIt%20was%20a%20.mov%3C%2FP%3E%3CP%3EI%20think%20this%20highlights%20a%20problem%20though%2C%20there%20is%20little%20to%20no%20documentation%20on%20Stream.%3C%2FP%3E%3CP%3EAm%20I%20missing%20something%20somewhere%20where%20it%20says%20that%20it%20only%20works%20with%20these%20filetypes%3F%20Why%20is%20the%20enable%20auto-caption%20option%20even%20there%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-93128%22%20slang%3D%22en-US%22%3ERe%3A%20Caption%20auto-generation%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-93128%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20everyone%2C%20thanks%20for%20the%20feedback.%26nbsp%3B%3C%2FP%3E%0A%3CP%3ECurrently%20we%20are%20only%26nbsp%3Bable%20to%20process%20captions%20for%20MP4%20files%20and%20WMV%20files.%3C%2FP%3E%0A%3CP%3EGood%20news%20is%20that%20we%20are%20currently%20building%20support%20for%20MOV%20files%20(and%20all%20other%20file%20types).%20%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-92623%22%20slang%3D%22en-US%22%3ERe%3A%20Caption%20auto-generation%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-92623%22%20slang%3D%22en-US%22%3E%3CP%3EI%20have%20a%20.ts%20file%20and%20the%20captioning%20does%20not%20occur%20for%20this%20file%20type%20either.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-92324%22%20slang%3D%22en-US%22%3ERe%3A%20Caption%20auto-generation%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-92324%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20Ivan%2C%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20experienced%20the%20same%20issue%20over%20the%20past%20couple%20of%20weeks%20as%20well.%20For%20some%20reason%2C%20my%20videos%20are%20not%20being%20automatically%26nbsp%3Bcaptioned.%26nbsp%3B%3C%2FP%3E%3CP%3EThanks-%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E*UPDATE*%3C%2FP%3E%3CP%3EI%20went%20back%20to%20some%20older%20videos%20that%20were%20automatically%20transcribed%20and%20discovered%20that%20those%20were%20uploaded%20in%20MP4%20video%20format.%20My%20new%20ones%20that%20are%20not%20working%20are%20MOV.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-92198%22%20slang%3D%22en-US%22%3ERe%3A%20Caption%20auto-generation%20not%20working%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-92198%22%20slang%3D%22en-US%22%3EI'm%20actually%20seeing%20better%20caption%20auto-generation%20recently.%20I%20just%20ran%20a%20couple%20of%20videos%20through%20last%20night%20with%20high%20quality%20(professional)%20audio%2C%20and%20the%20caption%20generation%20was%20really%20good%2C%20except%20for%20the%20technical%20terms%20and%20a%20couple%20of%20spots%20where%20it%20just%20stopped%20generating%20after%20the%20first%20couple%20of%20words%20in%20a%20sentence.%3C%2FLINGO-BODY%3E
Highlighted
New Contributor

I've uploaded a few test videos in the past and they have all been captioned just fine however after uploading three yesterday (in English with clear audio) no captions have been generated. 

This is the primary reason we're interested in Stream as it cuts down on a time-consuming task for us. Faces detection has been applied and "generate captions" is ticked in the file options.

 

Anyone have any idea, or is there anywhere that any errors would be shown?

7 Replies
Highlighted
I'm actually seeing better caption auto-generation recently. I just ran a couple of videos through last night with high quality (professional) audio, and the caption generation was really good, except for the technical terms and a couple of spots where it just stopped generating after the first couple of words in a sentence.
Highlighted

Hi Ivan, 

I have experienced the same issue over the past couple of weeks as well. For some reason, my videos are not being automatically captioned. 

Thanks-

 

*UPDATE*

I went back to some older videos that were automatically transcribed and discovered that those were uploaded in MP4 video format. My new ones that are not working are MOV. 

Highlighted

I have a .ts file and the captioning does not occur for this file type either.

Highlighted

Hi everyone, thanks for the feedback. 

Currently we are only able to process captions for MP4 files and WMV files.

Good news is that we are currently building support for MOV files (and all other file types).  

Highlighted

Thanks Adarsh,

 

It was a .mov

I think this highlights a problem though, there is little to no documentation on Stream.

Am I missing something somewhere where it says that it only works with these filetypes? Why is the enable auto-caption option even there?

Highlighted

Apologies for the confusion.  We will update the documentation to reflect our current coverage.

 

 

Highlighted

Update: turns out this was already documented,  but not very easily discoverable.  We will augment the visibility of this section of the documentation.

 

For reference, it can be found under "Considerations" here: https://stream.microsoft.com/en-us/documentation/stream-portal-autogenerate-captions/#considerations