Videos auto-removed from channel

New Contributor

While the subject is self-explanatory, I will go through the situation:

1. I created a company-wide channel

2. I added 5 videos to the channel

3. I wanted to add tags to the descriptions so I opened the first video from the list of videos in the channel, added a tag and applied the change.

4. Going back to the channel I saw it only had 4 videos. When I located the original video I saw that all permissions were removed, including my own (though I did remain video owner, it just wasn't listed). I added the video to the channel and applied and I was back to 5 videos.

5. I repeated this process in exactly the same way for all 5 videos - 2 behaved as described above, 3 were behaved as expected (i.e. editing change made and video remained in channel).

Is this a bug, and if so where should I report it? Or is there something else at play that I should be aware of? It was easy to notice with 5 videos, but this channel will have hundreds of videos soon.

Just to make clear - while the channel is companywide, users are unaware of it, so it could not have been done by a user. Also, the timing immediately after having edited the video does not seem to point to any user's intervention.

Thank you.

3 Replies

What you have experienced is very extrange!!! This forum is a good option to notify about this possible bug...adding here @Marc Mroz so he can advice best way to report this problem...I think it is also worth to open a support ticket

@Ofra Shai - I'm sorry you are running into an issue. 


I just tried to reproduce the issue myself in an internal environment but wasn't able to do so. Maybe there is something specific you are doing that I didn't replicate or maybe it's browser/OS specific? (I was on Edge + Win 10). 


If you can consistently reproduce this issue could you get a fiddler trace while you are doing it? Also you may want to open up a support ticket with our support team and they might be able to help you narrow down why/how it's happening so we can get logs/traces to better find the issue and fix it.

Thank you for looking into this.

Regretfully I cannot replicate. As I've written - I did the exact same thing for five videos, one after the other. I encountered this issue in two of the five.

The only thing that I can think of that may contribute is that I very often encounter a blank screen or a very very long time getting actions to work (loading videos, search results, getting the edit screen...) - sometimes 3-5 minutes if I am patient enough to wait. Many times I need to refresh in order to get results. I have tried this on a number of computers with both IE and Edge, encountering the same issues, and have had pilot users reporting same. Maybe not everything is uploaded when I make the changes? I am hesitant in raising this because I don't know if this even makes sense, but more so because after the first video lost permissions, for the other four I checked the permission before making the modifications. In all four videos they were correct - yet in one case they were lost on applying of the description-change.

I work in Windows 10, but I do not remember whether I was in IE or in Edge. Our organization uses both and many users are partial to Chrome, so I would like to assume that Stream works in the same way whatever the browser.

My role is to set up Stream for organizational use and "getting the word out" to users. This experience is making me uneasy. I will gladly do whatever I can to help analyze the issue. I will ask our IT to open a support ticket.