Video or channel could not be found

Brass Contributor



we are currently facing an issue with the permissions and video publication.


When I create a channel that is public for all the company - some users have the following error message displayed when click on the shared link: Failed to load the channel. The channel could not be found.


Please note that we double checked that the permission for the channel and even for the video are set correctly.

Do you have any ideas what might be wrong?

Many thanks in advance!

3 Replies
I've not seen that myself, but I'd suggest logging a Service Request so they can see if there's something going on behind the scenes.

@Anna Procházková - Sorry you are running into issues.

You could either file a support request or send me a private message with the following info and I could have one of our engineers take a look.


Go to ? > About Microsoft Stream

Send me your session ID and where Data stored.


Send me channel page URL that is having issues.

Send me a video player page URL that is having issues.

@Marc Mroz 



I too am experiencing the same error on Teams.

I have noticed that if you try and view/download the video soon after it has been recorded all is good. Attempting a few days later and we get the same error:
"Microsoft Stream

The video could not be found"