Using Stream with Mac Safari

Copper Contributor

I uploaded a video to Stream. Video plays back and does everything as expected except that I cannot edit it. I am using Safari on my Mac. When I go to ...More, I choose Edit or any of the other choices in the dropdown, but nothing happens. This is unlike the experience I have using either Firefox or Chrome on the same computer. I have tried this on three different Macs and have the same issue. I have tried checking or unchecking Safari preferences->Security->Allow plugins. Flash is enabled; Java is enabled for I have tried Advanced->Stop plugins to save power. Nothing has any effect on this. Any ideas what is going on?

6 Replies

Same here. It worked fine on Safari on my iphone tho. Desktop safari I couldn't edit or delete videos.

We'll try and reproduce this issue back here at Microsoft and see if we can figure out why Mac + Safari is having issues. What version of Mac are you using? (Just in case it's something specific to the OS version.)

I have tested this with macOS Sierra 10.12.5 (using Safari 10.1.1) and also Yosemite. I have no problem with iOS.

Thanks. We have one of our on-call engineers investigating this issue today.

Thank you for your reply.

I had no trouble wit iOS and cleaned up the page there.

My iMac: 

Safari v10.1.1 (12603.2.4)

iMac: macOS Sierra v 10.12.5


Please let me know if you need anything else.


Thank you




best response confirmed by Vishal Sood (Microsoft)

It works for me now. I don't know what changed, but we're good.