The request is invalid using Stream video in iframe

Copper Contributor

I have a Stream video embedded in an internal intranet site using the Share > Embed iframe generated in Stream when clicking on the Share button.


The internal intranet site is authenticated using Azure AD.


When a user accesses the site on their desktop, the embedded video loads and plays without any problems. When the same page is loaded on a mobile the users are presented with the following.


The request is invalid

Your browser is not configured properly, preventing us from authenticating you. Please contact your administrator.


This is the same across both iOS and Android, have also tried different browsers on the devices too.

11 Replies

Are you using intune managed browser or something like that? I wonder if that's causing that message in some way.

Nope, it's the same on all devices. Have tried it on my own personal phone using Safari, Edge and DuckDuckGo and it's the same message.


If I access Stream directly the videos play fine on mobile, just seems to be when they are in the iFrame in our intranet.

I'm not able to reproduce this myself. My embed from a test environment works fine on Android.


I'm checking with some others on our team to see if they've heard of this issue or know what to look at next. But in parallel, can you work with your O365 Admin to open up a support ticket? Support can help get fiddler/network traces and hopefully track down more of what's going on or what next steps needed.



This same error is consistently returned in our organization when using the combination of IE11 and Windows 7. See this thread in the Power Users forum:


One of my clients is experiencing the same issue. Did you ever get this resolved? I keep finding solutions for Desktop, not mobile.

I have same problem on website PHP (LMS Moodle).
Guys any workarround?
On android work fine. On IOS dont work on all browsers
I've discovered this same issue today using the Stream web part, works fine in Chrome but in Safari the error appears, you can resolve the issue by navigating to the Stream service ( and refreshing the page but its not ideal. Looks like Safari doesn't auto log in via the iFrame, which it does in Chrome.

For Scenarios that don't work only on IOS through Safari: Disable Prevent cross-site tracking on Safari Settings

this did not fix it for me. Using the stream web part on a sharepoint page.

actually it did, just had to clear cookies and cache.