Stream videos require sign in using Teams desktop app

Copper Contributor

Everything was working fine until about a week ago.  We have stream videos on a sharepoint page.  We then have the sharepoint page added to a team in MS Teams.


Everything works fine if using Teams in the browswer, the videos play and all the links work just fine.


However, on the MS Teams desktop app the same page doesn't work.  All the links to stream videos tell us we have to sign in to see the content.  


I am a global admin and have access to all videos and links and it is still a problem.  But again everything works perfect in the Teams in the browswer.


It is like it is not passing the authentication of the person logged in the desktop app through to Stream to show the videos.  I have done research and it appears others have had this issue in 2017 and in 2020(usually teachers) but no one has ever mentioned they resolved it. 


I am sure people have the correct security for it and we can go to sharepoint and view the videos just fine.  Also, if we add the video to the stream app in the teams desktop it works.   It appears to be only when the stream videos are on a sharepoint page and that page has been added to the team that the desktop app has a problem.


Strangely this also seemed to coincide close to the announcement that Microsoft Stream will soon be called Microsoft Stream Classic as they are changing the way stream works all together over the next year.


9 Replies

@Glenn_ScottI have found with authentication issues like this in the desktop app, that problem is usually solved by having the user take the following two steps. If number 1 doesn't work, try number 2.

  1. Sign out of Teams completely (Click on profile pic/initials in top right>Sign out) then quit Teams and restart the app and sign-in again.
  2. Quit the Teams app completely by right clicking on Teams>Quit Teams. Clear the Teams cache by going in Windows Explorer to %AppData%\Microsoft and deleting the Teams folder. Teams will automatically regenerate the folder when the application is restarted. Restart Teams and sign-in.


Thank you, I tried that but it did not work.  I also spun up a new virtual machine with a fresh windows install and teams install and the issue occurs on a brand new setup as well with credentials being used for the first time.


The odd thing is that if I uninstall teams completely and reinstall the videos will show just fine the first time I log back into MS Teams desktop app.  But if I leave the page and come back to it, the videos are back to being inaccessible and it wants me to sign into Stream.  Also, if I click on the link to sign in to stream it just takes me to a blank page and never requests credentials


@Glenn_Scott I have the same issue here. Did you already opened a support ticket at Microsoft?

@millerblair The two options you mention didn't solve the issue.



@Anita Boerboomthanks for the feedback. I haven't opened a support ticket with Microsoft. Perhaps the root cause is different from what users in our tenant were experiencing.

best response confirmed by Glenn_Scott (Copper Contributor)
Someone at the client I'm working for has contacted Microsoft and it seems to be a bug they are working on. No estimates when it is solved.

@Anita Boerboom 


That's what I was afraid of.  Just haven't had time to open a ticket myself.




Based on the information received from MS Support, they are working on the problem, and they estimate to release a fix in July. Unfortunately, I haven't any other details.

Did you have any news about the resolution of this problem?
The error is present on my side but only on mobile?

What was the procedure to fix the problem on your side?
I'm guessing this was a bug on either Stream classic or on teams desktop that was fixed.

For your issue on mobile are you using the stream web part on your SharePoint page that's shown inside teams mobile? If you're using the embed web part try the stream one instead. Also I be this issue wouldn't happen if you started putting your videos directly in SharePoint and used the highlighted content and file viewer web parts.
1 best response

Accepted Solutions
best response confirmed by Glenn_Scott (Copper Contributor)
Someone at the client I'm working for has contacted Microsoft and it seems to be a bug they are working on. No estimates when it is solved.

View solution in original post