Stream cuts off video

Copper Contributor



Has anyone had the issue where after uploading a video, it will cut off a random amount of it?



- Recorded a 2 minute & 30 second video, during processing the video length is correct until it has finished uploading, the final video is only 30 seconds or so.


- Another video was 46 seconds in length, uploaded video cut down to 40 seconds


How do I fix this?

thank you

13 Replies

@keirsmith I'm experiencing the same issue. Have you been able to come up with a solution?

@CodyGober  - Is this happening only if you upload your videos to Stream (Classic)? Does it happen if you upload the same video to SharePoint, OneDrive, or Teams? 


We announced the retirement date of Stream (Classic) so you should start uploading your videos to SharePoint, OneDrive, Teams, or Yammer instead. 


But this issue doesn't sound normal. If you have to keep using Stream (Classic) for a bit longer I would suggest opening a support ticket on this issue. 

Hi @Marc Mroz 


It is happening in both Classic and SharePoint upload. It's been consistent after rebooting, deleting, and overwriting. 

I don't believe we ever fixed this one, since Stream is being retired we just stopped using this platform, sorry!

@CodyGober - Where are the source videos coming from? What tool are you using to make them? What settings are you using to export the videos? 


If you are seeing an issue of playback ending early in both classic and SharePoint/OneDrive that seems to me like the source videos are encoded in some different (or maybe incorrect) way.


Do you have issues playing the videos locally on your computer before upload?

The videos are being created in CreateStudio and exported in standard HD as an .mp4. Local playback shows the full 6:15 minute video with no issues. Other videos created in the same manner have worked flawlessly in the past.

@Marc Mroz I am experiencing the same issue. I've uploaded numerous videos to SharePoint, all encoded the same as the one I'm having this problem with. My 3:12 video stops at 3:05.

Exported from Premere Pro. H.264 1920x1080 29.97fps. No audio.

This video replaced a video that was shorter ( we added a few seconds of content). Since there are links to this video out in the world, I will not be able to delete it and try uploading it again. Replace is my only option.

I created a copy of the mp4 on my computer and uploaded it. The copy worked exactly as it should, the entire movie was uploaded. Tried to replace the video again with the copy that uploaded properly and it cut it off at 3:05. I wonder if the OP was replacing as well. Oddly enough, Both videos are 480Mb


Either way, we plan to use SharePoint to manage our videos, we will need to seek out another option if we cant fix this issue or figure out what I need to do to make sure they upload properly.

So, the issue corrected itself without any intervention on my part. I have a theory, please keep in mind that I was replacing an existing video when this issue started happening.


I uploaded a 3:05 long video. Then updated it and replaced it with a 3:10 long video. After replacing the video would show the new footage but cut off at 3:05. I went home for the day and the next morning I opened the video and it played all the way to 3:10.


My theory: I've noticed a few minute lag when creating and removing folders and files from SharePoint. I believe there is a glitch (or it is just the nature of Sharepoint) that updates the video length after it is uploaded. If there is a lag creating a folder, then there must certainly be one updating the video's details. In short, you just have to give SharePoint time to catch up. I recommend leaving the file alone, check in every once in a while and see if it updates the timeline to allow the full video to play. If it still doesn't, let it go overnight and see what you get in the morning. It still annoys me to no end, but I thought I'd share this for anyone who might stumble on this thread in search of answers.

See my reply to my reply :).... Try waiting a while (I know, not a great answer. But that is the solution in my case.)

18th August 2023 - Stream for SharePoint cutting out after 5 seconds when attempting to record a screen (instructions on error message followed exactly).  Attempts made with Google Chrome and Microsoft Edge.  Cookies and Cache has cleared on both browsers.

Same problem here. Video works as expected on other players and Youtube.
@jbhardman try converting the video to an .MP4 file and see if that fixes it. I'm betting it's another format. So far several people I have recommended this to have done this and it has solved the problem for them.

Same issue here, but I am uploading a bunch of videos from the same PC location to the same folder on OneDrive. Some of them are uploaded correctly, but the others are trimmed off a bit at the end. I have tried deleting, emptying the recycle bin, and reuploading the shortened files. Doesn't help. They are all in .mp4 format. Exported from Microsoft's own ClipChamp. This is so weird and upsetting. Office 365 has too many such bugs that keep recurring!